Home » Infrastructure » Unix » installation error during OID (oracle,10g,HPUX 11.1)
installation error during OID [message #281860] Mon, 19 November 2007 11:24 Go to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
Hi ,iam trying to install OID on hpux 11.1 downloaded the software from OTN and unpack the cpio files first when i used the command it was giving this ouput
cpio -idmv < as_hpux_oim_oif_101401_disk1.cpio
Out of phase--get help
Perhaps the "-c" option should be used
then i used
cpio -cidmv < as_hpux_oim_oif_101401_disk1.cpio and it got unpack,but i am getting the below error when i ran the runinstaller,any suggestions.


Preparing to launch Oracle Universal Installer from /tmp/OraInstall2007-11-19_04-52-56PM. Please wait .../tmp/OraInstall2007-11-19_04-52-56PM/jre/1.4.2/bin/PA_RISC2.0/tnameserv bad CRC 237977cc (should be 1fd80b3d)
/tmp/OraInstall2007-11-19_04-52-56PM/jre/1.4.2/bin/PA_RISC2.0W/policytool bad CRC 50ab95cb (should be 5a0cbccd)
/tmp/OraInstall2007-11-19_04-52-56PM/jre/1.4.2/lib/PA_RISC/hotspot/libjvm.sl bad CRC 921c1ea0 (should be 633e2fa1)
/tmp/OraInstall2007-11-19_04-52-56PM/jre/1.4.2/lib/PA_RISC/libawt.sl bad CRC c3fdac04 (should be f6688fdd)
/tmp/OraInstall2007-11-19_04-52-56PM/jre/1.4.2/lib/PA_RISC/server/libjvm.sl bad CRC 7f3b2520 (should be 633e2fa1)
/tmp/OraInstall2007-11-19_04-52-56PM/jre/1.4.2/bin/PA_RISC2.0W/policytool bad RC 50ab95cb (should be 5a0cbccd))
/tmp/OraInstall2007-11-19_04-52-56PM/jre/1.4.2/bin/PA_RISC2.0W/policytool bad CRC 50ab95cb (should be 5a0cbccd)
Re: installation error during OID [message #281999 is a reply to message #281860] Tue, 20 November 2007 05:48 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Did you verify the checksum of the file after you downloaded it?
Re: installation error during OID [message #282033 is a reply to message #281860] Tue, 20 November 2007 08:49 Go to previous messageGo to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
software downloaded was corrupt so had to download again .

Thanks
Re: installation error during OID [message #282050 is a reply to message #281860] Tue, 20 November 2007 12:14 Go to previous messageGo to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
My oracle context is
cn=oraclecontext,dc=panther,dc=com
after changing ldap.ora to

DIRECTORY_SERVERS=(panther.am.kwe.com:389:636)
DEFAULT_ADMIN_CONTEXT="dc=panther,dc=com"
DIRECTORY_SERVER_TYPE=oid

C:\Documents and Settings\sali>tnsping dbtest1

TNS Ping Utility for 32-bit Windows: Version 9.2.0.1.0 - Production on 20-NOV-20
07 11:46:35

Copyright (c) 1997 Oracle Corporation. All rights reserved.

Used parameter files:
c:\oracle\ora92\network\admin\sqlnet.ora

Used LDAP adapter to resolve the alias
Attempting to contact (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=pa
nther)(PORT=1533)))(CONNECT_DATA=(SID=dbtest1)))
TNS-12545: Connect failed because target host or object does not exist

is this because the /etc/hosts file doesn't have fully qualified domain name?

127.0.0.1 localhost loopback
#10.0.4.24 panther panther.am.kwe.com panther.kwe.com
10.0.4.24 panther

Re: installation error during OID [message #282102 is a reply to message #282050] Tue, 20 November 2007 20:51 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
You should be consistent with FQDN in your config files.

Is your LDAP server on the same node from where you are trying to tnsping? If not, can you simply ping panther from the node where your LDAP server is located?
Re: installation error during OID [message #282354 is a reply to message #281860] Wed, 21 November 2007 12:02 Go to previous messageGo to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
ThanksI resolved the issue,i put full qualified domain name in /etc/hosts file and when putting tns entries into LDAP server had to give full hostname.

C:\Documents and Settings\sali>tnsping dbtest1

TNS Ping Utility for 32-bit Windows: Version 9.2.0.1.0 - Production on 21-NOV-20
07 11:31:56

Copyright (c) 1997 Oracle Corporation. All rights reserved.

Used parameter files:
c:\oracle\ora92\network\admin\sqlnet.ora

Used LDAP adapter to resolve the alias
Attempting to contact (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=pa
nther.am.kwe.com)(PORT=1533)))(CONNECT_DATA=(SID=dbtest1)))
OK (20 msec).

Re: installation error during OID [message #282359 is a reply to message #281860] Wed, 21 November 2007 12:13 Go to previous messageGo to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
How to check that the Oracle Net Manager has entered our connection information into the directory is there any command line tool or a table to query within the repository?

Thanks
Re: installation error during OID [message #282365 is a reply to message #282359] Wed, 21 November 2007 12:40 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
monto wrote on Wed, 21 November 2007 13:02

ThanksI resolved the issue,i put full qualified domain name in /etc/hosts file and when putting tns entries into LDAP server had to give full hostname.


Thanks for the feedback.

monto wrote on Wed, 21 November 2007 13:13

How to check that the Oracle Net Manager has entered our connection information into the directory is there any command line tool or a table to query within the repository?

Have you tried the oidadmin tool?
Re: installation error during OID [message #282373 is a reply to message #282365] Wed, 21 November 2007 13:31 Go to previous messageGo to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
i can't find oidadmin tool in bin?what is the location or where
can i find this utility?
Re: installation error during OID [message #282379 is a reply to message #281860] Wed, 21 November 2007 14:14 Go to previous messageGo to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
Thanks ebrian i got it .
Re: installation error during OID [message #283626 is a reply to message #281860] Tue, 27 November 2007 14:38 Go to previous messageGo to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
Is there a licencing issue for making use of advance replication for OID for high availabity?
Re: installation error during OID [message #283659 is a reply to message #283626] Tue, 27 November 2007 21:23 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
I honestly don't know. We actually have load balancers and custom code to replicate amongst our OID sites.

You may want to check with your Oracle sales consultant for licensing.
Re: installation error during OID [message #284746 is a reply to message #281860] Fri, 30 November 2007 15:41 Go to previous messageGo to next message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
This is the error that i am getting during installtion of oracle internet directory(OID)
10g on HPUX-11.1

error in invoking target 'mkldflags' of makefile
'/amoidts1/OID/network/lib/ins_net_client.mk' see '/oracle/oraInventory/log/installActions2007-11-30_06-31-58PM.log' for details

$ /amoidts1/OID/install
vi make.log
/usr/ccs/bin/make -f ins_net_client.mk mkldflags ORACLE_HOME=/amoidts1/OID//usr/ccs/bin/make -f ins_net_client.mk mkldflags ORACLE_HOME=/amoidts1/OID/

once i installed OID sucessfully on this box then i had to remove it and again when i am trying to install i am getting .

$ uname -a
HP-UX panther B.11.11 U 9000/800 3949786300 unlimited-user license

export ORACLE_HOME=/amoidts1/OID

export LD_LIBRARY_PATH=$ORACLE_HOME/lib64:/usr/lib

export SHLIB_PATH=$ORACLE_HOME/lib64:/usr/lib

export PATH=/usr/css/bin:$ORACLE_HOME:$PATH:.

$ umask
022

Not sure what is going wrong?
Re: installation error during OID [message #284747 is a reply to message #284746] Fri, 30 November 2007 16:12 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
If you are saying that you had it successfully installed once, they I'd say to ensure that you have COMPLETELY removed the remnants of the old install and ensure that the proper environment variables are either set or unset correctly prior to installing.

By the way, please start a new thread in the Application Server forum for any continuing problems.
Re: installation error during OID [message #284749 is a reply to message #281860] Fri, 30 November 2007 16:15 Go to previous message
monto
Messages: 60
Registered: November 2007
Location: DALLAS
Member
Thanks ebrian i resolved it by setting proper environment for oracle .
Previous Topic: Unable to capture pl/sql dbms_output using shell script while running it through browser
Next Topic: How I can make ANSI printer on Oracle 7.1.6 for SCO UNIX
Goto Forum:
  


Current Time: Wed Apr 16 22:56:41 CDT 2014

Total time taken to generate the page: 0.07901 seconds