Home » RDBMS Server » Networking and Gateways » Domain Connectivity Issue
icon8.gif  Domain Connectivity Issue [message #280484] Tue, 13 November 2007 18:05 Go to next message
grahambo
Messages: 9
Registered: November 2006
Junior Member
Hi All

Im having an issue accessing a Database.

I am running an oracle 9i database on a windows 2000 server Machine which is a member of a domain.

I wish to access that database on this machine using a web application (hosted on IIS) which is running from a Windows XP professional Machine that is not part of the domain.

I keep getting an error saying cannot connect to database.

Strange part is I have installed the oracle 9i client and can access the database using the "test login" option.

I know if I add the XP mahine to the Domain it will be able to access the Database fine, so I'm assuming this has something to do with permissions. can you explain to me exactly what to do to get around this?

Cheers

Graham
Re: Domain Connectivity Issue [message #280485 is a reply to message #280484] Tue, 13 November 2007 18:17 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
>I know if I add the XP mahine to the Domain it will be able to access the Database fine
Have you actually added this system to the domain & verified that the web application successfully access the Oracle DB?

See, I have serious doubts you claim reflects reality.
In some/many/most cases, an "Application Server" sits between the web server (Apache, IIS, etc) & Oracle RDBMS.

Based upon what you've posted, I wonder exactly how IIS is supposed to inter-operate with the Oracle DB.
Re: Domain Connectivity Issue [message #280603 is a reply to message #280485] Wed, 14 November 2007 03:44 Go to previous messageGo to next message
grahambo
Messages: 9
Registered: November 2006
Junior Member
ok IIS has been installed on the XP machine and the website is running on it.

so I go http://localhost/mysite to access the web site which is being hosted on the XP machine

I should have made it clearer sorry, I am using this machine for testing purposes.

So to sum up the IIS webserver is not on our domain but the database is. My web application cannot access it. however I can test the connection in net manager on the which is hosting the wesite and it works ok with correct user name and password.

[Updated on: Wed, 14 November 2007 04:01]

Report message to a moderator

Re: Domain Connectivity Issue [message #280604 is a reply to message #280603] Wed, 14 November 2007 04:00 Go to previous message
grahambo
Messages: 9
Registered: November 2006
Junior Member
Solution

in the sqlnet.ora file I commented out

Names.Default_Domain = mydomain

the web app was then able to connect to the DB. dont ask me why this worked, I have no idea. prehaps someone could enlighten me. my earlier post of an in correct connection string turned out to be incorrect.

Graham

[Updated on: Wed, 14 November 2007 09:23]

Report message to a moderator

Previous Topic: the advantage of tnsnames.ora
Next Topic: not able to access thro db link
Goto Forum:
  


Current Time: Thu Dec 08 18:24:33 CST 2016

Total time taken to generate the page: 0.09635 seconds