Home » Developer & Programmer » Reports & Discoverer » Report generated in .txt format but some problems
Report generated in .txt format but some problems [message #277218] Mon, 29 October 2007 04:45 Go to next message
sasipalarivattom
Messages: 118
Registered: June 2007
Location: Cochin ( INDIA )
Senior Member

Hi......

I created a report which is geneated in .txt format.
What I do for this is
1.First I change the system parameter mode to character in the report.
2.Then I place a button in my form to call the report.
code in the button is as follows..



DECLARE
rePid REPORT_OBJECT;
rep_hndl VARCHAR2(100);
BEGIN
rePid := Find_Report_Object('reptxt.rdf');

Set_Report_Object_Property(rePid,Report_deStype,FILE);

Set_Report_Object_Property(rePid,Report_FileName,'d:\sasi\reports\reptxt.rdf');

Set_Report_Object_Property(rePid,Report_desName,'d:\sasi\output\repprint.txt');

rep_hndl := Run_Report_Object(rePid);
END;
and it is working..
Now the problam is that when I preview the report from the
report builder, it is in the format I needed.
But when I run the form and run the report,Its alligment is not correct.
I shall attach the notepad as reply for this post,Because I have to attach two files.

thanks in advance and sorry for the inconvenience due to 2 attachmets...

Please reply if u didn't get me...

[Updated on: Tue, 30 October 2007 00:26]

Report message to a moderator

Re: Report generated in .txt format but some problems [message #277221 is a reply to message #277218] Mon, 29 October 2007 04:48 Go to previous messageGo to next message
sasipalarivattom
Messages: 118
Registered: June 2007
Location: Cochin ( INDIA )
Senior Member

First attachment,
Format in which report should generate.
(Through the report previewer,the same format is generated.)
Re: Report generated in .txt format but some problems [message #277223 is a reply to message #277218] Mon, 29 October 2007 04:53 Go to previous messageGo to next message
sasipalarivattom
Messages: 118
Registered: June 2007
Location: Cochin ( INDIA )
Senior Member

Second attachment
This is the format in which the report is saved when I generate the report through the form.
  • Attachment: output.txt
    (Size: 41.80KB, Downloaded 366 times)
Re: Report generated in .txt format but some problems [message #279563 is a reply to message #277223] Fri, 09 November 2007 01:10 Go to previous messageGo to next message
sasipalarivattom
Messages: 118
Registered: June 2007
Location: Cochin ( INDIA )
Senior Member


SOMEBODY PLEASE HELP ME......

[Updated on: Fri, 09 November 2007 01:12]

Report message to a moderator

Re: Report generated in .txt format but some problems [message #279594 is a reply to message #279563] Fri, 09 November 2007 04:51 Go to previous messageGo to next message
Soumen Kamilya
Messages: 128
Registered: August 2007
Location: Kolkata
Senior Member

Humm..What I found here is while you generating report output through forms it breaks after 80 character.
Now you have to set the report property as 212 character so that it couldnot break after 80 character.

Cheers
Soumen
Re: Report generated in .txt format but some problems [message #303334 is a reply to message #277218] Thu, 28 February 2008 23:10 Go to previous messageGo to next message
bhagawandotcom
Messages: 2
Registered: September 2007
Junior Member
Hi

While transfering report to text,I didn't get output.My code is

DECLARE
rePid REPORT_OBJECT;
rep_hndl VARCHAR2(100);
BEGIN
rePid := Find_Report_Object('REP_QTY');
Set_Report_Object_Property(rePid,Report_deStype,FILE);
Set_Report_Object_Property(rePid,Report_FileName,'D:\DOR\reportsnew\DAR_QUANTITY_ESTIMATION_DTL.rdf');
Set_Report_Object_Property(rePid,Report_desName,'D:\DOR\output\repprint.txt');
rep_hndl := Run_Report_Object(rePid);

END;

So,Plz help me.
icon3.gif  Re: Report generated in .txt format but some problems [message #303506 is a reply to message #277218] Fri, 29 February 2008 10:53 Go to previous message
doss_arun
Messages: 10
Registered: February 2008
Location: iselin, new jersey
Junior Member

hi,

i have worked on this report in my previous company, my juniors also faced this probs.. u check the DESFORMAT SYSTEM PARAMETER based on the prt file. its problem. when u running the report alone its generation based on the right desformmat. but its not pick the right value when u run from form.


i remember my old thought, when i saw this sample text. like a bl no container no, packages.....

use the SRW.MESSAGE to find the problem.


by:->

arun
Previous Topic: Description of Report Parameter Form
Next Topic: connection error
Goto Forum:
  


Current Time: Thu Dec 08 14:06:38 CST 2016

Total time taken to generate the page: 0.17215 seconds