Home » RDBMS Server » Enterprise Manager » RMAN does not work from OEM
RMAN does not work from OEM [message #275829] Mon, 22 October 2007 20:35 Go to next message
stevenfoo
Messages: 10
Registered: October 2007
Junior Member
Hi All,

Platform: windows server 2003, oracle 10.2.0.3

I have been scheduling RMAN backup from OEM without problem until recently we upgrade to 10.2.0.3 from 10.2.0.2.

Running RMAN backup from the command prompt is fine.

When I schedule the RMAN backup (Maintenance=>Schedule Backup),
the RMAN ended with status Problems at the job overview.
I drill down and I find the status 'Failed'. I click on the link until I reach the output log which only gives me as per attachment or as follow:

Output Log


Recovery Manager: Release 10.2.0.3.0 - Production on Tue Oct 23 02:00:21 2007

Copyright (c) 1982, 2005, Oracle. All rights reserved.



Anyone could help?

Thanks
Steven






Re: RMAN does not work from OEM [message #275830 is a reply to message #275829] Mon, 22 October 2007 20:38 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Folks don't like to open .doc files in forums. Can you post the picture or text without posting a .doc file?
Re: RMAN does not work from OEM [message #275831 is a reply to message #275829] Mon, 22 October 2007 20:42 Go to previous messageGo to next message
stevenfoo
Messages: 10
Registered: October 2007
Junior Member
I am reattaching the file in JPG format.
Re: RMAN does not work from OEM [message #275833 is a reply to message #275831] Mon, 22 October 2007 20:54 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Do you see any additional information in $ORACLE_HOME/<host_sid>/sysman/log directory?
Re: RMAN does not work from OEM [message #275836 is a reply to message #275829] Mon, 22 October 2007 21:59 Go to previous messageGo to next message
stevenfoo
Messages: 10
Registered: October 2007
Junior Member
This is the error that I received from emoms.trc/emoms.log.

2007-10-23 10:56:59,626 [EMUI_10_56_55_/console/jobs/results$ctxType=ctxSummary$execId=B3B2BA5C06CB47BA940BFD341A0DECC6] ERROR em.console doGet.311 - com.evermind.server.http.HttpIOException: Connection reset by peer: socket write error
com.evermind.server.http.HttpIOException: Connection reset by peer: socket write error
at com.evermind.server.http.EvermindServletOutputStream.write(EvermindServletOutputStream.java:250)
at com.evermind.server.http.EvermindJSPWriter.writeOut(EvermindJSPWriter.java:457)
at com.evermind.server.http.EvermindJSPWriter.jspflush(EvermindJSPWriter.java:374)
at com.evermind.server.http.EvermindJSPWriter.close(EvermindJSPWriter.java:346)
at oracle.jsp.runtime.OracleJspRuntime.extraHandlePCFinally(OracleJspRuntime.java:1460)
at _jobs._results._jspService(_results.java:1423)
at oracle.jsp.runtime.HttpJsp.service(HttpJsp.java:139)
at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:274)
at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:509)
at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:413)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:765)
at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317)
at com.evermind.server.http.ServletRequestDispatcher.forward(ServletRequestDispatcher.java:220)
at oracle.sysman.emSDK.svlt.PageHandler.render(PageHandler.java:773)
at oracle.sysman.emSDK.svlt.PageHandler.handleRequest(PageHandler.java:396)
at oracle.sysman.emSDK.svlt.EMServlet.myDoGet(EMServlet.java:688)
at oracle.sysman.emSDK.svlt.EMServlet.doGet(EMServlet.java:291)
at oracle.sysman.eml.app.Console.doGet(Console.java:285)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.evermind.server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:65)
at oracle.sysman.emSDK.svlt.EMRedirectFilter.doFilter(EMRedirectFilter.java:101)
at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:16)
at oracle.sysman.db.adm.inst.HandleRepDownFilter.doFilter(HandleRepDownFilter.java:151)
at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:20)
at oracle.sysman.eml.app.ContextInitFilter.doFilter(ContextInitFilter.java:282)
at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:600)
at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317)
at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:793)
at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:270)
at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:112)
at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192)
at java.lang.Thread.run(Thread.java:534)
Re: RMAN does not work from OEM [message #275837 is a reply to message #275829] Mon, 22 October 2007 22:27 Go to previous messageGo to next message
stevenfoo
Messages: 10
Registered: October 2007
Junior Member
Hi All,

I tried to login using user SYSMAN to schedule the RMAN and I get the following from the sysman/log file:

2007-10-23 11:18:21,611 [EMUI_11_18_17_/console/database/rec/backup] ERROR em.jobs initializeEncryptionAlgorithms.4269 - RmanObject.initializeEncryptionAlgorithms() SQLException: java.sql.SQLException: ORA-00942: table or view does not exist

Now the error is differet from the previous one.

How could I resolved it?

Thanks.

Steven
Re: RMAN does not work from OEM [message #275838 is a reply to message #275829] Mon, 22 October 2007 22:33 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
> ORA-00942: table or view does not exist
Typically because 1 of 3 is lacking
1) actual TABLE
2) SYNONYM
3) Permission
Re: RMAN does not work from OEM [message #275839 is a reply to message #275829] Mon, 22 October 2007 22:56 Go to previous message
stevenfoo
Messages: 10
Registered: October 2007
Junior Member
What is the propose solution since the log did not let me more information on which table, synom or permission is missing.

Kindly advice.

Thanks.
Previous Topic: Purchase Requisition
Next Topic: help...listener and EM is not active (IM speak removed)
Goto Forum:
  


Current Time: Thu Dec 08 20:09:48 CST 2016

Total time taken to generate the page: 0.06036 seconds