Home » RDBMS Server » Networking and Gateways » Listener problem (Listener works but it does not ;-))
Listener problem [message #275577] Sun, 21 October 2007 22:35 Go to next message
monti323
Messages: 5
Registered: October 2007
Junior Member
Hi,

since a long time I experience a strange problem with a server running NT4 Server and Oracle 9iRel2. The Listener server stops partly working. Means, if ones ping it using TNSPING, it still answers but any transfer to and from the server does not work anymore (all connected clients coming up with "Listener connection lost" faults. Stopping and Restarting the Listener-service on the server makes it working again.

There is no log entry in non of the logfiles which would almost fit the time frame when this errors occurs. Although there are quite some errors "Package receiving fault" which apparently indicate intermittent problems with the network connection.

If somebody has an idea, please let me know. I already reinstalled the whole oracle installation from scrap. Problems comes and goes, sometimes ok for some weeks, then a couple of times a day.

Thanks
Re: Listener problem [message #275578 is a reply to message #275577] Sun, 21 October 2007 22:38 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
Are there any "interesting" entries in either Oracle's listener.log file or in Windows system "Event Viewer"?

I suspect a hardware (NIC) problem or external network glitch.
Re: Listener problem [message #275584 is a reply to message #275577] Sun, 21 October 2007 22:49 Go to previous messageGo to next message
monti323
Messages: 5
Registered: October 2007
Junior Member
No, there is no entry in non of the logfiles which would fit the time when it happens.
You're right, there is definetely something wrong with that network but unless I can prove it, they blame it on the Oracle-installation.
Is that a known behaviour of the listener, that a network problem can bring it into that stage, that it still answers TNSPING requests but does not really function anymore unless the service is getting restarted ???

Thanks
Re: Listener problem [message #275587 is a reply to message #275577] Sun, 21 October 2007 22:58 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
I can't assist more.
I suggest you open a Service Request with Oracle.
Re: Listener problem [message #275588 is a reply to message #275577] Sun, 21 October 2007 22:58 Go to previous message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Can you copy and paste along with error message and what you did actually?
Previous Topic: 2000 Server install
Next Topic: ORA-03121 Unable to connect D2K with Oracle 8i
Goto Forum:
  


Current Time: Sat Dec 03 06:13:56 CST 2016

Total time taken to generate the page: 0.13910 seconds