Home » Developer & Programmer » JDeveloper, Java & XML » JDeveloper NOT Starting
JDeveloper NOT Starting [message #271906] Wed, 03 October 2007 06:15 Go to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member
Hi There,

I have Oracle 9i + 9i Dev Suite installed. I cannot Start JDeveloper???

When I go to Programs-->Oracle-->Jdeveloper and click on Jdeveloper nothing is happening.

I appreciate anyones help.

thanks,
Baz
Re: JDeveloper NOT Starting [message #271911 is a reply to message #271906] Wed, 03 October 2007 06:25 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
Seriously, what do you expect from us?
Re: JDeveloper NOT Starting [message #271912 is a reply to message #271911] Wed, 03 October 2007 06:31 Go to previous messageGo to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member
Quote:

Seriously, what do you expect from us?



Simply, if I have to start any service or this is something I am missing when trying to start Jdeveloper.

Is it an Installation issue?

Thanks in advance.

Re: JDeveloper NOT Starting [message #271913 is a reply to message #271912] Wed, 03 October 2007 06:35 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
There is nothing you have to do after you installed the program, if you followed the install-guide.
Normally, installing would be either unzipping the downloaded package or running the downloaded installer (depends on version).
Re: JDeveloper NOT Starting [message #271915 is a reply to message #271912] Wed, 03 October 2007 06:38 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
The reason for my initial reply is that the question is "a tad vague"
Imagine a MicroSoft Office forum, where someone posts "I installed Word. When I start it from the startmenu nothing happens"
Would you know where to start, or would you think "yeah, right.. and how can we tell anything just by that description to help you" ?
Re: JDeveloper NOT Starting [message #271918 is a reply to message #271911] Wed, 03 October 2007 06:41 Go to previous messageGo to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member
It's Ok Frank, no worries about the initial response.


I have installed Jdeveloper Along with oracle DS suite(Complete Installation). This is the first time I am trying to run JDeveloper and it is not loading anything.

Should I download the JDeveloper again and reinstall it separately? Could that be a proper solution?

Thanks,
Baz
Re: JDeveloper NOT Starting [message #271922 is a reply to message #271918] Wed, 03 October 2007 06:46 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
what happens if you open a dosbox in the JDeveloper/jdev/bin directory and issue jdev.exe

(not sure if this will work for 9i; I only have 10.1.3 installed)
Re: JDeveloper NOT Starting [message #271924 is a reply to message #271922] Wed, 03 October 2007 06:48 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
also, use Windows process manager (ctrl-shift-esc) to see if you have a process (second tab-page) named jdev
Re: JDeveloper NOT Starting [message #271930 is a reply to message #271924] Wed, 03 October 2007 06:57 Go to previous messageGo to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member
I tried that from the Command Prompt. The Process Shows in the Task Manager for a Split of a Second and then disappears swiftly.

Still the issue remains Mad

Thanks for your support

[Updated on: Wed, 03 October 2007 06:57]

Report message to a moderator

Re: JDeveloper NOT Starting [message #271938 is a reply to message #271930] Wed, 03 October 2007 07:08 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
try jdev -verbose
Re: JDeveloper NOT Starting [message #271943 is a reply to message #271938] Wed, 03 October 2007 07:14 Go to previous messageGo to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member
C:\oracle\Oracle9iDS\jdev\bin>jdev -verbose
JNI Option: -Xverify:none
JNI Option: -Xmx512M
JNI Option: -Dsun.java2d.noddraw=true
JNI Option: -Dorg.omg.CORBA.ORBClass=com.inprise.vbroker.orb.ORB
JNI Option: -Dorg.omg.CORBA.ORBSingletonClass=com.inprise.vbroker.orb.ORB
JNI Option: -Dice.browser.forcegc=false
JNI Option: -Dcom.apple.macos.useScreenMenuBar=true
.
.
.
.
;C:\oracle\Oracle9iDS\jdk\lib\tools.jar;C:\oracle\Oracle9iDS\jdk\lib\dt.jar;C:\o
racle\Oracle9iDS\jdk\lib\tools.jar;C:\oracle\Oracle9iDS\jdk\lib\dt.jar
JNI Option: -Djava.library.path=
JNI Option: -Dide.user.dir=
JVM path is C:\oracle\Oracle9iDS\jdk\jre\bin\vanilla\jvm.dll


Hi Frank,

I tried this command and I have got a long thread of messages in the Command Prompt but still the JDeveloper is not Loading or opening.

Any clue?

Thanks Bud

Re: JDeveloper NOT Starting [message #271945 is a reply to message #271943] Wed, 03 October 2007 07:17 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
Are you on OSX?
Re: JDeveloper NOT Starting [message #271947 is a reply to message #271945] Wed, 03 October 2007 07:23 Go to previous messageGo to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member
Nope I am on Windows XP SP2
Re: JDeveloper NOT Starting [message #272208 is a reply to message #271947] Thu, 04 October 2007 04:23 Go to previous messageGo to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member
I installed the same Oracle 9i Dev Suite on another machine and the JDeveloper is working fine.

But on my Old machine, I Un-installed Dev Suite and RE-installed it again and that DID NOT FIX the JDeveloper issue.

Thanks Frank for the support.

Guys, what could be the issue on my Machine with JDeveloper?

Regards,
Baz
Re: JDeveloper NOT Starting [message #318422 is a reply to message #271906] Tue, 06 May 2008 17:06 Go to previous messageGo to next message
oaom
Messages: 4
Registered: May 2008
Junior Member
I have the same problem
I think the problem is from the JVM that comes with JDeveloper 10g

I receive this error message

JNI Option: -Djava.system.class.loader=oracle.ideimpl.IdeClassLoader
JVM path is C:\oracle\product\DevSuiteHomeOAOM\jdk\jre\bin\client\jvm.dll
Error occurred during initialization of VM
Could not reserve enough space for object heap


How to change the path for the used JVM
Re: JDeveloper NOT Starting [message #318424 is a reply to message #271906] Tue, 06 May 2008 17:15 Go to previous messageGo to next message
oaom
Messages: 4
Registered: May 2008
Junior Member
I found these line within jdev.conf file


#
# If you run into problems related to relocation errors of system dll's, use
# this option to resolve them. This option only works under ojvm.
#
# AddVMOption -Xheapbase100000000

I try it without benefit
Re: JDeveloper NOT Starting [message #318426 is a reply to message #271906] Tue, 06 May 2008 17:21 Go to previous messageGo to next message
oaom
Messages: 4
Registered: May 2008
Junior Member
I get a soultion and successfuly run JDeveloper 10g

within Jdev.conf file located at C:\oracle\product\DevSuiteHomeOAOM\jdev\bin

the third line from the end of file is
SetJavaHome C:\oracle\product\DevSuiteHomeOAOM\jdk

I mark it with # so it became
#SetJavaHome C:\oracle\product\DevSuiteHomeOAOM\jdk

I add this line
SetJavaHome C:\jdk1.6.0_05

Then I start the JDeveloper 10g Successfully.
notice that I receive a warning from JDeveloper that it is not certified to run with JAVA JDK 1.6 which I download it from SUN website



Re: JDeveloper NOT Starting [message #318427 is a reply to message #271906] Tue, 06 May 2008 17:22 Go to previous message
oaom
Messages: 4
Registered: May 2008
Junior Member
I forget to say thanks for bbaz
He help me to get the road to start solving the problem
Previous Topic: Where to download JDeveloper Books for Free
Next Topic: unable to create UIX page in jdev 10.1.3.3
Goto Forum:
  


Current Time: Sun Dec 21 18:44:47 CST 2014

Total time taken to generate the page: 3.89866 seconds