Home » SQL & PL/SQL » SQL & PL/SQL » using array in pl/sql doesnt work - not urgent at all so PLEASE, PLEASE take your time.
using array in pl/sql doesnt work - not urgent at all so PLEASE, PLEASE take your time. [message #271787] Tue, 02 October 2007 22:44 Go to next message
samir25
Messages: 1
Registered: October 2007
Junior Member
hi
i want to use this owa_util.ident_arr to capture values in the pl/sql listprint. however i deleted all teh code in the pl/sql and still not able to run it..here is waht i am doing in spec and body
procedure data2 (
var1 in owa_util.ident_arr );
procedure data2 (
var1 in owa_util.ident_arr )
is
begin
htp.p('this page is under testing');
end;

can someone help me know why i cant use this array defination.

this page doesnt run saying the data2 doesnt exists

[Updated on: Wed, 03 October 2007 07:58] by Moderator

Report message to a moderator

Re: V. Urgent: using array in pl/sql doesnt work [message #271801 is a reply to message #271787] Wed, 03 October 2007 00:51 Go to previous messageGo to next message
Michel Cadot
Messages: 64140
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Please read and follow OraFAQ Forum Guide, especially "How to format your post?" section.
Make sure that lines of code do not exceed 80 characters when you format. Use the "Preview Message" button.
Please always post your Oracle version (4 decimals).

Regards
Michel
Re: V. Urgent: using array in pl/sql doesnt work [message #271819 is a reply to message #271787] Wed, 03 October 2007 01:24 Go to previous messageGo to next message
flyboy
Messages: 1832
Registered: November 2006
Senior Member
Hi,

I would like to summarize your post.
First, what I know:
- you are not able to run something
Second, what I can deduce:
- you get some error when calling DATA2
- you do not have stored procedure called DATA2
- you probably included it into package called somehow
Third, what I do not know at all:
- whether the covering package (if my assumption is correct) was created without errors
- how you exactly call DATA2

Instead of describing problem you should copy/paste your session to show exact statements called and Oracle output, as recommended in the OraFAQ Forum Guide. The structure of previous paragraph would be different and the chance for getting fast and exact help would be bigger.
Note the section about NOT using words like urgent.
Before that, you shall consult documentation, found eg. online on http://tahiti.oracle.com/, especially the PL/SQL User's Guide and Reference.

I suppose you called it just DATA2, which is not correct as DATA2 is not a procedure.
You shall call it with correct notation package_name.DATA2 (note I do not know the package name as you did not post it).
Re: V. Urgent: using array in pl/sql doesnt work [message #271825 is a reply to message #271801] Wed, 03 October 2007 01:39 Go to previous message
Maaher
Messages: 7062
Registered: December 2001
Senior Member
What do you mean when you say that you are "not able to run it"? You need a simple startup page as you cannot call that procedure directly from your web browser if I remember correctly. It's been a long time since I used mod plsql but I don't see how you would pass an array directly in the URL. You normally call a modplsql procedure like this:
http://yourserver:7777/pls/myconfig/package.procedure?parameter1=something&parameter2=...

Can't you use a simple startup page that redirects to this procedure?

MHE
Previous Topic: Two snippets doesn't work the same
Next Topic: when do apply last dml ?
Goto Forum:
  


Current Time: Fri Dec 09 04:25:51 CST 2016

Total time taken to generate the page: 0.06702 seconds