Home » RDBMS Server » Server Administration » Always connected to an idle instance
Always connected to an idle instance [message #271648] Tue, 02 October 2007 05:58 Go to next message
M.Shakeel Azeem
Messages: 226
Registered: September 2006
Senior Member
Dear All

Oracle Version: 9i
Operating System: windows server 2003

i had successfully created duplicate database on the same machine by using the following link
http://babudba.blogspot.com/search/labe ... 20Creation

OracleService is auto-started
All are working fine but whenever i reboot my PC ,the service is started but i try to connect db through SQL*PLUS
It prompts
Connected to an idle instance.
So Everytime i have to manually startup Db
SQL> startup
ORACLE instance started.

Total System Global Area 100663296 bytes
Fixed Size 787648 bytes
Variable Size 65796928 bytes
Database Buffers 33554432 bytes
Redo Buffers 524288 bytes
Database mounted.
Database opened.

where could be the problem ?
can u help me in this regard?
Re: Always connected to an idle instance [message #271656 is a reply to message #271648] Tue, 02 October 2007 06:35 Go to previous messageGo to next message
Michel Cadot
Messages: 64140
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Service is autostarted but not instance and database.
Run regedit -> Go to HKLM/Software/Oracle/<your oracle home>
and set ORA_<sid>_AUTOSTART to TRUE.

Regards
Michel
Re: Always connected to an idle instance [message #271778 is a reply to message #271648] Tue, 02 October 2007 21:47 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Another way RIght click on my computer ->manage -> service ->make oracle services automatic.
Re: Always connected to an idle instance [message #271791 is a reply to message #271778] Tue, 02 October 2007 23:54 Go to previous messageGo to next message
M.Shakeel Azeem
Messages: 226
Registered: September 2006
Senior Member
Dear Arju
i have already mentioned that particular service is already automatic and the service is also started automatically when i reboot the system but
when i try to connect db

SQL>conn sys@testdb as sysdba
password:

connected to an idle instance

i think the problem is much clear now
where could b the problem and how to resolve this?
can u help me in this regard?

Re: Always connected to an idle instance [message #271792 is a reply to message #271648] Tue, 02 October 2007 23:58 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Isn't Michel's Answer solve your problem?
Re: Always connected to an idle instance [message #271805 is a reply to message #271792] Wed, 03 October 2007 00:56 Go to previous messageGo to next message
Michel Cadot
Messages: 64140
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Surely but some do not like my answers and discard them.

Regards
Michel
Re: Always connected to an idle instance [message #271806 is a reply to message #271805] Wed, 03 October 2007 01:03 Go to previous messageGo to next message
M.Shakeel Azeem
Messages: 226
Registered: September 2006
Senior Member
oh dear this is not the case

I had created the service with the following command

C:\> oradim –new –sid WLLSETT –intpwd pass –startmode a –pfile D:\oracle\ora92\database \initWLLSETT.ora

As mentioned in command the Service WLLSETT is set to autostart and when i reboot the system that particular service is started automatically and i also checked the option u provided in ur post

Run regedit -> Go to HKLM/Software/Oracle/<your oracle home>
and set ORA_<sid>_AUTOSTART to TRUE

this option is already set to true

Now what i should have to do to solve this problem ?
Any Suggestion please!!!!!!!!!!!!!!! ?
Re: Always connected to an idle instance [message #271814 is a reply to message #271806] Wed, 03 October 2007 01:15 Go to previous messageGo to next message
Michel Cadot
Messages: 64140
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Have a look at alert.log and see what happened at starting time.
Have also a look at Windows event log.

Regards
Michel
Re: Always connected to an idle instance [message #317691 is a reply to message #271806] Fri, 02 May 2008 09:43 Go to previous messageGo to next message
mhay
Messages: 1
Registered: May 2008
Junior Member
Hello! Nowadays, I am facing the same problem on 10g database. Did you solve the problem?
Re: Always connected to an idle instance [message #317820 is a reply to message #271648] Sat, 03 May 2008 22:27 Go to previous message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

ORA-01034: ,ORA-27101: shared memory realm does not exist
Previous Topic: tablespace is 92% used.
Next Topic: What Front-end tools could be used to access the database server
Goto Forum:
  


Current Time: Fri Dec 09 04:12:55 CST 2016

Total time taken to generate the page: 0.16153 seconds