Home » Developer & Programmer » Forms » show_view is not working
icon7.gif  show_view is not working [message #270528] Thu, 27 September 2007 06:25 Go to next message
sourajit_seth
Messages: 38
Registered: November 2005
Location: India
Member
I have 3 canvases ---> X ( Content), Y ( Stack) and Z ( Stack) which has 3 blocks BX, BY, BZ resp.

WHEN-NEW-BLOCK-INSTANCE trigger of BX :
execute_query;
show_view('Y') ;

Now X and Y both canvases are displayed.

WHEN-BUTTON-PRESSED trigger of an Item of BX
Go_Block('BZ') ;
Now only canvas Z is displayed.

WHEN-BUTTON-PRESSED trigger of an Item of BZ
Go_Block('BX') ;
show_view('Y') ;

Now only X is displayed. Canvas Y is vanished after a single blink.

But I require both canvases as in initial stage. Please advice.
Re: show_view is not working [message #270575 is a reply to message #270528] Thu, 27 September 2007 10:28 Go to previous messageGo to next message
Soumen Kamilya
Messages: 128
Registered: August 2007
Location: Kolkata
Senior Member

Allocate individual window for the canvas. It will solve your problem.

Cheers
Soumen
Re: show_view is not working [message #270718 is a reply to message #270528] Thu, 27 September 2007 18:44 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Make sure that you have moved the focus of the form to an item that is NOT covered/overlayed by the view you are trying to show.

David
Re: show_view is not working [message #270883 is a reply to message #270528] Fri, 28 September 2007 04:40 Go to previous messageGo to next message
sourajit_seth
Messages: 38
Registered: November 2005
Location: India
Member
Thanks for your response.

The item is not overlapped and canvas Y is vanished within a second. It looks like only content canvas 'X' is displayed.


Actually one of my purpose is to reduce the number of items in the forms to ease the maintenance. So I want to keep all the canvas in same window if possible.

Let me know if there is any other way out.
Re: show_view is not working [message #271769 is a reply to message #270883] Tue, 02 October 2007 19:05 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Instead of 'go_block' I suggest using 'go_item'.

David
icon14.gif  Re: show_view is not working [message #570877 is a reply to message #271769] Sat, 17 November 2012 01:21 Go to previous message
Hamza_Bukhari
Messages: 1
Registered: November 2012
Location: Pakistan
Junior Member
Thanx DjMartin Smile
My Problem is Solved Due to You.
Previous Topic: 11g forms and report
Next Topic: Post change trigger in oracle forms
Goto Forum:
  


Current Time: Sat Dec 20 20:48:31 CST 2014

Total time taken to generate the page: 0.11800 seconds