Home » RDBMS Server » Enterprise Manager » RemoteOperationException: ERROR: Wrong password for user (merged)
RemoteOperationException: ERROR: Wrong password for user (merged) [message #119156] Tue, 10 May 2005 19:45 Go to next message
ORARAY
Messages: 6
Registered: May 2005
Junior Member
Hi All,

I have installed Oracle 10g on Windows XP. I created a database called orcl1 using DBCA and set the sys and system user passwords as "oracle". My windows xp operating system password is set as username:Bobby and password :welcome4all.
Yet at the startup/shutdown page in Enterprise Manager, when I enter HOST CREDENTIALS as username:Bobby,password :welcome4all
and credentials for target database as username:sys,password :oracle, I get RemoteOperationException:ERROR: WRONG PASSWORD FOR USER .
I don't understand why? Am I doing something wrong?
Please Help!
Thanks
icon8.gif  Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #121765 is a reply to message #119156] Tue, 31 May 2005 22:17 Go to previous messageGo to next message
takume
Messages: 1
Registered: May 2005
Junior Member
I have the same problem as well..but i am using XP Pro however my OS user name have no password. Does anyone solve this cases ?
icon8.gif  Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #127425 is a reply to message #119156] Mon, 11 July 2005 10:59 Go to previous messageGo to next message
tajdba
Messages: 3
Registered: July 2005
Junior Member
Even I face the same problem, hope somebody in the forum has a work around for that.

I read a work around in the forum replies as follows.
If you are on windows: Go to Control Panel-->Administrative Tools-->Local Security Policy-->Local Policies-->User Rights Assignment-->U will see in the policy as "Log on as a batch Job-->right click-->Properties-->add user or groups-->give your OS username.
I think this will solve the problem and also use your hostname instead of localhost in your URL.

But, unfortunately, i still didn't work for me, you guys may also give it a try.
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #128795 is a reply to message #127425] Wed, 20 July 2005 12:12 Go to previous messageGo to next message
loedolff
Messages: 1
Registered: July 2005
Junior Member
Holy smokes. That worked. Thanks!

This was my problem also. I'll repeat your solution also:

In several different operations in the Oracle Enterprise Manager 10g, when prompted for a "Host" username (for example, under Preferences | Preferred Credentials | Host | Set Credentials, also Database | Listener | Net Services Administration | Administer - "Local Naming" | Go) I kept getting the error "Validation Error, RemoteOperationException: ERROR: Wrong password for user".

My operating system is Windows 2000 Server. I added a new user account, called "oracle" and used Control Panel | Administrative Tools | Local Security Policy | Local Policies | User Rights Assignment | Logon as a batch job" and added the "oracle" user to the list.

Going back to Enterprise Manager I was able to complete the authentication.
icon12.gif  Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #132546 is a reply to message #119156] Sun, 14 August 2005 10:05 Go to previous messageGo to next message
tajdba
Messages: 3
Registered: July 2005
Junior Member
Dear Friends,
Try this out, it worked for me.

You have to provide the 'Log on as a batch job' privilege:

1. Go to control panel/administrative tools
a. click on "local security policy"
b. click on "local policies"
c. click on "user rights assignments"
d. double click on "log on as a batch job"
e. click on "add" and add the user that was entered in the "normal username" or "privileged username" section of the EM Console.

2. Go to the Preferences link in the EM GUI
a. click on Preferred Credentials (link on the left menu)
b. under "Target Type: Host" click on "set credentials"
c. enter the OS user who has logon as a batch job privilege into the "normal username" and "normal password" fields

3. Test the connection
a. while in the Set Credentials window, click on "Test"
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #138245 is a reply to message #119156] Tue, 20 September 2005 22:29 Go to previous messageGo to next message
AdamSmith
Messages: 2
Registered: September 2005
Location: Wichita
Junior Member
I have the same situation.
But after I do everything tajdba lists, when I hit the "Test" button the next screen says :

"Connection to 68.103.203.104 as user Jeff failed: ERROR: Wrong password for user"

(I'm entering "Jeff" (the name of the windowsXP user account) and I'm entering the password I enter on the windows XP logon screen.)

Why would this be? Do I need to set up something elsewhere in order to get it to recognise the "Jeff" username?

Thanks.
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #138316 is a reply to message #138245] Wed, 21 September 2005 05:29 Go to previous messageGo to next message
alliejane
Messages: 59
Registered: July 2005
Location: Glasgow
Member
Try to stop and start dbconsole

emctl stop dbconsole, emctl start dbconsole

That ususally fixes the issue..
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #138421 is a reply to message #119156] Wed, 21 September 2005 21:40 Go to previous messageGo to next message
AdamSmith
Messages: 2
Registered: September 2005
Location: Wichita
Junior Member
After doing this multiple times, I still get the "ERROR: Wrong password for user" message. There seems to be no change at all.
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #172626 is a reply to message #119156] Wed, 17 May 2006 07:20 Go to previous messageGo to next message
troracle34
Messages: 6
Registered: May 2006
Location: istanbul
Junior Member
i face same problem that when enter my password and username
error about it but i tihnk everyting is ok.

i apply all step in ebove mentition but same error rise

pls help mee:(

gokhan dedeler jnr dba
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #173817 is a reply to message #119156] Wed, 24 May 2006 11:24 Go to previous messageGo to next message
binoy1522
Messages: 1
Registered: May 2006
Location: Detroit, MI
Junior Member
Hi Friends

I faced the same problem.

I read a work around in the forum replies as follows.
If you are on windows: Go to Control Panel-->Administrative Tools-->Local Security Policy-->Local Policies-->User Rights Assignment-->U will see in the policy as "Log on as a batch Job-->right click-->Properties-->add user or groups-->give your OS username.

It did work.

Thanks
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #179121 is a reply to message #119156] Sun, 25 June 2006 20:34 Go to previous messageGo to next message
czetsuya
Messages: 4
Registered: June 2006
Location: Philippines
Junior Member

omg it did work after reading some forums it finally paid off well thanks a bunch guys Smile.. Razz
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #248983 is a reply to message #127425] Tue, 03 July 2007 00:45 Go to previous messageGo to next message
vivek13agarwal
Messages: 1
Registered: July 2007
Location: delhi
Junior Member
Hi friends,
It worked for me...Thanks a lot...i was in big trouble

Thanks
RemoteOperationException: ERROR: Wrong password for user [message #250259 is a reply to message #119156] Mon, 09 July 2007 05:55 Go to previous messageGo to next message
sbmk_design
Messages: 87
Registered: April 2007
Location: CHENNAI
Member
Hi
I am using Oracle 10.1. Enterprises Manager.While using
1)Net Services Administration 2)exp 3)imp it ask Host Credentials
I gave my server's administrator's name & 3 letter password, but the password changes automatically to 11 character(i.e no of star symbol).Then it show error like this
Error - RemoteOperationException: ERROR: Wrong password for user How to correct this please...

by
sbmk_design
Re: RemoteOperationException: ERROR: Wrong password for user [message #250316 is a reply to message #250259] Mon, 09 July 2007 11:02 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
sbmk_design wrote on Mon, 09 July 2007 04:55
Hi
I am using Oracle 10.1. Enterprises Manager.While using
1)Net Services Administration 2)exp 3)imp it ask Host Credentials
I gave my server's administrator's name & 3 letter password, but the password changes automatically to 11 character(i.e no of star symbol).Then it show error like this
Error - RemoteOperationException: ERROR: Wrong password for user How to correct this please...

by
sbmk_design


Go to "Control Panel" -> "Admin Tools" -> "Local Security Policy."
Within "Local Policies", go to user "Right Assignment."
Add the user to "Logon as a Batch Job."
The logon problem should now be resolved. This is for trying to run Oracle 10g on Windows 2003 Server.
icon8.gif  Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #268109 is a reply to message #248983] Mon, 17 September 2007 09:44 Go to previous messageGo to next message
joeller
Messages: 17
Registered: September 2007
Location: Indian Head, Maryland
Junior Member
Did not work. Operating system Windows Server 2003. Changed policy for user logging on which is administrator. Did not work.

Same exception
Re: RemoteOperationException: ERROR: Wrong password for user [message #268110 is a reply to message #250316] Mon, 17 September 2007 09:47 Go to previous messageGo to next message
joeller
Messages: 17
Registered: September 2007
Location: Indian Head, Maryland
Junior Member
Tried that. Windows Server 2003 changed local policy for operating system user Administrator. Same erro.
Re: RemoteOperationException: ERROR: Wrong password for user [message #268116 is a reply to message #268110] Mon, 17 September 2007 10:24 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Did you add your local user to "Logon as a Batch Job."
Restart your OEM.

[Updated on: Mon, 17 September 2007 10:26]

Report message to a moderator

Re: RemoteOperationException: ERROR: Wrong password for user [message #268122 is a reply to message #268116] Mon, 17 September 2007 10:34 Go to previous messageGo to next message
joeller
Messages: 17
Registered: September 2007
Location: Indian Head, Maryland
Junior Member
Yes and Yes

IT reports that the listener is looking for Oracle service "Transcom". Yet the listener files and the TNSNames files all say the Service name is TRANSCOM_SI. The old style enterprise manager (a better format in my mind) is working just fine. There are no log in problems and no problems finding the service.

[Updated on: Mon, 17 September 2007 10:37]

Report message to a moderator

Re: RemoteOperationException: ERROR: Wrong password for user [message #268154 is a reply to message #268122] Mon, 17 September 2007 16:13 Go to previous messageGo to next message
joeller
Messages: 17
Registered: September 2007
Location: Indian Head, Maryland
Junior Member
After adding login to policy, had to go to 9i enterprise manager to set passwords for sysman, sys, system, and dbsnmp. While these users could connect fine over the network, connecting locally resulted in a ORD-06553 PLS-801 56319 error. This was because we had moved the database from Oracle 64 bit to Oracle 32 bit. This required us to run utlirp.sql, CatPProc.sql, and Catalog.sql. Once this was done we could connect fine in sqlplus, but the enterprise manager still did not work. The enterprise manager was looking for the service by the wrong name. Then we did a emca -config. When that did not work (because it refused to accept the dbsnmp password), we did a emca -deconfig, and a emca -config. No joy. Then we did an emca -deconfig all db -repos drop command then tried to run the emca -config all db -repos create. This kept failing by returning a Fatal error that "Component 'VALID' must be declared." (ora-06550 PLS-00302) After a number of failures here, we just did a emca -config all db, and "Voila" it worked. Hopefully I will never have to go throught this again.
Re: RemoteOperationException: ERROR: Wrong password for user (merged) [message #268643 is a reply to message #119156] Wed, 19 September 2007 04:41 Go to previous messageGo to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
Instead of starting a new thread around the same issue, I post here:

I run Oracle 10g (10.2.0.3) on Suse10.2.
I can log in to EM. But when I try to use Oracle-Suggested Backup or Customized Backup I get this error:

Validation Error
Examine and correct the following errors, then retry the operation:
Error - Connection to host as user pha failed: ERROR: Failed to run command in process

Pha is my host login.

Any ideas how to solve this issue?

Regards
H
Re: RemoteOperationException: ERROR: Wrong password for user (merged) [message #268648 is a reply to message #119156] Wed, 19 September 2007 04:50 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Quote:
Instead of starting a new thread around the same issue, I post here:

Appreciate it.

And for later part is it an Oracle Error? Oracle Error usually comes with ORA-Number format.
Re: RemoteOperationException: ERROR: Wrong password for user (merged) [message #268650 is a reply to message #268648] Wed, 19 September 2007 04:56 Go to previous messageGo to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
No, what I posted is the full error messege...no ORA-error code.
Re: RemoteOperationException: ERROR: Wrong password for user (merged) [message #269273 is a reply to message #268650] Fri, 21 September 2007 07:46 Go to previous messageGo to next message
hristo
Messages: 258
Registered: May 2007
Senior Member
*bump*
Re: RemoteOperationException: ERROR: Wrong password for user (merged) [message #269294 is a reply to message #269273] Fri, 21 September 2007 09:01 Go to previous messageGo to next message
joeller
Messages: 17
Registered: September 2007
Location: Indian Head, Maryland
Junior Member
Presumably you've tried everything already discussed. If so you are beyond me. Try entering your error message in google along with the task you are trying to accomplish and see what pops up. The final answer to one of my issues turned out to be as simple as turning the Oracle service on and off, and I found that in a thread that seemingly had no relationship to my issue. Sorry I can't be of any real assistance, but I am primarily a PostSQL and SQL Server DBA, who has been pressed into service working on this Oracle DB.
Re: RemoteOperationException: ERROR: Wrong password for user [message #275631 is a reply to message #268116] Mon, 22 October 2007 02:32 Go to previous messageGo to next message
masterborj
Messages: 21
Registered: October 2007
Location: Philippines
Junior Member

im using an Oracle 10g on a windows 2003 sp2 standard ed.it already added the administrator account on the policy "log on as a batch job" but still it doesnt work.i keep on receiving error message "ERROR:Wrong Password for user".is there anything i still need to configure or change?pls help
Re: RemoteOperationException: ERROR: Wrong password for user [message #275706 is a reply to message #275631] Mon, 22 October 2007 08:02 Go to previous messageGo to next message
joeller
Messages: 17
Registered: September 2007
Location: Indian Head, Maryland
Junior Member
Read the entire thread above. Try everything I reported that we tried. If that doesn't work it is beyond me. It was very irritating to have all these people telling me to try the things that I had already stated that I had tried. Oh and try restarting the service. I remember one time we had taken all the necessary steps to fix the problem but it still would not work until we had re-started the service.
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #412747 is a reply to message #132546] Sat, 11 July 2009 02:18 Go to previous messageGo to next message
SameerChoudhari
Messages: 9
Registered: July 2009
Location: Bangalore
Junior Member

This solution doesnt work for Windows Vista Home Premium 32Bit OS. I am stuggling a lot to find solution . Could anyone know how to solve this problem on Vista. I am using Oracle 10g on Vista.
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #430723 is a reply to message #412747] Thu, 12 November 2009 00:57 Go to previous messageGo to next message
nghiavt
Messages: 1
Registered: November 2009
Location: VN
Junior Member
Dear All,

Like some guys post before do just modified on step 4 that what i resolve my problem

1. Go to "Control Panel" -> "Admin Tools" -> "Local Security Policy."
2. Within "Local Policies", go to user "Right Assignment."
3. Add the user to "Logon as a Batch Job."

Remember that Group Policy for local will be loaded when computer start, So if you still meet error password you should update group policy on computer that oracle installed

4. go to cmd press:
gpupdate /force

5. The logon problem should now be resolved. This is for trying to run Oracle 10g on Windows 2003 Server.

Note: on the vista OS i think that the same

Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #448999 is a reply to message #430723] Fri, 26 March 2010 03:57 Go to previous messageGo to next message
haider786
Messages: 1
Registered: March 2010
Location: Telford, UK
Junior Member
Hi,
Suggestion from "alliejane" solved my problem.

emctl stop dbconsole

then

emctl start dbconsole


Regards
Haider
Re: RemoteOperationException: ERROR: Wrong password for user (merged) [message #450871 is a reply to message #119156] Fri, 09 April 2010 18:02 Go to previous messageGo to next message
Elinornrond
Messages: 1
Registered: April 2010
Junior Member
Although you may assume loging onto the local machine unless specifying otherwise, especially the professional/business versions of Windows have a tendency to assume less.

Specify the "domain", in this particular case the local host name, for which the account is valid: [host name]\[user name], instead of just [user name].

You may notice, when adding your account to the privilige "logon as a batch job", that your local host name is added by default as domain, rather than just the local user name.

[Updated on: Fri, 09 April 2010 18:09]

Report message to a moderator

Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #510527 is a reply to message #430723] Mon, 06 June 2011 06:51 Go to previous messageGo to next message
Rekhanatraj
Messages: 1
Registered: June 2011
Junior Member
Hi,
Thanks a lot.... It worked for me....
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #614064 is a reply to message #132546] Thu, 15 May 2014 06:34 Go to previous messageGo to next message
gjn870
Messages: 2
Registered: May 2014
Junior Member
I also tried that Log on as a Batch Job.. But Its says Name not found..
Do u hv any solution? It will very usefull for me.. Thx..
Re: REMOTE OPERATION EXCEPTION: WRONG PASSWORD FOR USER [message #614065 is a reply to message #132546] Thu, 15 May 2014 06:36 Go to previous message
gjn870
Messages: 2
Registered: May 2014
Junior Member
I also tried that Log on as a Batch Job On win7.. But Its says Name not found.. I am sending u screenshot..
Do u hv any solution? It will very usefull for me.. Thx..
Previous Topic: Getting Chrome browser error "SSL connection error" Error code: ERR_SSL_PROTOCOL_ERROR after upgrade
Next Topic: Change times shown in EM Performance tab
Goto Forum:
  


Current Time: Mon Dec 22 21:55:33 CST 2014

Total time taken to generate the page: 0.12292 seconds