Home » Infrastructure » Windows » Getting ORA-01031 when submitting job using scheduler 'at'
icon5.gif  Getting ORA-01031 when submitting job using scheduler 'at' [message #266306] Mon, 10 September 2007 08:12
KCee
Messages: 16
Registered: October 2006
Junior Member
I meet the requirement on Windows:
1. in %ORACLE_HOME%\network\admin\sqlnet.ora:
SQLNET.AUTHENTICATION_SERVICES = (NTS)
2. I'm member of the local group ORA_DBA
(net localgroup ORA_DBA)

When I start a batch file, containing
'sqlplus "/ as sysdba"', this works fine.
When I submit this job using 'at', I get an ORA-01031 in the Event Viewer:
command:
Start --> cmd
at HH:MM cmd /c %TEMP%\test.cmd ^> %TEMP%\test.log

N.B. I have added SYSTEM to ORA_DBA:
net localgroup ORA_DBA SYSTEM /ADD
User 'NT AUTHORITY\SYSTEM' is now a member of ORA_DBA.

Looks fine, works fine on some Windows 2000 servers.
But now I've got a Windows 2000 server which shows the next error in the Event Viewer (Application):

Audit trail: ACTION : 'CONNECT' DATABASE USER: '/' PRIVILEGE : NONE CLIENT USER: SYSTEM CLIENT TERMINAL: <NODE> STATUS: 1031.

And that's strange, on other Windows 2000 servers I noticed that the CLIENT USER is 'NT AUTHORITY\SYSTEM', but on this server it is 'SYSTEM'.

I don't know why on this server the job using 'at' is using 'SYSTEM' instead of 'NT AUTHORITY\SYSTEM'.

In services the 'Task Scheduler' is using the Local System account.


Previous Topic: Silent pre configured Oracle 9i installation by using a deployment system
Next Topic: Listener and CPU utilization
Goto Forum:
  


Current Time: Fri Dec 09 21:42:13 CST 2016

Total time taken to generate the page: 0.23568 seconds