Home » RDBMS Server » Server Administration » Changing parallel_max_servers parameter
Changing parallel_max_servers parameter [message #263735] Thu, 30 August 2007 22:01 Go to next message
stevefox777
Messages: 26
Registered: September 2006
Junior Member
Hi,
I'm try to change the parallel_max_servers parameter from 5 to 2 with the command below but it fails with the error ORA-02095. Could someone tell me why this error is occurring and how too change this parameter?

SQL> alter system set parallel_max_servers=2 scope=both;
alter system set parallel_max_servers=2 scope=both
                 *
ERROR at line 1:
ORA-02095: specified initialization parameter cannot be modified


Any help will be appreciated.

Steve
Re: Changing parallel_max_servers parameter [message #263783 is a reply to message #263735] Fri, 31 August 2007 00:50 Go to previous messageGo to next message
Michel Cadot
Messages: 64131
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
SQL> alter system set parallel_max_servers=2 scope=both;

System altered.

ALWAYS post your Oracle version (4 decimals).

Regards
Michel
Re: Changing parallel_max_servers parameter [message #264158 is a reply to message #263735] Sat, 01 September 2007 03:42 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Also you specify about started your database whether with pfile or spfile?
Re: Changing parallel_max_servers parameter [message #264577 is a reply to message #264158] Mon, 03 September 2007 18:29 Go to previous messageGo to next message
stevefox777
Messages: 26
Registered: September 2006
Junior Member
Oracle version is 9.2.0.7.0.
I found out that it can be done with 'scope=spfile' option.
Re: Changing parallel_max_servers parameter [message #264594 is a reply to message #263735] Mon, 03 September 2007 22:01 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Also it should be done if you start your database by pfile. In that case specify pfile=memory.
Re: Changing parallel_max_servers parameter [message #264618 is a reply to message #264594] Mon, 03 September 2007 23:35 Go to previous message
Michel Cadot
Messages: 64131
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
In 9i, this parameter is static so you can't specify both or memory.
This is why you HAVE TO always post your version number, answer almost always depends on version.

Regards
Michel
Previous Topic: pwd file
Next Topic: control file block size.
Goto Forum:
  


Current Time: Wed Dec 07 14:22:11 CST 2016

Total time taken to generate the page: 0.09027 seconds