Home » Server Options » Data Guard » Getting error ORA-12154: TNS:could not resolve the connect identifier specified
Getting error ORA-12154: TNS:could not resolve the connect identifier specified [message #263007] Tue, 28 August 2007 14:18 Go to next message
kaustubh
Messages: 26
Registered: June 2007
Junior Member
Hi All,

Precondition:
Primary database is up
Standby database is down

Issue:
When I a trying to connect to Standby database from the Primary database I am getting the following error:
ORA-12154: TNS:could not resolve the connect identifier specified


But I do not get any error when Primary and Standby databases are up. (Primary is up and running and Standby is mounted as Standby)

Could you please help me understand the issue?

Thanks and regards,
Kaustubh Kane.
Re: Getting error ORA-12154: TNS:could not resolve the connect identifier specified [message #263018 is a reply to message #263007] Tue, 28 August 2007 14:38 Go to previous messageGo to next message
Michel Cadot
Messages: 64106
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-12154: TNS:could not resolve the connect identifier specified
 *Cause:  A connection to a database or other service was requested using
 a connect identifier, and the connect identifier specified could not
 be resolved into a connect descriptor using one of the naming methods
 configured. For example, if the type of connect identifier used was a
 net service name then the net service name could not be found in a
 naming method repository, or the repository could not be
 located or reached.
 *Action:
   - If you are using local naming (TNSNAMES.ORA file):
      - Make sure that "TNSNAMES" is listed as one of the values of the
        NAMES.DIRECTORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA)
      - Verify that a TNSNAMES.ORA file exists and is in the proper
        directory and is accessible.
      - Check that the net service name used as the connect identifier
        exists in the TNSNAMES.ORA file.
      - Make sure there are no syntax errors anywhere in the TNSNAMES.ORA
        file.  Look for unmatched parentheses or stray characters. Errors
        in a TNSNAMES.ORA file may make it unusable.
   - If you are using directory naming:
      - Verify that "LDAP" is listed as one of the values of the
        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA).
      - Verify that the LDAP directory server is up and that it is
        accessible.
      - Verify that the net service name or database name used as the
        connect identifier is configured in the directory.
      - Verify that the default context being used is correct by
        specifying a fully qualified net service name or a full LDAP DN
        as the connect identifier
   - If you are using easy connect naming:
      - Verify that "EZCONNECT" is listed as one of the values of the
        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA).
      - Make sure the host, port and service name specified
        are correct.
      - Try enclosing the connect identifier in quote marks.

   See the Oracle Net Services Administrators Guide or the Oracle
   operating system specific guide for more information on naming.

Quote:
When I a trying to connect to Standby database from the Primary database

You never do that.

Regards
Michel

Re: Getting error ORA-12154: TNS:could not resolve the connect identifier specified [message #263022 is a reply to message #263007] Tue, 28 August 2007 14:42 Go to previous message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
post the result of query


SQL> select DEST_ID,STATUS,ERROR
  2  from V$archive_dest
  3  where dest_id=2;

   DEST_ID STATUS
---------- ---------
ERROR
-----------------------------------------------------------------
         2 VALID

Previous Topic: after MRP is down why scn are being generated??
Next Topic: The Best form to make Backup DATA GUARD
Goto Forum:
  


Current Time: Mon Dec 05 02:35:25 CST 2016

Total time taken to generate the page: 0.11144 seconds