Home » RDBMS Server » Enterprise Manager » java.lang:exception error (merged)
java.lang:exception error (merged) [message #242006] Thu, 31 May 2007 05:59 Go to next message
abo_mahmoud
Messages: 31
Registered: May 2006
Location: UAE
Member
Sorry but I didn't know where to post this topic.
When I'm trying to enter Administration page at ORACLE 10g R2 the following message Appeared:

java.lang.Exception Exception in sending Request null

Does any one knows WHY.........
Re: java.lang.Exception [message #242308 is a reply to message #242006] Fri, 01 June 2007 09:45 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Are using XP??
Re: java.lang.Exception [message #242379 is a reply to message #242006] Fri, 01 June 2007 14:19 Go to previous messageGo to next message
abo_mahmoud
Messages: 31
Registered: May 2006
Location: UAE
Member
I got the solution ..............(Yes I'm using XP)
the cause is agentTZtime.............I should put Oracle compatible TZ then do some steps and oops it's working
Re: java.lang.Exception [message #242416 is a reply to message #242379] Fri, 01 June 2007 18:28 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Thanks for posting solution;)
Re: java.lang.Exception [message #242496 is a reply to message #242416] Sat, 02 June 2007 17:27 Go to previous messageGo to next message
abo_mahmoud
Messages: 31
Registered: May 2006
Location: UAE
Member
DreamzZ wrote on Fri, 01 June 2007 18:28
Thanks for posting solution;)


You welcome,that's why we 're in forum
icon9.gif  Re: java.lang.Exception [message #243324 is a reply to message #242006] Wed, 06 June 2007 22:51 Go to previous messageGo to next message
mivey4
Messages: 19
Registered: March 2007
Junior Member
Hey I am having the same problem. It would be nice if you provided more information for how the problem was resolved.

"the cause is agentTZtime.............I should put Oracle compatible TZ then do some steps and oops it's working "

What does this mean??? Embarassed

Can anyone provide more information on this problem and how to resolve it plz? It would be nice.

thx
Re: java.lang.Exception [message #243333 is a reply to message #243324] Wed, 06 June 2007 23:31 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Timezone mismatch agentTZRegion does not match the current environment TZ setting

To get Oracle's sweet Enterprise Manager Database Control web gui running, you'll need to use the Enterprise Manager control to start it. Use the following command:
emctl start dbconsole

The web gui runs on port 1158. For some reason, though my TZ environment variable matched what was in the emd.properties file, I got the following error:
[oracle@oracletest oracle]$ emctl start dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
http://oracletest.test.com:1158/em/console/aboutApplication

Timezone mismatch: The agentTZRegion value (EST) in
/oracle/oracletest.test.com_test/sysman/config/emd.properties
does not match the current environment TZ setting(EST).
The dbconsole cannot run with this mismatch.

If EST is the correct timezone, set your timezone environment variable to EST and repeat the 'emctl start dbconsole' operation.

If EST is not the correct timezone, make sure that the timezone in your environment is correct, and then run the following command in your local Oracle Home: 'emctl resetTZ agent'

The output of this command will include detailed instructions to follow, to correct the mismatch.

If I echo out my timezone, I see that it is set to EST:
[oracle@oracletest oracle]$ echo $TZ
EST

Then, I looked in the emd.properties file and saw that the agentTZRegion is set to the same:
[oracle@oracletest oracle]$ grep Z /oracle/oracletest.test.com_test/sysman/config/emd.properties
agentTZRegion=EST

What the heck? After a bit of googling, I saw someone simply unset the TZ environment variable and the dbconsole started up. So I did the same:
[oracle@oracletest oracle]$ unset TZ
[oracle@oracletest oracle]$ echo $TZ


This seemed to work for me as the dbconsole started and port 1158 was up and listening!
[oracle@oracletest oracle]$ emctl start dbconsole TZ set to US/Eastern
Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
http://oracletest.test.com:1158/em/console/aboutApplication
Starting Oracle Enterprise Manager 10g Database Control .............. started.
------------------------------------------------------------------
Logs are generated in directory /oracle/oracletest.test.com_test/sysman/log
[oracle@oracletest oracle]$
[root@oracletest oracle]# netstat -na grep 1158
tcp 0 0 0.0.0.0:1158 0.0.0.0:* LISTEN

Ah well..all's well that ends well!



http://www.techanswerguy.com/2007/04/timezone-mismatch-agenttzregion-does.html
icon8.gif  Re: java.lang.Exception [message #257472 is a reply to message #243333] Wed, 08 August 2007 07:43 Go to previous messageGo to next message
mjq_77
Messages: 1
Registered: August 2007
Junior Member
Hi I am also getting the same error but the problem is I am not getting error in emctl start dbconsole it works fine but still the error is same

M:\>emctl start dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
http://KHOL00173.s1.ms.unilever.com:1158/em/console/aboutApplication
Starting Oracle Enterprise Manager 10g Database Control ...The requested service has already been started.

More help is available by typing NET HELPMSG 2182.

Re: java.lang.Exception [message #257547 is a reply to message #257472] Wed, 08 August 2007 10:43 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Unset your TZ and then try.
see the above threads.

cmd>unset TZ
java.lang:exception error-(Shaya Sent2) [message #262223 is a reply to message #242006] Sat, 25 August 2007 07:04 Go to previous messageGo to next message
sh.hazeri
Messages: 12
Registered: August 2007
Junior Member
I have problem in running EM ,
I got message "java.lang:exception in sending request::null"
I saw the FAQ history about this problem and it seems to be relevant with time zone but I donot know what is the meaning of that.
where (in windows XP SP2) I should correct that and how , it would be convenient if some body could help me in detail with step by step instructions.
thanks
Re: java.lang:exception error-(Shaya Sent2) [message #262249 is a reply to message #262223] Sat, 25 August 2007 11:49 Go to previous messageGo to next message
krblr
Messages: 24
Registered: April 2007
Location: MD
Junior Member

Running what part of EM? did you get that message while logging-in? sending an email? creating a job? adding an administrator? creating a rule? also, what version of EM? so kindly be a little more specific ...
Re: java.lang:exception error-(Shaya Sent2) [message #262271 is a reply to message #262223] Sat, 25 August 2007 14:23 Go to previous messageGo to next message
sh.hazeri
Messages: 12
Registered: August 2007
Junior Member
I get this message at first in fact while logging-in when I enter the user name and password to enter EM(ver 10g) the next page shows this message.
I also set loop back adapter before installing oracle but have problem yet.
Re: java.lang.Exception [message #262272 is a reply to message #242379] Sat, 25 August 2007 14:29 Go to previous messageGo to next message
sh.hazeri
Messages: 12
Registered: August 2007
Junior Member
Hi I have the problem like you , could you please help my in detail what should i do to solve this problem ? i do not know where and how (in win Xp sp2) i should correct the time zone .
Re: java.lang.Exception [message #262300 is a reply to message #262272] Sun, 26 August 2007 01:39 Go to previous messageGo to next message
sh.hazeri
Messages: 12
Registered: August 2007
Junior Member
Hi again
CAN ANY BODY HELP ME IN THIS CASE ? ( regarding my previous reply)
I'm looking for.... Embarassed
regards
Re: java.lang.Exception [message #262302 is a reply to message #262300] Sun, 26 August 2007 01:44 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
On windows command prompt ( as mentioned by DreamZ)

start ==> run ==> cmd <<enter>>

cmd>unset TZ
cmd>set TZ  (correct value)



Regards
Taj
Re: java.lang.Exception [message #262312 is a reply to message #262302] Sun, 26 August 2007 02:09 Go to previous messageGo to next message
sh.hazeri
Messages: 12
Registered: August 2007
Junior Member
thank you for your reply :
1: the unset command didnot work actually windows did not know this command but SET works
2:I Issue : cmd>set EST
3:in emd.properties also put agentTZtime=EST
4:emctl stop dbconsole
5:emctl start dbconsole
unfortunatelly it does not work yet and I get the same Error message
also I do not know how and with which sppeling my correct time zone is so reffer to responses to this topic I set it to EST.
thank you again
look forward .... Razz
Re: java.lang.Exception [message #262313 is a reply to message #262312] Sun, 26 August 2007 02:13 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Sorry for mistake.

cmd> set TZ=


For unset TZ varible in windows you can just null in variable value.

Re: java.lang.Exception [message #262331 is a reply to message #262313] Sun, 26 August 2007 03:51 Go to previous messageGo to next message
sh.hazeri
Messages: 12
Registered: August 2007
Junior Member
I have problem yet . here is what I did :
1- set tz=
2- set tz=EST ( actually I Do not Know what is my Correct TZ where should I get it ? I set by guess)
3-emctl stop dbconsole
4-emctl start dbconsole

but does not work Embarassed

[Updated on: Sun, 26 August 2007 03:59]

Report message to a moderator

Re: java.lang.Exception [message #262333 is a reply to message #242006] Sun, 26 August 2007 04:04 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

You should search. I have raised this problem and from my wiki,

The reason of this problem:
this problem will appear if you just change the Time Zone of your system.

The Solution:
To solve this problem you need to run "emctl resetTZ agent" like this:

1- Open the command prompt and type
set oracle_sid=(your DB name)

2- Then Type this command
emctl resetTZ agent

3- You will see this message that will tell you what to do :

Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright  1996, 2005 Oracle Corporation. All rights reserved.
Updating D:\oracle\product\10.2.0\db_1/osama-pc_orcl/sysman/config/emd.properties...
Time zone set to Africa/Cairo.
To complete this process, you must either:
connect to the database served by this DBConsole as user 'sysman', and execute:
SQL> exec mgmt_target.set_agent_tzrgn('osama-pc:3938','Africa/Cairo')
-- or --
connect to the database served by this DBConsole as user 'sys', and execute:
SQL> alter session set current_schema = SYSMAN;
SQL> exec mgmt_target.set_agent_tzrgn('osama-pc:3938','Africa/Cairo

4- You must restart the DBCONSOLE Service Or reboot your machine and you will find that the problem has gone.
Re: java.lang.Exception [message #262334 is a reply to message #242006] Sun, 26 August 2007 04:06 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

So as user sysman you have to run operation which is not followed by you as it seems to me.
Re: java.lang.Exception [message #262372 is a reply to message #262334] Sun, 26 August 2007 12:25 Go to previous message
sh.hazeri
Messages: 12
Registered: August 2007
Junior Member
Thank you so much
with your recipe my problem was solved and thank you again Laughing
Previous Topic: Invalid Clone Bean Object when Clone DB
Next Topic: EM stopped working
Goto Forum:
  


Current Time: Thu Dec 08 16:19:04 CST 2016

Total time taken to generate the page: 0.15789 seconds