Home » RDBMS Server » Server Administration » upgrading to 10g
upgrading to 10g [message #262327] Sun, 26 August 2007 03:27 Go to next message
vijaychauhan
Messages: 106
Registered: December 2005
Senior Member
hi!
I am upgrading 9i release 2 database on windows 2000 to 1og r2 on windows 2000 manually using the catupgrad script.
First I, checked for upgrade using the upgrade requiste script, then I, started the database in startup upgrade and the created the sysaux tablespace, then I, ran the catupgrad scrpirt, but it gives the error package standard in not accessible.
When I, try to create the package standard using the available script , it does not create the package, what can be possible reason for this.
Re: upgrading to 10g [message #262329 is a reply to message #262327] Sun, 26 August 2007 03:31 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

, it does not create the package

Any error message is return ???

Re: upgrading to 10g [message #262360 is a reply to message #262327] Sun, 26 August 2007 09:12 Go to previous messageGo to next message
vijaychauhan
Messages: 106
Registered: December 2005
Senior Member
The error when I, run the upgrade script is
ora-06553 :pls-213 package standard not accessible.

The error when I, run the standard is
warning : package created with compilation errors.

create or replace
error at line 1
ora-06553:pls -213 package standard not accessible
grant succeeded.

Re: upgrading to 10g [message #262361 is a reply to message #262360] Sun, 26 August 2007 09:23 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Did you follow each step mentioned in README.TXT file for upgrade proccessing.???

Can you post few lines from upgrade log files


regards
Taj

Re: upgrading to 10g [message #262365 is a reply to message #262327] Sun, 26 August 2007 09:57 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
>what can be possible reason for this.
I suspect that ORACLE_HOME does not point to the 10g s/w tree.
Re: upgrading to 10g [message #262377 is a reply to message #262327] Sun, 26 August 2007 13:44 Go to previous messageGo to next message
vijaychauhan
Messages: 106
Registered: December 2005
Senior Member
Actaually I installed oracle 9i and then oracle 10g on the same server.
Both the software work fine independently.
I also upgarded using dbua and it worked fine.
But when I do it manually it gives problem.
The steps that I, followed for upgrade.
I made a 9i database and then copied the init file and pasted it 10g oracle_home/database.
Then I ran the prerequiste script to check the changes needed to make.
Then I, changed the size of shared pool and java pool as specified, then I, started the database in startup upgrade mode and created the sysaux tablespace.
Then when I, run the upgrade script it gives error.
Re: upgrading to 10g [message #262573 is a reply to message #262377] Mon, 27 August 2007 10:34 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
can you mentioin which script you RAN?
Re: upgrading to 10g [message #262598 is a reply to message #262327] Mon, 27 August 2007 16:29 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
>I made a 9i database and then copied the init file and pasted it 10g oracle_home/database.
If PATH is still using the V9 tree, I suspect you'll have problems.
Re: upgrading to 10g [message #262634 is a reply to message #262327] Mon, 27 August 2007 23:40 Go to previous message
vijaychauhan
Messages: 106
Registered: December 2005
Senior Member
hi!
The script the I, ran is catupgrad.sql.
Previous Topic: Oracle Version
Next Topic: when table altered?
Goto Forum:
  


Current Time: Thu Dec 08 12:39:11 CST 2016

Total time taken to generate the page: 0.06917 seconds