Home » RDBMS Server » Enterprise Manager » EM stopped working
EM stopped working [message #262108] Fri, 24 August 2007 09:33 Go to next message
Kingfisher
Messages: 40
Registered: August 2007
Location: Oslo, Norway
Member
Hi all

I have done no changes, and until yesterday EM worked just fine on my 10g install on XP, but now it refuses to service users...

When I start the service everything seems ok:
D:\Documents and Settings\XXXXXXXX>emctl start dbconsole
Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
http://XXXXXXXX:5500/em/console/aboutApplication
Starting Oracle Enterprise Manager 10g Database Control ...The OracleDBConsoleocp10g service is starting....
..............................................................................
The OracleDBConsoleocp10g service was started successfully.

Cannot connect, so I check emagent.trc. The last lines look like this:
(error = 10061)
2007-08-24 16:14:34 Thread-200 ERROR pingManager: nmepm_pingReposURL: Cannot connect to http://BEKK-RolfB.BEKK.no:5500/em/upload/: retStatus=-1
2007-08-24 16:14:36 Thread-200 WARN http: snmehl_connect: connect failed to (XXXXXXXXXX:5500): No connection could be made because the target machine actively refused it.

(error = 10061)
2007-08-24 16:14:36 Thread-200 ERROR pingManager: nmepm_pingReposURL: Cannot connect to http://XXXXXXXXXX:5500/em/upload/: retStatus=-1
2007-08-24 16:14:37 Thread-2192 WARN vpxoci: OCI Error -- ErrorCode(2391): ORA-02391: exceeded simultaneous SESSIONS_PER_USER limit

SQL = " OCISessionBegin"...
LOGIN = dbsnmp/<PW>@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=XXXXXXXXXX)(PORT=1521))(CONNECT_DATA=(SID=ocp10g)))
2007-08-24 16:14:38 Thread-2192 ERROR vpxoci: ORA-02391: exceeded simultaneous SESSIONS_PER_USER limit
2007-08-24 16:14:53 Thread-2192 WARN vpxoci: OCI Error -- ErrorCode(2391): ORA-02391: exceeded simultaneous SESSIONS_PER_USER limit

SQL = " OCISessionBegin"...
LOGIN = dbsnmp/<PW>@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=XXXXXXXXXX)(PORT=1521))(CONNECT_DATA=(SID=ocp10g)))
2007-08-24 16:14:53 Thread-2192 ERROR vpxoci: ORA-02391: exceeded simultaneous SESSIONS_PER_USER limit
2007-08-24 16:15:07 Thread-912 WARN http: snmehl_connect: connect failed to (XXXXXXXXXX:5500): No connection could be made because the target machine actively refused it.

(error = 10061)
2007-08-24 16:15:07 Thread-912 ERROR pingManager: nmepm_pingReposURL: Cannot connect to http://XXXXXXXXXX:5500/em/upload/: retStatus=-1
2007-08-24 16:15:08 Thread-2192 WARN vpxoci: OCI Error -- ErrorCode(2391): ORA-02391: exceeded simultaneous SESSIONS_PER_USER limit

SQL = " OCISessionBegin"...
LOGIN = dbsnmp/<PW>@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=XXXXXXXXXX)(PORT=1521))(CONNECT_DATA=(SID=ocp10g)))
2007-08-24 16:15:08 Thread-912 WARN http: snmehl_connect: connect failed to (XXXXXXXXXX:5500): No connection could be made because the target machine actively refused it.

(error = 10061)
2007-08-24 16:15:08 Thread-2192 ERROR vpxoci: ORA-02391: exceeded simultaneous SESSIONS_PER_USER limit
2007-08-24 16:15:08 Thread-912 ERROR pingManager: nmepm_pingReposURL: Cannot connect to http://BEKK-RolfB.BEKK.no:5500/em/upload/: retStatus=-1
2007-08-24 16:15:10 Thread-936 WARN http: snmehl_connect: connect failed to (XXXXXXXXXX:5500): No connection could be made because the target machine actively refused it.

(error = 10061)
2007-08-24 16:15:10 Thread-936 ERROR command: nmejcn: failed http connection to http://XXXXXXXXXX:5500/em/upload/: retStatus=-1
2007-08-24 16:15:13 Thread-2616 WARN http: 256,-1: nmehl_httpListener: signaled to exit from emctl

Anyone got any hints and tips to the solution?
Re: EM stopped working [message #262114 is a reply to message #262108] Fri, 24 August 2007 10:08 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
You trying to connect as NORMAL user?
Do you have ENABLE PROFILES?
Check the SESSIONS_PER_USER limit parameter of profile.
How many sessions you can open as a NORMAL user through SQL PLUS?
Post EMCTL STATUS?
Re: EM stopped working [message #262466 is a reply to message #262114] Mon, 27 August 2007 02:23 Go to previous messageGo to next message
Kingfisher
Messages: 40
Registered: August 2007
Location: Oslo, Norway
Member
DreamzZ wrote on Fri, 24 August 2007 17:08
You trying to connect as NORMAL user?

Yes.
Quote:
Do you have ENABLE PROFILES?

Yes.
Quote:
Check the SESSIONS_PER_USER limit parameter of profile.

I tried connecting with system a second time through sqlplus, and it failed. Too many concurrent users. So I set resource_limit=false, and now I could connect a second sqlplus with the same user. This did not solve the problem with enterprise manager, though.
Quote:
How many sessions you can open as a NORMAL user through SQL PLUS?

Don't know. This is just a testserver I use for certification tracks.
Quote:
Post EMCTL STATUS?

Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation.  All rights reserved.
http://XXXXXXXXXXXX:5500/em/console/aboutApplication
Oracle Enterprise Manager 10g is not running.

If I do a "emctl start dbconsole" I get this:
Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation.  All rights reserved.
http://XXXXXXXXXXXX:5500/em/console/aboutApplication
Starting Oracle Enterprise Manager 10g Database Control ...The requested service has already been started.

More help is available by typing NET HELPMSG 2182.
Re: EM stopped working [message #262470 is a reply to message #262466] Mon, 27 August 2007 02:31 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
Reconfigure your em repository.

1. 

E:\>set oracle_sid=db01

2.  

 DECLARE
 CURSOR c1 IS
 SELECT owner, synonym_name name
 FROM dba_synonyms
 WHERE table_owner = 'SYSMAN';

 BEGIN
 FOR r1 IN c1
 LOOP
 IF r1.owner = 'PUBLIC' THEN
 EXECUTE IMMEDIATE 'DROP PUBLIC SYNONYM '||r1.name;
 ELSE
 EXECUTE IMMEDIATE 'DROP SYNONYM '||r1.owner||'.'||r1.name;
 END IF;
 END LOOP;
 END;


PL/SQL procedure successfully completed.

DROP ROLE mgmt_user;

Role dropped.

DROP user mgmt_view cascade;

User dropped.

DROP user sysman cascade;

User dropped.

3. 

E:\>emca


http://dbataj.blogspot.com/2007/01/oc4j-configuration-issue.html

Regards
Taj
Re: EM stopped working [message #262476 is a reply to message #262466] Mon, 27 August 2007 02:50 Go to previous message
Kingfisher
Messages: 40
Registered: August 2007
Location: Oslo, Norway
Member
I restarted the services again, and now it worked!

Thanks for the help.
Previous Topic: java.lang:exception error (merged)
Next Topic: cannot expand database node
Goto Forum:
  


Current Time: Wed Dec 07 05:03:20 CST 2016

Total time taken to generate the page: 0.12760 seconds