Home » Developer & Programmer » Forms » "FRM-41042 no such property for set_item_property"
"FRM-41042 no such property for set_item_property" [message #261519] Wed, 22 August 2007 22:44 Go to next message
sams
Messages: 100
Registered: August 2007
Senior Member
i have written code to insert record in table:

declare
blk_name varchar(60);
form_name varchar(60);

begin
create_record;

form_name:=get_application_property(current_form_name);
blk_name:= get_form_property(form_name,first_block);
item_enable_disable(blk_name,property_on);

end;

And to save record i wrote code:

commit_form;


now i want to insert and save my record only when one button pressed.so when i combine this code this gives error message:
"FRM-41042 no such property for set_item_property"
it is inserting record properly but why this message occured?


full code:

declare
blk_name varchar(60);
form_name varchar(60);

begin
create_record;

form_name:=get_application_property(current_form_name);
blk_name:= get_form_property(form_name,first_block);
item_enable_disable(blk_name,property_on);
commit_form;
end;


any solution?
thnks
Re: "FRM-41042 no such property for set_item_property" [message #261548 is a reply to message #261519] Thu, 23 August 2007 00:47 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Because 'item_enable_disable' procecure (which you didn't post) contains invalid SET_ITEM_PROPERTY property.
Re: "FRM-41042 no such property for set_item_property" [message #261581 is a reply to message #261548] Thu, 23 August 2007 01:31 Go to previous messageGo to next message
sams
Messages: 100
Registered: August 2007
Senior Member
but when i run this code(procedure item_enable_disable) individually ,it runs sucessfully.
without any error message


when i write inser record code on "insert button" it runs sucessfully and insert record.
and when i write save code on save button "commit_form". it works sucessfully.


i want to write both codes on one button "insert and save"

"then error occurs"
FRM-41042 no such property for set_item_property
Re: "FRM-41042 no such property for set_item_property" [message #261630 is a reply to message #261581] Thu, 23 August 2007 03:03 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
How much would it cost if you, actually, post this procedure?
Re: "FRM-41042 no such property for set_item_property" [message #263747 is a reply to message #261630] Thu, 30 August 2007 23:32 Go to previous messageGo to next message
sams
Messages: 100
Registered: August 2007
Senior Member
This is the procedure:

PROCEDURE item_enable_disable(blk_name IN char , item_on_off IN NUMBER) IS
 nxt_itemname varchar2(70);
 itemtype varchar2(25);
 itemcanvas varchar2(25);
BEGIN
    nxt_itemname:=blk_name ||'.'||get_block_property(blk_name,first_item);
  loop
  	itemtype:=get_item_property(nxt_itemname,item_type);
  	itemcanvas:=get_item_property(nxt_itemname,item_canvas);
  	if (itemtype<>'DISPLY ITEM') and (itemcanvas is not null)
  		and (get_item_property(nxt_itemname,enabled) = 'TRUE')then 
  		set_item_property(nxt_itemname,updateable,ITEM_ON_OFF);
  	end if;
  	nxt_itemname:=blk_name||'.'||get_item_property(nxt_itemname,next_navigation_item);
  	if(nxt_itemname=blk_name||'.ROWID') then
  		exit;
  	end if;
  end loop;
END;





Re: "FRM-41042 no such property for set_item_property" [message #263769 is a reply to message #263747] Fri, 31 August 2007 00:16 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Quote:
set_item_property(nxt_itemname,updateable,ITEM_ON_OFF);

What is your Developer Suite version? Perhaps it does have those, but in my 10g
  • there's no UPDATEABLE property.
  • there's no PROPERTY_ON property value.

Open Forms Online Help System, navigate to SET_ITEM_PROPERTY built-in and search for valid combination of property and its value.
Re: "FRM-41042 no such property for set_item_property" [message #264117 is a reply to message #263769] Fri, 31 August 2007 22:49 Go to previous messageGo to next message
sams
Messages: 100
Registered: August 2007
Senior Member
i m using developer6i and oracle8i
Re: "FRM-41042 no such property for set_item_property" [message #264156 is a reply to message #264117] Sat, 01 September 2007 03:32 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I'm glad you are.

So, did you check information I suggested?
Re: "FRM-41042 no such property for set_item_property" [message #264215 is a reply to message #264156] Sun, 02 September 2007 01:44 Go to previous messageGo to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member

This is what I found on Oracle 10g Forms Reference:

Quote:

Propagation of Property Changes You can only specify a change to one item property at a time through the SET_ITEM_PROPERTY Built-in. However, one SET_ITEM_PROPERTY statement can cause changes to more than one item property if the additional changes are necessary to complete, or propagate, the intended change. This is included primarily for compatibility with prior versions.

The following table shows the SET_ITEM_PROPERTY settings that cause Oracle Forms to propagate changes across item properties:

Setting this property parameter...
To this setting
Also causes these propagated changes:

ENABLED
False
sets the Navigable item property to False
sets the Update_Null item property to False
sets the Updateable item property to False

VISIBLE
False
sets the Enabled and Navigable item properties to False
sets the Updateable item property to False
sets the Update_Null item property to False
sets the Queryable item property to False

UPDATEABLE
True
sets the Update_Null item property to False

UPDATE_NULL
True
sets the Updateable item property to False





Hope this Helps.

http://www.oracle.com/webapps/online-help/forms/10g/state?navSetId=_&navId=0

Re: "FRM-41042 no such property for set_item_property" [message #265941 is a reply to message #264215] Sat, 08 September 2007 00:54 Go to previous messageGo to next message
sams
Messages: 100
Registered: August 2007
Senior Member
where to set these properties.i m still confused.i m not getting your point.

reply
thnks
Re: "FRM-41042 no such property for set_item_property" [message #266516 is a reply to message #265941] Tue, 11 September 2007 01:35 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
The point is that 'ITEM_ON_OFF' is not a valid Oracle option.

Get a copy of the Reference manual, save it to your PC, your network drive, and your thumb drive. Do a find on 'SET_ITEM_PROPERTY' and READ it.

David
Re: "FRM-41042 no such property for set_item_property" [message #266531 is a reply to message #266516] Tue, 11 September 2007 01:52 Go to previous messageGo to next message
sams
Messages: 100
Registered: August 2007
Senior Member
thnks 4 suggession.But i have solved my problem. Laughing
Re: "FRM-41042 no such property for set_item_property" [message #266536 is a reply to message #266531] Tue, 11 September 2007 01:55 Go to previous messageGo to next message
bbaz
Messages: 138
Registered: April 2007
Senior Member
Glad to Know that you found the Solution Cool

Can you please POST it so that other can benefit from this Topic in the future.

Thanks,
Baz
Re: "FRM-41042 no such property for set_item_property" [message #404809 is a reply to message #266536] Sun, 24 May 2009 02:56 Go to previous messageGo to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
hi,
iam also getting same problem:
"FRM-41042 no such property for set_item_property"

iam using forms 10g.

i tried by making both update allowed,insert allowed as 'YES' and also 'NO'. i tried both 'yes' and 'no'.

even though i was not able to solve it.

thanks
jillu
Re: "FRM-41042 no such property for set_item_property" [message #404815 is a reply to message #261519] Sun, 24 May 2009 08:32 Go to previous message
cookiemonster
Messages: 12422
Registered: September 2008
Location: Rainy Manchester
Senior Member
I suggest you look up the allowed values in form builder help.
Previous Topic: How to use the like clause in Where
Next Topic: How I Can send SMS In from 6i
Goto Forum:
  


Current Time: Fri Dec 09 21:15:22 CST 2016

Total time taken to generate the page: 0.09048 seconds