Home » RDBMS Server » Backup & Recovery » ORA-00280..........
ORA-00280.......... [message #261011] Tue, 21 August 2007 09:19 Go to next message
naveenkumar001
Messages: 62
Registered: July 2007
Location: Bangalore
Member

Hi,
I got stuck up when i was doing recovery. Please help me.
I took backup of all the datafiles,redogfiles and controlfiles.
I opened the database and created table called student. After that I inserted values to it and purposely made log switch. So that when alter database recover command is given it should prompt the archive log file.

insert into student values(101);
alter system switch logfile;
insert into student values(102);
alter system switch logfile;
insert into student values(103);
alter system switch logfile; 

Three Archived log files got generated:-
1) ARC00001.001 2) ARC00002.001 3) ARC00003.001

After that I shutdown the database and opened the database and I got the following error:-
SQL> startup;
ORACLE instance started.

Total System Global Area 118255568 bytes
Fixed Size 282576 bytes
Variable Size 83886080 bytes
Database Buffers 33554432 bytes
Redo Buffers 532480 bytes
Database mounted.

ORA-01157: cannot identify/lock data file 9 - see DBWR trace file
ORA-01110: data file 9: 'C:\ORACLE\ORADATA\KARTHIK\NAVDBF.DBF'


After that I restored the datafile to its original location and when I gave alter database recover command I got the following error:-
SQL> alter database recover;
alter database recover
*
ERROR at line 1:
ORA-00279: change 271469 generated at 08/21/2007 18:05:51 needed for thread 1
ORA-00289: suggestion: C:\ORACLE\ADMIN\KARTHIK\ARCH\ARC00001.001
ORA-00280: change 271469 for thread 1 is in sequence #1


After that I gave the archived log name as follows and I got following error:-
SQL> ARC00001.001
SP2-0734: unknown command beginning "ARC00001.0..." - rest of line ignored.


What should I enter when it prompts for Archive files? Please guide me.

Regards,
Naveen
Re: ORA-00280.......... [message #261019 is a reply to message #261011] Tue, 21 August 2007 09:29 Go to previous messageGo to next message
Sanjay Bajracharya
Messages: 279
Registered: October 2001
Location: Florida
Senior Member
Did you let the archiver complete writing the archive logs and did you do a clean shutdown ?
Re: ORA-00280.......... [message #261033 is a reply to message #261019] Tue, 21 August 2007 09:48 Go to previous messageGo to next message
naveenkumar001
Messages: 62
Registered: July 2007
Location: Bangalore
Member

Hi Sanjay,
Archiving got completed and three Archives files got generated :-
1) ARC00001.001 2) ARC00002.001 3) ARC00003.001

After that i shutdown the database properly.

But when it prompted for archive log this time i gave absolute path and i got following error:-

SQL> C:\ORACLE\ADMIN\KARTHIK\ARCH\ARC00001.001;
SP2-0023: String not found.


Please guide me.

Regards,
Naveen
Re: ORA-00280.......... [message #261034 is a reply to message #261019] Tue, 21 August 2007 09:50 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
how did you take backup by closing the database online
SQL>alter database beging backup
or
SQL>alter tablespace beging backup
command?

After restoring your datafiles startup mount ans issue
SQL>recover database;
Re: ORA-00280.......... [message #261035 is a reply to message #261034] Tue, 21 August 2007 09:53 Go to previous messageGo to next message
naveenkumar001
Messages: 62
Registered: July 2007
Location: Bangalore
Member

Hi Dreamzland,

I took cold backup by shutting down the database.

Regards,
Naveen
Re: ORA-00280.......... [message #261036 is a reply to message #261035] Tue, 21 August 2007 09:54 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
did you try recover database by auto option?
Re: ORA-00280.......... [message #261041 is a reply to message #261036] Tue, 21 August 2007 10:04 Go to previous messageGo to next message
naveenkumar001
Messages: 62
Registered: July 2007
Location: Bangalore
Member

Hi,
Thank you for all your answers now its working fine.

Problem was I had not given the absolute path of archive log file.

Thank you for all your guidence.

Regards,
Naveen
Re: ORA-00280.......... [message #261043 is a reply to message #261041] Tue, 21 August 2007 10:07 Go to previous message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
you welcome Wink
by the way im not Dreamzland Laughing
Previous Topic: Incremental backup Doubt!
Next Topic: incremental vs. archive logs
Goto Forum:
  


Current Time: Fri Dec 09 23:34:48 CST 2016

Total time taken to generate the page: 0.12357 seconds