Home » Developer & Programmer » Precompilers, OCI & OCCI » lclntst10 not found error
lclntst10 not found error [message #259119] Tue, 14 August 2007 08:05 Go to next message
ijy_david
Messages: 7
Registered: August 2007
Location: UK
Junior Member
Hi,

I am trying 2 compile a pro* c program without a make file.
The objective is to get a 64 bit static library.

This is the command i give
cc +DA2.0W -o MGRWR01K FILLO01M.o MGRWR01K.o -L$ORACLE_HOME/lib -lclntst10

But am getting an error
ld: Mismatched ABI (not an ELF file) for -lclntst10, found /opt/oracle/product/10.2.0.3/lib/libclntst10.a
Fatal error.


If I give -lclntsh instead of -lclntst10, it compiles. But i need it static?

Could anyone please help me in this regard?

Regards,
Ijy
Re: lclntst10 not found error [message #267016 is a reply to message #259119] Wed, 12 September 2007 04:49 Go to previous messageGo to next message
KCee
Messages: 16
Registered: October 2006
Junior Member
Check if variable LPATH is set.
Is so, unset variable and try again.
Re: lclntst10 not found error [message #273080 is a reply to message #267016] Tue, 09 October 2007 01:17 Go to previous message
kmohan
Messages: 28
Registered: July 2005
Junior Member
Are you sure your OH/lib/libclntst10.a is of non-zero size? Try running OH/bin/genclntst which will recreate the full static library.
Previous Topic: Bind Variable, ORA-01008: not all variables bound
Next Topic: Problem with C++ STL string, getString() and VARCHAR...
Goto Forum:
  


Current Time: Wed Sep 17 12:42:36 CDT 2014

Total time taken to generate the page: 0.17621 seconds