Home » Developer & Programmer » Forms » forms upgrade problem:text line-height in forms 10g
forms upgrade problem:text line-height in forms 10g [message #258629] Mon, 13 August 2007 03:54 Go to next message
tassada
Messages: 6
Registered: August 2007
Junior Member
In forms upgrade....4.5 -> 6i -> 10g

The line-height of text field in the Forms 10g is much wider than the old forms(version 4.5 ,6i) text field.
Is there any relationship with the setting in the Jinitiator Or the Forms As conf?

Can any body help ...please... Embarassed

example:text layer only
4.5:
AAAAAAAAAAAAAA
AAAAAAAAAAAAAA

10g
AAAAAAAAAAAAAA

AAAAAAAAAAAAAA

[Updated on: Mon, 13 August 2007 03:56]

Report message to a moderator

Re: forms upgrade problem:text line-height in forms 10g [message #258944 is a reply to message #258629] Mon, 13 August 2007 18:56 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
A screen shot (in 8 bit colour) would have been more helpful for other readers but I understand the problem you are describing.

I assume that you have verified that the space between lines has been set to '0' (zero) and that you are using normal fonts on your windows environment. If my memory serves me correctly, there is nothing that you can do except make sure that you have the latest version of the JInitiator. You could try another Java interface driver but I don't think that it had nny effect over the laterst version of JInitiator. It just means that you may have to either remove a line from the block or move some of the items around on the screen. You may also have to make the items one character wider.

David
Re: forms upgrade problem:text line-height in forms 10g [message #259135 is a reply to message #258944] Tue, 14 August 2007 09:00 Go to previous messageGo to next message
tassada
Messages: 6
Registered: August 2007
Junior Member
to David
thank you for your advice.

;p
I didn't work today.
I'll send the pic of the forms tomorrow.



You mean it can be something wrong with my Jinitiator?
I remember my Jinitiator's version is 1.xx.25...
and I installed Jinitiator which version is 1.xx.26 too and ran forms in debug mode..It gave me the same odd layout..

I really confused...I see there is nothing wrong with Layout in Forms Developer 10g
but, IE show an other text style layout....

I don't wanna to modify over hundreds forms one by one.
especially I can't see the really layout when using Forms Developer 10g to fix this layout problem...

I'll give the pic example later..

[Updated on: Wed, 15 August 2007 01:49]

Report message to a moderator

Re: forms upgrade problem:text line-height in forms 10g [message #259250 is a reply to message #259135] Tue, 14 August 2007 19:30 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
You are using 'normal' fonts aren't you?

David
Re: forms upgrade problem:text line-height in forms 10g [message #259311 is a reply to message #259250] Wed, 15 August 2007 00:17 Go to previous messageGo to next message
tassada
Messages: 6
Registered: August 2007
Junior Member
TO David
I don't know about the meaning of the normal font, I am using Msゴシッン Font.
I had tried the Font 'New times Roman' , but still looked odd ...

-------------- -----------------
I don't know that why I cant edit my topic
I just put the screen shot of my Forms here.

This is the pic of the canvas in Form Dev. 10g
there is nothing wrong In the Canvas..
http://img128.imageshack.us/img128/1088/pic1sy4.th.jpg

This is the Screen shot of IE...
The text layer looks odd.
line height is not the same as the original source.
http://img520.imageshack.us/img520/3760/pic2rc3.th.jpg

this is the property of that text and my Jinitiator setting.
http://img366.imageshack.us/img366/8510/pic3qz3.th.jpg
http://img169.imageshack.us/img169/3063/pic4jo7.th.jpg

[Updated on: Wed, 15 August 2007 00:30]

Report message to a moderator

Re: forms upgrade problem:text line-height in forms 10g [message #259314 is a reply to message #259311] Wed, 15 August 2007 00:30 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I can only retrieve the first image. Please try posting the images again by saving the four images as files on your PC, then in the 'box' below the 'edit' window, press browse and point at a file, then press the 'upload file' button. You will have to do this for each file separately.

David
Re: forms upgrade problem:text line-height in forms 10g [message #259315 is a reply to message #259311] Wed, 15 August 2007 00:33 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Concerning 'normal' font, go to 'Start', 'Settings', 'Control Panel', 'Display', then 'Appearance'. Verify that the 'Font Size' is 'normal'.

David
Re: forms upgrade problem:text line-height in forms 10g [message #259340 is a reply to message #259315] Wed, 15 August 2007 01:45 Go to previous messageGo to next message
tassada
Messages: 6
Registered: August 2007
Junior Member
I had edited that message again....
somthing wrong with the url ..
sorry

[Updated on: Wed, 15 August 2007 01:52]

Report message to a moderator

Re: forms upgrade problem:text line-height in forms 10g [message #259341 is a reply to message #259340] Wed, 15 August 2007 01:46 Go to previous messageGo to next message
tassada
Messages: 6
Registered: August 2007
Junior Member
Layout in IE...
./fa/2892/0/
  • Attachment: pic2.JPG
    (Size: 22.93KB, Downloaded 330 times)
Re: forms upgrade problem:text line-height in forms 10g [message #259344 is a reply to message #259341] Wed, 15 August 2007 02:35 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I don't know whether this can be changed by changing either the font or the Java engine. If you have access to metalink you may be able to get them to have access to the bug that I logged 5 or 6 years ago concerning this issue. Unfortunately, I now work for a different company and do not have access to the bug.

I did a general search and found https://metalink.oracle.com/metalink/plsql/f?p=200:27:3844605719372891943::::p27_id,p27_show_header,p27_show_help:579409.993,1,1 have a look at it and see what you think.

David
Previous Topic: Add Bookmark using Webutil
Next Topic: How to user Alert in form
Goto Forum:
  


Current Time: Wed Dec 07 04:43:44 CST 2016

Total time taken to generate the page: 0.21931 seconds