Home » RDBMS Server » Backup & Recovery » RMAN Clone Operation Fails with RMAN-05001
RMAN Clone Operation Fails with RMAN-05001 [message #258452] Sun, 12 August 2007 01:10 Go to next message
Chewie71
Messages: 19
Registered: October 2005
Location: WIU
Junior Member
Hi,

I'm having trouble getting an RMAN clone to work. I've followed the steps here (http://www.idevelopment.info/data/Oracle/DBA_tips/RMAN_9i/RMAN9_31.shtml#Steps%20Required) but am still running into the RMAN-05001 error (auxiliary filename ... conflicts with a file used by the target db).

I've created the 'initCLONESID.ora' file over on the clone server in $ORACLE_HOME/dbs. In that file I added the db_file_name_convert and log_file_name_convert parameters so that during the clone operation RMAN knows where the data files go on the clone server.

For some reason I am still getting this RMAN-05001 error and I've been messing with this for hours. Anyone have an idea why it's giving me this problem?

Is the 'initCLONESID.ora' file supposed to be on the target(production) server? I'm pretty sure it's supposed to be on the auxiliary(clone) server, but just in case I was reading the docs wrong I put a copy over on the target...still have the same issue.

I can post the configuration files if you want to see them, but maybe someone knows right off the top of their head where I might find my problem.

Thanks,
Matt
Re: RMAN Clone Operation Fails with RMAN-05001 [message #258453 is a reply to message #258452] Sun, 12 August 2007 01:19 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

(auxiliary filename ... conflicts with a file used by the target db).

Did you set "db_file_convert_name" or "log_file_convert_name" parameters ?



Regards
Taj

[Updated on: Sun, 12 August 2007 01:19]

Report message to a moderator

Re: RMAN Clone Operation Fails with RMAN-05001 [message #258454 is a reply to message #258453] Sun, 12 August 2007 01:29 Go to previous messageGo to next message
Chewie71
Messages: 19
Registered: October 2005
Location: WIU
Junior Member
Yes...second paragraph of my original post.

I placed those lines in the 'initCLONESID.ora' file on the auxiliary server. Maybe that's the wrong place?

Matt
Re: RMAN Clone Operation Fails with RMAN-05001 [message #258455 is a reply to message #258454] Sun, 12 August 2007 01:33 Go to previous message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

I placed those lines in the 'initCLONESID.ora' file on the auxiliary server. Maybe that's the wrong place?

That is right place but you edit "init<sid>.ora" file ...and may be your instance startup with "spfile<sid>.ora" file ...so did you recreate your spfile after edit pfile to make changes in spfile.


Again Review both parameters.

Check it if you doing cloning on same machine.

http://dbataj.blogspot.com/2006/12/duplicating-database-with-recovery.html

Previous Topic: How to recover redologfile, which is deleted
Next Topic: Automatic or Managed Recovery
Goto Forum:
  


Current Time: Sun Dec 04 06:28:33 CST 2016

Total time taken to generate the page: 0.05555 seconds