Home » Developer & Programmer » Forms » problem of populating record group
problem of populating record group [message #258315] Sat, 11 August 2007 00:23 Go to next message
fam_bila
Messages: 43
Registered: August 2007
Location: pakistan
Member
helo,
i made a record group name as "RECORD_GROUP2"
on this i write code

select session_no
from sesion


then i made a canvas , on canvas i place a list item name as "list_id" and a button label as "id" now i want that when i click on button the data of record group populated on list item, for this i write code on button

BEGIN
Populate_List('list_id','RECORD_GROUP2');
END;


but on complation i got a error

FRM-30351: No list elements defined for list item.
List LIST_ID


and on runtime when click on button an error occour

invalid record group for list population

now please tell me what is the problem with this process.

thanx
Re: problem of populating record group [message #258323 is a reply to message #258315] Sat, 11 August 2007 00:36 Go to previous messageGo to next message
azamkhan
Messages: 548
Registered: August 2005
Senior Member
do you have another record group under the same name?
Re: problem of populating record group [message #258326 is a reply to message #258323] Sat, 11 August 2007 00:56 Go to previous messageGo to next message
fam_bila
Messages: 43
Registered: August 2007
Location: pakistan
Member
no i have not. there is only one record group wd this name.
Re: problem of populating record group [message #258508 is a reply to message #258315] Sun, 12 August 2007 20:14 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
If you have defined the record_group in the Forms Builder and associated it with an LOV and associated that LOV with an item you don't need to do a manual 'populate_list'. It will be done by the Form at runtime. Remove the manual 'populate_list' and see what happens.

David
Re: problem of populating record group [message #258602 is a reply to message #258508] Mon, 13 August 2007 03:06 Go to previous messageGo to next message
musman
Messages: 147
Registered: July 2007
Location: Lahore
Senior Member

is ur problem solved ..
else tell me ..am using code on trigger at form level ..
WHEN_NEW_FORM instance..
it will populate group at run time ..from datadase each time ..
if ur problem solved before then its ok
Re: problem of populating record group [message #259600 is a reply to message #258508] Thu, 16 August 2007 01:46 Go to previous messageGo to next message
fam_bila
Messages: 43
Registered: August 2007
Location: pakistan
Member
as u say :
If you have defined the record_group in the Forms Builder and associated it with an LOV and associated that LOV with an item you don't need to do a manual 'populate_list'. It will be done by the Form at runtime. Remove the manual 'populate_list' and see what happens.

so:
i make a record_group and associate it with a LOV. but i don't know how to associate it with the list item.

plz tell me
waiting ur reply
thanx
Re: problem of populating record group [message #259623 is a reply to message #258315] Thu, 16 August 2007 02:31 Go to previous messageGo to next message
sispk6
Messages: 164
Registered: November 2006
Location: pakistan
Senior Member
1...dont enclose LIST_ID in quotes or use list_name
or
2... compare the data types for campatability
or
3 ... increase the length of field you want to populate
or
4 ... use id_null to verify whether list_id is found or not

regards

PEACE
Re: problem of populating record group [message #259627 is a reply to message #258602] Thu, 16 August 2007 02:35 Go to previous messageGo to next message
fam_bila
Messages: 43
Registered: August 2007
Location: pakistan
Member
hi,
our problem doesnot seems to solved please tell us how can we use form trigger "when new form instance" to populate record group at runtime.
thanx
Re: problem of populating record group [message #259632 is a reply to message #259623] Thu, 16 August 2007 02:40 Go to previous messageGo to next message
sispk6
Messages: 164
Registered: November 2006
Location: pakistan
Senior Member
OHH MAN
your record group does not exist first check it,
whenever you create any item, check its existance by using
" id_null" ( strongly recommended).
regards


PEACE
Re: problem of populating record group [message #259638 is a reply to message #259632] Thu, 16 August 2007 02:48 Go to previous messageGo to next message
musman
Messages: 147
Registered: July 2007
Location: Lahore
Senior Member

declare
	rg_name VARCHAR2(40) :='TYPEID';
	rg_id RecordGroup;
	gc_id GroupColumn;
	errcode NUMBER;
	
begin
	CLEAR_LIST('EMPLOYEE.TYPE_ID');
      --CLEAR_LIST('groupname,itemname)this is what u have to   write here
	rg_id := Find_Group(rg_name);
	IF Id_Null(rg_id) then
		rg_id := Create_Group(rg_name);
	  gc_id := Add_Group_Column(rg_id,'DESCRIPTION',CHAR_COLUMN,60);	
		gc_id := Add_Group_Column(rg_id,'TYPE_ID',CHAR_COLUMN,3);
	
	end if;
	errcode := Populate_Group_With_Query(rg_id,'select description,type_id from emp_type');--write your query in it..
	POPULATE_LIST('EMPLOYEE.TYPE_ID',RG_ID);
        --groupname,itemname
end;


--------------------------------------
use this code in trigger when_new_form_instance
at form level
IS IT OK

[Updated on: Thu, 16 August 2007 02:55]

Report message to a moderator

Re: problem of populating record group [message #259974 is a reply to message #259638] Fri, 17 August 2007 01:18 Go to previous messageGo to next message
fam_bila
Messages: 43
Registered: August 2007
Location: pakistan
Member
hi
we have tried almost every possible solution to solve our problem
but not succeded.

the way you told us also tried but we have an error as:
FRM-30351: No list elements defined for list item.

plese help us.
thanx
Re: problem of populating record group [message #259999 is a reply to message #259974] Fri, 17 August 2007 02:19 Go to previous messageGo to next message
musman
Messages: 147
Registered: July 2007
Location: Lahore
Senior Member

then plz send me ur form..also ur schema (tables involve in it)..
i will do it on week end ..
then will send u back..
If it is possible for you..
Re: problem of populating record group [message #260333 is a reply to message #258315] Sat, 18 August 2007 09:31 Go to previous messageGo to next message
hemavb
Messages: 103
Registered: May 2007
Location: Dubai , UAE
Senior Member
fam_bila,

In the list item at desgin time put a black line in the List elements. Element label as single space and element value as single space.

The eror that you are specifyin will go off.

When you are populating a list dynamically, the procedure will always overwrite/replace any details tthat you have defined at design time.

Regards-
Hemavb
Re: problem of populating record group [message #260502 is a reply to message #259999] Mon, 20 August 2007 03:03 Go to previous messageGo to next message
fam_bila
Messages: 43
Registered: August 2007
Location: pakistan
Member
sir,
kindly give us ur email id so that we can send u our docments
Re: problem of populating record group [message #260548 is a reply to message #260502] Mon, 20 August 2007 05:07 Go to previous message
musman
Messages: 147
Registered: July 2007
Location: Lahore
Senior Member

manizzzz@gmail.com
Previous Topic: Want help in coding
Next Topic: Calling a form from another form
Goto Forum:
  


Current Time: Thu Dec 08 08:48:02 CST 2016

Total time taken to generate the page: 0.05868 seconds