Home » Developer & Programmer » Forms » Help For Tree in Form 6i
Help For Tree in Form 6i [message #257688] Thu, 09 August 2007 00:38 Go to next message
alijeyan
Messages: 180
Registered: January 2007
Location: IRAN
Senior Member
i want use the Heirarchical tree in My form .

when i use static Record group tree is Fine but when i put data

in table and use record group fom table tree is empty .

i use this code for populate tree :

declare
htree item ;
begin
htree:=find_item ('my_block.tree1');
ftree.populate_tree(htree);
end;

my data in table is

initail_stat depth lable icon data

-1 1 car '' car
0 2 honda '' civic
1 1 airplane '' plane
0 2 boing '' 747
0 2 boing '' 757

and my record group is

select initail_stat,depth,lable,icon,data from table_tree;

please help me.

ThanQ IRAN ALI
Re: Help For Tree in Form 6i [message #259069 is a reply to message #257688] Tue, 14 August 2007 06:10 Go to previous messageGo to next message
hemavb
Messages: 103
Registered: May 2007
Location: Dubai , UAE
Senior Member
Use "1" as the initstate for the first line instead of "-1".
It will work.
Re: Help For Tree in Form 6i [message #259208 is a reply to message #259069] Tue, 14 August 2007 11:44 Go to previous messageGo to next message
alijeyan
Messages: 180
Registered: January 2007
Location: IRAN
Senior Member
ThanQ
i use 1 instead -1 .
but do not work .
Re: Help For Tree in Form 6i [message #259252 is a reply to message #259208] Tue, 14 August 2007 19:34 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Don't keep us in suspense!!! Show us the code!! Tell us the error code and error message!! Tell us what you tried to do and what result you received.

David
Re: Help For Tree in Form 6i [message #259782 is a reply to message #257688] Thu, 16 August 2007 08:56 Go to previous messageGo to next message
hemavb
Messages: 103
Registered: May 2007
Location: Dubai , UAE
Senior Member
Alijeyan,

We will need to see the code if we have to help you fix it.

-Hemavb

[Updated on: Thu, 16 August 2007 08:56]

Report message to a moderator

Re: Help For Tree in Form 6i [message #260924 is a reply to message #259782] Tue, 21 August 2007 04:56 Go to previous messageGo to next message
alijeyan
Messages: 180
Registered: January 2007
Location: IRAN
Senior Member
Thanq All

i sent my code .

in this code i have 2 Tree :
1 - Tree15 with static record_group and work
2 - Tree13 with query record_group annd not work

please help me .
  • Attachment: TEST_TREE.fmb
    (Size: 44.00KB, Downloaded 206 times)
Re: Help For Tree in Form 6i [message #260940 is a reply to message #257688] Tue, 21 August 2007 05:29 Go to previous messageGo to next message
hemavb
Messages: 103
Registered: May 2007
Location: Dubai , UAE
Senior Member
when using a query to fetch a tree... donot use the "record group" property, use the "data query" property.

If you take the querry from your rg_query record group and put it in the "data query" property of tree13, the application works.

SO here is your solution.

oh yeah... donot forget to make the "record group"property for tree 13 null.

[Updated on: Tue, 21 August 2007 05:29]

Report message to a moderator

icon14.gif  Re: Help For Tree in Form 6i [message #260958 is a reply to message #260940] Tue, 21 August 2007 06:26 Go to previous messageGo to next message
alijeyan
Messages: 180
Registered: January 2007
Location: IRAN
Senior Member
ThanQ Very Much Hemvab

I Live in IRAN ... Please Say what you Like From IRAN . I Can send to You

ThanX

icon6.gif  Re: Help For Tree in Form 6i [message #260968 is a reply to message #257688] Tue, 21 August 2007 06:47 Go to previous message
hemavb
Messages: 103
Registered: May 2007
Location: Dubai , UAE
Senior Member
Thanks a lot.
We are here to help you out. Thats what a forum is all about.

Enjoy. Cool
Previous Topic: set_canvas_property
Next Topic: please send me Oracle Forms 6i Documentation or tutorial(links)
Goto Forum:
  


Current Time: Sun Dec 04 16:49:09 CST 2016

Total time taken to generate the page: 0.09515 seconds