Home » RDBMS Server » Server Administration » ORA-04043: object RAY.MTE_LOG does not exist
ORA-04043: object RAY.MTE_LOG does not exist [message #256821] Mon, 06 August 2007 15:34 Go to next message
caprikar
Messages: 226
Registered: March 2007
Senior Member
Hi,
I have a user called RAY in which I have a table MTE_LOG.

I created a ROLE RAY_SELECT and did,
grant select on RAY.MTE_LOG to RAY_SELECT;
Also I granted RAY_SELECT to another user called MIG,
grant RAY_SELECT to MIG;

But when I try to
select * from RAY.MTE_LOG ;
I'm getting -->

ORA-04043: object RAY.MTE_LOG does not exist

can anyone tell me why?

Thanks,
GK
Re: ORA-04043: object RAY.MTE_LOG does not exist [message #256841 is a reply to message #256821] Mon, 06 August 2007 21:48 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
It works for me.
 sqlplus

SQL*Plus: Release 10.2.0.2.0 - Production on Mon Aug 6 19:44:21 2007

Copyright (c) 1982, 2005, Oracle.  All Rights Reserved.

Enter user-name: / as sysdba

Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.2.0 - 64bit Production
With the Partitioning, OLAP and Data Mining options

SQL> @fubar
SQL> create user ray identified by ID10T default tablespace users temporary tablespace temp;

User created.

SQL> grant create session to ray;

Grant succeeded.

SQL> grant create table to ray;

Grant succeeded.

SQL> grant create ROLE  to ray;

Grant succeeded.

SQL> GRANT UNLIMITED TABLESPACE TO ray;

Grant succeeded.

SQL> create user MIG identified by FUBAR default tablespace users temporary tablespace temp;

User created.

SQL> grant create session to mig;

Grant succeeded.

SQL> connect ray/ID10T
Connected.
SQL> create table MTE_LOG (ID varchar2(8));

Table created.

SQL> insert into MTE_LOG VALUES ('TEST');

1 row created.

SQL> create role ray_select;

Role created.

SQL> grant select on RAY.MTE_LOG to RAY_SELECT;

Grant succeeded.

SQL> grant RAY_SELECT to MIG;

Grant succeeded.

SQL> connect MIG/FUBAR
Connected.
SQL> select * from RAY.MTE_LOG;

ID
--------
TEST

SQL> 

So, what did you do wrong or not do right?
Re: ORA-04043: object RAY.MTE_LOG does not exist [message #257102 is a reply to message #256841] Tue, 07 August 2007 10:28 Go to previous message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Oracle Troubleshooting ORA-04043
http://www.cryer.co.uk/brian/oracle/ORA04043.htm
Previous Topic: Oracle user process
Next Topic: ORA-00305
Goto Forum:
  


Current Time: Sat Dec 03 08:11:08 CST 2016

Total time taken to generate the page: 0.10659 seconds