Home » SQL & PL/SQL » Client Tools » Connection using sql*plus
Connection using sql*plus [message #256447] Sat, 04 August 2007 16:02 Go to next message
surenhr
Messages: 45
Registered: August 2007
Location: gurgoan
Member
Hi guyz,
I am able to connect to my databse using
SQL> conn suren/suren@sct
Connected.

But i heard somewhere that we can connect using username and password only;

for that i have set ORACLE_SID=c:\oracle\oradata\sct;.;

but still its not working,it shows the following error.

SQL> connect suren/suren
ERROR:
ORA-12560: TNS:protocol adapter error

all services are active for oracle.
Re: Connection using sql*plus [message #256456 is a reply to message #256447] Sat, 04 August 2007 17:03 Go to previous messageGo to next message
BlackSwan
Messages: 25038
Registered: January 2009
Location: SoCal
Senior Member
>for that i have set ORACLE_SID=c:\oracle\oradata\sct;.;
Why did you choose this collection of incorrect characters?
Do you know what is your SID?
Are you logged directly on the same system where the DB resides?
Re: Connection using sql*plus [message #256469 is a reply to message #256456] Sat, 04 August 2007 23:51 Go to previous messageGo to next message
Michel Cadot
Messages: 64111
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Sometimes I have the strange feeling that some randomly try things and as this of course doesn't work, post.

How to make them understand that Oracle is not a toy and it needs read and work to make it work?

Regards
Michel
Re: Connection using sql*plus [message #256473 is a reply to message #256447] Sat, 04 August 2007 23:56 Go to previous messageGo to next message
BlackSwan
Messages: 25038
Registered: January 2009
Location: SoCal
Senior Member
This OP may have used this forum a WONR drive (as opposed to WORM); Write Once Never Read (Write Once Read Many)
Re: Connection using sql*plus [message #256474 is a reply to message #256473] Sun, 05 August 2007 00:02 Go to previous messageGo to next message
Michel Cadot
Messages: 64111
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Laughing
Nice to start a Sunday laughing.
Btw, what are you doing here on Saturday evening?

Regards
Michel
Re: Connection using sql*plus [message #256477 is a reply to message #256447] Sun, 05 August 2007 00:11 Go to previous messageGo to next message
BlackSwan
Messages: 25038
Registered: January 2009
Location: SoCal
Senior Member
I'm winding down from a long, long week at work & a equally long one on a personal level.
http://www.acuraclassic.com/
It as just up the road a few miles & we've been season tickets holder since 1991.
I've noticed that you are an early morning person base upon when you start online every day.
You are usually up before I go to bed; which is Goodness for this forum.
We have it covered 24x7.

More later!
Re: Connection using sql*plus [message #256512 is a reply to message #256477] Sun, 05 August 2007 08:16 Go to previous messageGo to next message
surenhr
Messages: 45
Registered: August 2007
Location: gurgoan
Member
Yeah i m logged on to the same system where my DB resides.
Re: Connection using sql*plus [message #256515 is a reply to message #256512] Sun, 05 August 2007 08:31 Go to previous messageGo to next message
Michel Cadot
Messages: 64111
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
Do you know what is your SID?

You didn't answer to this question.
Do we have to assume that you don't?

Regards
Michel
Re: Connection using sql*plus [message #256522 is a reply to message #256447] Sun, 05 August 2007 08:44 Go to previous messageGo to next message
surenhr
Messages: 45
Registered: August 2007
Location: gurgoan
Member
SID defaults to the database name.
name of my database is suren.
Re: Connection using sql*plus [message #256523 is a reply to message #256522] Sun, 05 August 2007 08:49 Go to previous messageGo to next message
Michel Cadot
Messages: 64111
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
So set ORACLE_SID to this name.

Regards
Michel
Re: Connection using sql*plus [message #256526 is a reply to message #256523] Sun, 05 August 2007 09:08 Go to previous message
surenhr
Messages: 45
Registered: August 2007
Location: gurgoan
Member
Thanks alot Sir ..
it works ..Smile
Previous Topic: Drop User Command Help
Next Topic: doubt in sql*plus
Goto Forum:
  


Current Time: Mon Dec 05 15:05:27 CST 2016

Total time taken to generate the page: 0.31388 seconds