Home » RDBMS Server » Performance Tuning » Problem when installing statspack  () 1 Vote
Problem when installing statspack [message #255631] Wed, 01 August 2007 06:12 Go to next message
chaitanya_krishna
Messages: 8
Registered: August 2007
Junior Member
When running the spcreate.sql file
it is taking the perfstat password,
perfstat's default table space,
perfstat's temporary table space,
till the point ,it is ok,
but after that
when executing the statement
connect PERFSTAT/&&perfstat_password
it is showing network adaptor error.
what may be the reason and how to scrutiny this.
Re: Problem when installing statspack [message #255637 is a reply to message #255631] Wed, 01 August 2007 06:42 Go to previous messageGo to next message
Michel Cadot
Messages: 64116
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You have to first locally connect as sysdba without using network syntax (@...).

Instead of saying what you did, post (copy and paste) your SQL*Plus session.
But before that read How to format your posts.
Make sure that lines of code do not exceed 80 or 100 characters when you format.
Please always post your Oracle version (4 decimals).

Regards
Michel

Re: Problem when installing statspack [message #255819 is a reply to message #255631] Wed, 01 August 2007 23:04 Go to previous messageGo to next message
chaitanya_krishna
Messages: 8
Registered: August 2007
Junior Member
Hi,
when executing the spcreate.sql file,
till @@spcuser,it is ok,after that when executing the statement,
see the below file and the statement 'connect PERFSTAT/PERFSTAT6'

SQL> connect PERFSTAT/PERFSTAT6;
ERROR:
ORA-12560: TNS:protocol adapter error

Warning: You are no longer connected to ORACLE.

Rem
Rem $Header: spcreate.sql 16-apr-2002.11:22:55 vbarrier Exp $
Rem
Rem spcreate.sql
Rem
Rem Copyright (c) 1999, 2002, Oracle Corporation. All rights
reserved.
Rem
Rem NAME
Rem spcreate.sql - Statistics Create
Rem
Rem DESCRIPTION
Rem SQL*PLUS command file which creates the STATSPACK user,
Rem tables and package for the performance diagnostic tool
STATSPACK
Rem
Rem NOTES
Rem Note the script connects INTERNAL and so must be run from
Rem an account which is able to connect internal.
Rem
Rem MODIFIED (MM/DD/YY)
Rem cdialeri 02/16/00 - 1191805
Rem cdialeri 12/06/99 - 1103031
Rem cdialeri 08/13/99 - Created
Rem
--
-- Create PERFSTAT user and required privileges
@@spcusr
--
-- Build the tables and synonyms
connect PERFSTAT/PERFSTAT6
@@spctab
-- Create the statistics Package
@@spcpkg
Re: Problem when installing statspack [message #255821 is a reply to message #255819] Wed, 01 August 2007 23:26 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,

1.check Oracle Service is started.
2.use TNS ENTRY with username/ password@TNS_ENTRY
3.set Oracle_sid variable.


Regards
Taj
Re: Problem when installing statspack [message #255828 is a reply to message #255819] Thu, 02 August 2007 00:29 Go to previous messageGo to next message
chaitanya_krishna
Messages: 8
Registered: August 2007
Junior Member
Hi All,
my problem was solved.
thanks & regards
Re: Problem when installing statspack [message #255831 is a reply to message #255631] Thu, 02 August 2007 00:34 Go to previous messageGo to next message
BlackSwan
Messages: 25039
Registered: January 2009
Location: SoCal
Senior Member
Please post solution for benefit of others.
Re: Problem when installing statspack [message #255837 is a reply to message #255831] Thu, 02 August 2007 00:52 Go to previous messageGo to next message
chaitanya_krishna
Messages: 8
Registered: August 2007
Junior Member
Definitely i will do it,
Thanks
Re: Problem when installing statspack [message #255839 is a reply to message #255837] Thu, 02 August 2007 00:54 Go to previous messageGo to next message
Michel Cadot
Messages: 64116
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
When?

Regards
Michel
Re: Problem when installing statspack [message #255853 is a reply to message #255631] Thu, 02 August 2007 02:25 Go to previous messageGo to next message
chaitanya_krishna
Messages: 8
Registered: August 2007
Junior Member
if anybody face similar problems,
i will post my response,
i didn't understand what you mean by when,

Regards,
Re: Problem when installing statspack [message #255855 is a reply to message #255853] Thu, 02 August 2007 02:32 Go to previous messageGo to next message
Michel Cadot
Messages: 64116
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Why don't you post your solution right now?

Regards
Michel
Re: Problem when installing statspack [message #255908 is a reply to message #255631] Thu, 02 August 2007 05:47 Go to previous messageGo to next message
chaitanya_krishna
Messages: 8
Registered: August 2007
Junior Member
Hi Cadot,
ok, i got the point,now it-self i am posting the answer.
here onwards i will do it immediately.
This is the solution.

in spcreate.sql change the line

Old line:
connect perfstat/&&perfstat_password

New line:
connect perfstat/&&perfstat_password@(DESCRIPTION =(ADDRESS = (PROTOCOL = TCP)(HOST = 172.24.103.424)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED)(SERVICE_NAME = XE)))

Now i was able to coneect it.
Re: Problem when installing statspack [message #255913 is a reply to message #255908] Thu, 02 August 2007 06:11 Go to previous messageGo to next message
Michel Cadot
Messages: 64116
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
This is why I said:
Quote:
You have to first locally connect as sysdba without using network syntax (@...).

There you are sure to use the correct script, the one for the database version.
Are you sure your remote version is the correct one?

Regards
Michel
Re: Problem when installing statspack [message #255924 is a reply to message #255631] Thu, 02 August 2007 07:19 Go to previous messageGo to next message
chaitanya_krishna
Messages: 8
Registered: August 2007
Junior Member
Frankly,
i had not seen the reply.
when i open the script,i got that idea.
i connected by giving the tns string, i tried and i succssed.
then when i open the forum, i had seen the reply.
any way thanks for your suggestion.
for me i am working on a remote one.
Re: Problem when installing statspack [message #256186 is a reply to message #255631] Fri, 03 August 2007 06:23 Go to previous message
chaitanya_krishna
Messages: 8
Registered: August 2007
Junior Member
ok
Previous Topic: Temp Datafiles Size
Next Topic: Sort Area Size - ORA-600 & ORA-02097 (merged)
Goto Forum:
  


Current Time: Tue Dec 06 02:37:16 CST 2016

Total time taken to generate the page: 0.07127 seconds