Home » Developer & Programmer » Forms » Problem in navigating the buttons.
Problem in navigating the buttons. [message #255608] Wed, 01 August 2007 05:01 Go to next message
james_aron
Messages: 32
Registered: July 2007
Location: chennai
Member
Hi All,

I have two blocks in one main canvas(content) and i have first,next,previous,last button in my main canvas(content).But my first,next,previous,last button is working only in first block only, it is not navigating in second block.

If i click on the second block the buttons has to workout when my cursor is in that block tooooooo.

help asup!.......!

regards,
jame
Re: Problem in navigating the buttons. [message #255624 is a reply to message #255608] Wed, 01 August 2007 05:57 Go to previous messageGo to next message
azamkhan
Messages: 548
Registered: August 2005
Senior Member
Yes it must work... Perhaps you might be doing some mistake in your code. Tell us what code you are writing in your buttons
Re: Problem in navigating the buttons. [message #255630 is a reply to message #255608] Wed, 01 August 2007 06:10 Go to previous messageGo to next message
james_aron
Messages: 32
Registered: July 2007
Location: chennai
Member
hi,

In Frist Button <
------------------
go_block('department_block');
first_record;

In Previous Button < <
----------------------------
go_block('department_block');
if :system.cursor_record = 1 then
proc_alert('You are in first record');
raise form_trigger_failure;
else
previous_record;
end if;

In Next Button > >
---------------------------
go_block('department_block');
if :system.last_record = 'TRUE' then
proc_alert('You are in last record');
raise form_trigger_failure;
else
next_record;
end if;

In Last Button >
-----------------
go_block('department_block');
last_record;

regards,
jame

Re: Problem in navigating the buttons. [message #255823 is a reply to message #255630] Wed, 01 August 2007 23:37 Go to previous messageGo to next message
azamkhan
Messages: 548
Registered: August 2005
Senior Member
What kind of navigation problem are you facing on buttons
icon1.gif  Re: Problem in navigating the buttons. [message #255826 is a reply to message #255630] Thu, 02 August 2007 00:25 Go to previous messageGo to next message
parag100
Messages: 4
Registered: June 2007
Location: INDIA
Junior Member

in ur code of buttons
u specified only FIRST BLOCK NAME .SO IS THE PRBLEM.
I THINK U TAKE SECOND SET OF BUTTONS.
CHANGE THE BLOCK NAME.
Re: Problem in navigating the buttons. [message #255830 is a reply to message #255630] Thu, 02 August 2007 00:33 Go to previous messageGo to next message
james_aron
Messages: 32
Registered: July 2007
Location: chennai
Member
hi,
I have three blocks, First block contains four buttons called first,next,previous,last button and lov to display the other 2 blocks according to the selection made in lov. My requirement is, after displaying 2 blocks i need to navigate through each record according to the blocks selected(cursor point). I have trigger in my first block 'when-new-record-instance' and this trigger contains procedure which has to do some internal population.

regards,
jame
Re: Problem in navigating the buttons. [message #255840 is a reply to message #255823] Thu, 02 August 2007 00:57 Go to previous messageGo to next message
james_aron
Messages: 32
Registered: July 2007
Location: chennai
Member
hi parag100,
Is it possible to call all the block in the button like below.

In Previous Button < <
----------------------------
go_block('employee_block');
go_block('salary_block'); <----------
go_block('department_block'); <----------
if :system.cursor_record = 1 then
proc_alert('You are in first record');
raise form_trigger_failure;
else
previous_record;
end if;

It wouldnt work at all.............
See my previous post that will explain u what i need exactly.

many thanks to reply ya.

regards,
jame

[Updated on: Thu, 02 August 2007 01:02]

Report message to a moderator

Re: Problem in navigating the buttons. [message #255869 is a reply to message #255608] Thu, 02 August 2007 03:57 Go to previous message
james_aron
Messages: 32
Registered: July 2007
Location: chennai
Member
hi parag100,
I got solution to my prob. while i read ur reply i got an idea of replacing a new set of duplicate buttons.

< in ur code of buttons
< u specified only FIRST BLOCK NAME .SO IS THE PRBLEM.
< I THINK U TAKE SECOND SET OF BUTTONS.
< CHANGE THE BLOCK NAME.

thanks man,

regards,
jame
Previous Topic: regarding quries using in oracle forms
Next Topic: how to use icons in 10g
Goto Forum:
  


Current Time: Fri Dec 09 19:24:58 CST 2016

Total time taken to generate the page: 0.09151 seconds