Home » Infrastructure » Linux » Oracle XE on Fedora Core 5 - shared memory realm error
Oracle XE on Fedora Core 5 - shared memory realm error [message #253040] Sat, 21 July 2007 20:52 Go to next message
uzee
Messages: 5
Registered: July 2007
Junior Member
Hi All,
I have a VPS hosting account running Fedora Core 5. I'm working with a developer on a test application for which we need java, tomcat and oracle xe.
We have installed+configured java and tomcat successfully. I was able to install Oracle XE as well last night and followed the installation steps from the oracle website but have the following issue and can't understand why...

When I try to run sqlplus, it asks for a password which I had set after the installation through the
"/etc/init.d/oracle-xe configure" But after the password it gives the following error:

[root@host]# sqlplus
SQL*Plus: Release 10.2.0.1.0 - Production on Sat Jul 21 19:15:55 2007
Copyright (c) 1982, 2005, Oracle. All rights reserved.
Enter user-name: system
Enter password:
ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
Linux Error: 2: No such file or directory


I have been researching on this and have found that its either related to a lack of memory/swap space issue or a problem with environment variables. As far as I could check these both are ok on my system, see below .... can someone please please help me to figure out this problem... !!!
Also, I cannot get to the http homepage at:
http://<my_IP_Address>:8090/apex
(I configured port 8090 at install time to avoid conflict with tomcat)

As far as I can see I have 2GB RAM and 4GB swap which should be more than enough and my env variables are ok too....

[root@host]# uname -a
Linux host 2.6.9-023stab044.4-smp #1 SMP Thu May 24 17:23:29 MSD 2007 i686 i686 i386 GNU/Linux
[root@host]# rpm -qa|grep oracle
oracle-xe-univ-10.2.0.1-1.0

[root@host]# free -m
total used free shared buffers cached
Mem: 2022 1644 377 0 268 661
-/+ buffers/cache: 714 1307
Swap: 4094 0 4094

[root@host]# df -k
Filesystem 1K-blocks Used Available Use% Mounted on
vzfs 9437184 882209 8554975 10% /

[root@host]# echo $ORACLE_HOME
/usr/lib/oracle/xe/app/oracle/product/10.2.0/server

[root@host]# echo $ORACLE_SID
XE
[root@host]#



Please Help !!
Thanks in advance

uzee
Re: Oracle XE on Fedora Core 5 - shared memory realm error [message #253041 is a reply to message #253040] Sat, 21 July 2007 22:10 Go to previous messageGo to next message
BlackSwan
Messages: 22690
Registered: January 2009
Senior Member
It likely means oracle is NOT running.
ps -ef | grep pmon

If the command above only returns itself, then oracle is NOT up.

It is NOT recommended to invoke sqlplus as OS user "root".

You'll have better chances of success if you are logged onto the system as the OS user which installed the oracle s/w; usually user "oracle".

if/when logged on as Oracle s/w owner

Post CUT & PASTE results from two lines below:
sqlplus
/ as sysdba
Re: Oracle XE on Fedora Core 5 - shared memory realm error [message #253047 is a reply to message #253040] Sat, 21 July 2007 22:43 Go to previous messageGo to next message
uzee
Messages: 5
Registered: July 2007
Junior Member
Thanks "anacedent" you are absolutely right, oracle is NOT running. The only process running is the listener. Also note that I installed oracle as root, which was per the oracle website install guide. However I'm posting the sqplus output after su'ing to user "oracle", I could get to the SQL prompt but the same issue after that.

[root@host]# ps -ef|grep pmon
root 9931 9752 0 21:25 pts/1 00:00:00 grep pmon

[root@host]# ps -ef|grep ora
oracle 13769 1 0 03:51 ? 00:00:00 /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/tnslsnr LISTENER -inherit
root 9935 9752 0 21:25 pts/1 00:00:00 grep ora


Here's the output for sqlplus, I also tried the startup command from the sqlplus prompt and that gave a memory error.

[root@host]# su - oracle
-bash-3.1$ id
uid=502(oracle) gid=502(dba) groups=502(dba)

-bash-3.1$ sqlplus / as sysdba

SQL*Plus: Release 10.2.0.1.0 - Production on Sat Jul 21 21:16:24 2007
Copyright (c) 1982, 2005, Oracle. All rights reserved.

Connected to an idle instance.

SQL> connect
Enter user-name: sysdba
Enter password:
ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
Linux Error: 2: No such file or directory

Warning: You are no longer connected to ORACLE.
SQL> exit
-bash-3.1$
-bash-3.1$ sqlplus / as sysdba

SQL*Plus: Release 10.2.0.1.0 - Production on Sat Jul 21 21:23:21 2007

Copyright (c) 1982, 2005, Oracle. All rights reserved.

Connected to an idle instance.

SQL> startup;
ORA-27102: out of memory
Linux Error: 28: No space left on device
SQL> exit
Disconnected
-bash-3.1$


Please let me know if you need any other info... I really appreciate your help, thanks.
uzee

[Updated on: Sat, 21 July 2007 22:45]

Report message to a moderator

Re: Oracle XE on Fedora Core 5 - shared memory realm error [message #253049 is a reply to message #253040] Sat, 21 July 2007 22:55 Go to previous messageGo to next message
BlackSwan
Messages: 22690
Registered: January 2009
Senior Member
You are the 2nd person in as many days who can't read & follow what I thought were explicit directions.

Please note in my previous post I stated
Post CUT & PASTE results from TWO lines below:
sqlplus
/ as sysdba

What part of TWO you do NOT understand?
I did NOT suggest/request "sqlplus / as sysdba" on 1 line!

Use CUT & PASTE and do the following command as root:
df -h
cat /etc/sysctl.conf

[Updated on: Sat, 21 July 2007 22:57] by Moderator

Report message to a moderator

Re: Oracle XE on Fedora Core 5 - shared memory realm error [message #253054 is a reply to message #253040] Sun, 22 July 2007 00:42 Go to previous messageGo to next message
uzee
Messages: 5
Registered: July 2007
Junior Member
Smile I can understand your frustration, let me apologize for that. What I should've mentioned in my popst was that I did try that in TWO separate lines first but that displays the same message "connected to an idle instance", anyways see below:

[root@host]# su - oracle
-bash-3.1$ sqlplus

SQL*Plus: Release 10.2.0.1.0 - Production on Sat Jul 21 23:28:24 2007

Copyright (c) 1982, 2005, Oracle. All rights reserved.

Enter user-name: / as sysdba
Connected to an idle instance.

SQL>

[root@host]# df -h
Filesystem Size Used Avail Use% Mounted on
vzfs 9.0G 862M 8.2G 10% /

[root@host]# cat /etc/sysctl.conf
# Kernel sysctl configuration file for Red Hat Linux
#
# For binary values, 0 is disabled, 1 is enabled. See sysctl(Cool and
# sysctl.conf(5) for more details.

# Controls IP packet forwarding
net.ipv4.ip_forward = 0

# Controls source route verification
net.ipv4.conf.default.rp_filter = 1

# Do not accept source routing
net.ipv4.conf.default.accept_source_route = 0

# Controls the System Request debugging functionality of the kernel
# kernel.sysrq = 0

# Controls whether core dumps will append the PID to the core filename.
# Useful for debugging multi-threaded applications.
# kernel.core_uses_pid = 1

# Controls the use of TCP syncookies
net.ipv4.tcp_syncookies = 1
###########
# Oracle XE Recommended Values
kernel.sem = 250 32000 100 128
kernel.shmmax = 536870912
########
[root@host]#


Thanks...
uzee
Re: Oracle XE on Fedora Core 5 - shared memory realm error [message #253062 is a reply to message #253040] Sun, 22 July 2007 01:47 Go to previous messageGo to next message
BlackSwan
Messages: 22690
Registered: January 2009
Senior Member
here is what I use:
#below oracle specific for
kernel.shmall = 2097152
kernel.shmmax = 7956500000
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
fs.file-max = 65536
net.ipv4.ip_local_port_range = 1024 65000
net.core.rmem_default = 262144
net.core.rmem_max = 262144
net.core.wmem_default = 262144
net.core.wmem_max = 262144
#end oracle specific paramters
Re: Oracle XE on Fedora Core 5 - shared memory realm error [message #253078 is a reply to message #253040] Sun, 22 July 2007 03:17 Go to previous messageGo to next message
uzee
Messages: 5
Registered: July 2007
Junior Member
Hi,
Can't seem to change most of the values. I added your kernel parameters to my sysctl.conf and then tried to reload with the p option but it gives error saying operation not permitted, even though I'm root. Also tried with echo, same problem.

(End part of /etc/sysctl.conf)
# Oracle XE Recommended Values
kernel.shmall = 2097152
kernel.shmmax = 7956500000
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
fs.file-max = 65536
net.ipv4.ip_local_port_range = 1024 65000
net.core.rmem_default = 262144
net.core.rmem_max = 262144
net.core.wmem_default = 262144
net.core.wmem_max = 262144
#end oracle specific paramters
########

[root@host]# sysctl -p /etc/sysctl.conf
net.ipv4.ip_forward = 0
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.accept_source_route = 0
error: "Operation not permitted" setting key "net.ipv4.tcp_syncookies"
kernel.shmall = 2097152
kernel.shmmax = 7956500000
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
error: "Operation not permitted" setting key "fs.file-max"
error: "Operation not permitted" setting key "net.ipv4.ip_local_port_range"
error: "Operation not permitted" setting key "net.core.rmem_default"
error: "Operation not permitted" setting key "net.core.rmem_max"
error: "Operation not permitted" setting key "net.core.wmem_default"
error: "Operation not permitted" setting key "net.core.wmem_max"
[root@host]#

[root@host]# echo 262144 > /proc/sys/net/core/rmem_default
-bash: echo: write error: Operation not permitted


I was able to set one parameter with the "w" switch but sysctl -a still shows old value:


[root@host]# sysctl -w kernel.shmmax=7956500000
kernel.shmmax = 7956500000

[root@host]# sysctl -p /etc/sysctl.conf
net.ipv4.ip_forward = 0
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.accept_source_route = 0
error: "Operation not permitted" setting key "net.ipv4.tcp_syncookies"
kernel.shmall = 2097152
kernel.shmmax = 7956500000
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
error: "Operation not permitted" setting key "fs.file-max"
error: "Operation not permitted" setting key "net.ipv4.ip_local_port_range"
error: "Operation not permitted" setting key "net.core.rmem_default"
error: "Operation not permitted" setting key "net.core.rmem_max"
error: "Operation not permitted" setting key "net.core.wmem_default"
error: "Operation not permitted" setting key "net.core.wmem_max"
[root@host]# sysctl -a|grep shm
kernel.shmmni = 4096
kernel.shmall = 2097152
kernel.shmmax = 3661532704
error: "Operation not permitted" reading key "kernel.cap-bound"
[root@host]#


Any ideas.... my understanding was that I would not need to reboot if I use "sysctl -p " .... is it a reboot or something else?

Appreciate your help...


Re: Oracle XE on Fedora Core 5 - shared memory realm error [message #253108 is a reply to message #253040] Sun, 22 July 2007 12:28 Go to previous messageGo to next message
BlackSwan
Messages: 22690
Registered: January 2009
Senior Member
> oracle shows this message:
> ORA-27102: out of memory
> Linux Error: 28: No space left on device

This error means your kernel parameter are not allowing the OS to allocate enough shared memory.
Verify your kernel parameter meet the minimum requied by an Oracle installation:
http://download-west.oracle.com/docs/cd/B19306_01/install.102/b15660/pre_install.htm#sthref264
Also make sure you have enough configured swap space.
Re: Oracle XE on Fedora Core 5 - shared memory realm error [message #253218 is a reply to message #253040] Mon, 23 July 2007 03:05 Go to previous message
uzee
Messages: 5
Registered: July 2007
Junior Member
Thanks much I have tried the steps in the link as well but still the same... I'm wondering if it could be because my server is actually a VPS which shares resources from the main host, and if the values shown by "free -m" are actually for my VPS or they are for the main host ?
I have asked this on the fedora forum as this seems to be an OS issue, will update here as soon as I get an answer.

Thanks so much for the help.
uzee
Previous Topic: No Drives Found Error....
Next Topic: Three different ORA errors when installing 10g on SuSe
Goto Forum:
  


Current Time: Fri Aug 22 12:44:18 CDT 2014

Total time taken to generate the page: 0.05511 seconds