Home » RDBMS Server » Server Administration » Invalid object in the OLAPSYS schema after upgrade from 10.2.0.1 to 10.2.0.3
Invalid object in the OLAPSYS schema after upgrade from 10.2.0.1 to 10.2.0.3 [message #252234] Wed, 18 July 2007 04:49 Go to next message
jerabekm
Messages: 5
Registered: August 2005
Location: Czech Republic
Junior Member
Hi,
since I upgraded DB from 10.2.0.1 to 10.2.0.3 (Patchset 5337014) I have had 29 objects (views, package body) invalid in the OLAPSYS schema (and 25 synonyms in PUBLIC).

When I try compile e.g. the view OLAPSYS.ALL$OLAP2_AW_CUBES, I get error:
ORA-12663: Services required by client not available on the server
ORA-36961: Oracle OLAP is not available.
ORA-06512: at "SYS.OLAPIMPL_T", line 23
ORA-06512: at "SYS.OLAPIMPL_T", line 17
ORA-06512: at line 4

I use Mandriva 2006 but I think that it can not be problem (but for support of Oracle it is problem Sad ).

Anyone know how to resolve this issue? I found this http://forums.oracle.com/forums/thread.jspa?messageID=1309606 but it didn't help me.
Thank

Michal
Re: Invalid object in the OLAPSYS schema after upgrade from 10.2.0.1 to 10.2.0.3 [message #252237 is a reply to message #252234] Wed, 18 July 2007 04:54 Go to previous messageGo to next message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

Quote:
ORA-12663:Services required by client not available on the server
Cause: Service(s) that was (were) required by the client process were not available on the server process.
Action: Configure the server with the services required by the client (best solution) or delete the requirement from the configuration file of the client (least secure).

[Updated on: Wed, 18 July 2007 05:16] by Moderator

Report message to a moderator

Re: Invalid object in the OLAPSYS schema after upgrade from 10.2.0.1 to 10.2.0.3 [message #252367 is a reply to message #252237] Wed, 18 July 2007 13:01 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Quote:
ALTER TRIGGER OLAPISTARTUPTRIGGER DISABLE; ALTER TRIGGER OLAPISHUTDOWNTRIGGER DISABLE;



http://orafaq.com/maillist/oracle-l/2006/04/12/0530.htm
Re: Invalid object in the OLAPSYS schema after upgrade from 10.2.0.1 to 10.2.0.3 [message #252486 is a reply to message #252367] Thu, 19 July 2007 00:46 Go to previous messageGo to next message
jerabekm
Messages: 5
Registered: August 2005
Location: Czech Republic
Junior Member
This helps only when the error is:

ORA-12663: Services required by client not available on the server
ORA-36961: Oracle OLAP is not available.
ORA-06512: at "SYS.OLAPIHISTORYRETENTION", line 1
ORA-06512: at line 15

http://www.freelists.org/archives/oracle-l/04-2006/msg00475.html

Both of triggers I have disabled and my problem is not resolved.

[Updated on: Thu, 19 July 2007 00:55]

Report message to a moderator

Re: Invalid object in the OLAPSYS schema after upgrade from 10.2.0.1 to 10.2.0.3 [message #252490 is a reply to message #252237] Thu, 19 July 2007 00:52 Go to previous message
jerabekm
Messages: 5
Registered: August 2005
Location: Czech Republic
Junior Member
Ok, thank.

But I don't know HOW "Configure the server with the services required by the client"? Can anybody tell me a way?
Thank

[Updated on: Thu, 19 July 2007 00:55]

Report message to a moderator

Previous Topic: ORA-12560: TNS:protocol adapter error ???
Next Topic: Can' find Tablespace
Goto Forum:
  


Current Time: Fri Dec 02 14:15:49 CST 2016

Total time taken to generate the page: 0.09136 seconds