Home » Developer & Programmer » Precompilers, OCI & OCCI » thread blocked by operating on clob col?
thread blocked by operating on clob col? [message #249529] Wed, 04 July 2007 21:13
sagewu
Messages: 1
Registered: July 2007
Junior Member
My program is on "HP-UX AI64+ORACLE RAC 10g+OCCI", when insert clob record into db, its thread is blocked. The following is stack of the blocked thread:

#0 0x60000000c02a6bd0:0 in __ksleep+0x30 () from /usr/lib/hpux32/libc.so.1
#1 0x60000000c038d6c0:0 in __mxn_sleep+0xab0 () from /usr/lib/hpux32/libpthread.so.1
#2 0x60000000c034bd10:0 in <unknown_procedure> + 0x4a0 () from /usr/lib/hpux32/libpthread.so.1
#3 0x60000000c034ff10:0 in pthread_mutex_lock+0x170 () from /usr/lib/hpux32/libpthread.so.1
#4 0x60000000dd512ce0:0 in sltsmna+0x60 () from /oracle/oracle/app/oracle/product/10.2.0/db_1/lib32/libclntsh.so.10.1
#5 0x60000000dbd90fe0:0 in kpullas+0x1d40 () from /oracle/oracle/app/oracle/product/10.2.0/db_1/lib32/libclntsh.so.10.1
#6 0x60000000dbe9ea10:0 in OCILobLocatorAssign+0x30 () from /oracle/oracle/app/oracle/product/10.2.0/db_1/lib32/libclntsh.so.10.1
#7 0x561ded0:0 in oracle::occi::Clob::Clob(oracle::occi::Connection const*,OCILobLocator*,bool)+0x1b0 () at occiClob.cpp:204
#8 0x55d9750:0 in oracle::occi::ResultSetImpl::getClob () at occiResultSetImpl.cpp:1892
#9 0x4e11de0:0 in CTableObj::PutClobVal2DB (this=0x77337e50, rs=0x407fbaf8, pTblDef=0x4078b3e4, rec=@0x77337db0) at /home/myDB.cpp:788

It invokes "Environment::createEnvironment" with Environment::Mode(Environment::THREADED_MUTEXED | Environment::OBJECT)

anybody can help me???

Thanks in advance!!

Previous Topic: occi.h: No such file or directory
Next Topic: Could not open include file <string>
Goto Forum:
  


Current Time: Sun Dec 04 10:40:44 CST 2016

Total time taken to generate the page: 0.08323 seconds