Home » RDBMS Server » Server Administration » **FIXED** ORA-12514 When Setting up a Servive Name using Net Configuration Assistant
**FIXED** ORA-12514 When Setting up a Servive Name using Net Configuration Assistant [message #248863] Mon, 02 July 2007 08:54 Go to next message
t.summerfield
Messages: 39
Registered: March 2007
Location: UK
Member
I have two servers, A & B. Both are win 2003 and have Oracle 10gR2 installed.

When using the Net Configuration Assistant on server A to set up a service name to connect to server B I get the following error.

ORA-12514: TNS:listener does not currently know of service requested in connect descriptor
The test did not succeed.


However if I do the exact same to connect server B to server A there is no problem. I have checked the listener.ora files on both servers, but am unable to see a problem.


Contents of listener.ora for server A
# listener.ora Network Configuration File: D:\Oracle_10.2.0\network\admin\listener.ora
# Generated by Oracle configuration tools.

LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = A)(PORT = 1521))
)
)

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(GLOBAL_DBNAME = sid.B)
(ORACLE_HOME = D:\Oracle_10.2.0)
(SID_NAME = sid)
)
(SID_DESC =
(GLOBAL_DBNAME = sid_a)
(ORACLE_HOME = D:\Oracle_10.2.0)
(SID_NAME = sid)
)
)



Contents of listener.ora for server B
# LISTENER.ORA Network Configuration File: c:\oracle\ora92\network\admin\listener.ora
# Generated by Oracle configuration tools.

LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = B)(PORT = 1521)
)
)

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(GLOBAL_DBNAME = sid.b)
(ORACLE_HOME = c:\oracle\ora92)
(SID_NAME = sid)
)
(SID_DESC =
(GLOBAL_DBNAME = sid_a)
(ORACLE_HOME = c:\oracle\ora92)
(SID_NAME = sid)
)
)


Using the OEM console on server A I can connect to server B no problem.

Does anyone know why this is happening?

Any thoughts or suggestions will be greatly appreciated.

Regards
Toby

[Updated on: Tue, 03 July 2007 02:27]

Report message to a moderator

Re: ORA-12514 When Setting up a Servive Name using Net Configuration Assistant [message #248899 is a reply to message #248863] Mon, 02 July 2007 10:58 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
ORA-12514: TNS:listener does not currently know of service requested in connect descriptor

Cause: The listener received a request to establish a connection to a database or other service. The connect descriptor received by the listener specified a service name for a service (usually a database service) that either has not yet dynamically registered with the listener or has not been statically configured for the listener. This may be a temporary condition such as after the listener has started, but before the database instance has registered with the listener.


Action:

- Wait a moment and try to connect a second time.

- Check which services are currently known by the listener by executing: lsnrctl services <listener name>

- Check that the SERVICE_NAME parameter in the connect descriptor of the net service name used specifies a service known by the listener.

- If an easy connect naming connect identifier was used, check that the service name specified is a service known by the listener.

- Check for an event in the listener.log file.


Edit : Remove codes tags
Taj

[Updated on: Tue, 03 July 2007 00:28] by Moderator

Report message to a moderator

Re: ORA-12514 When Setting up a Servive Name using Net Configuration Assistant [message #248908 is a reply to message #248899] Mon, 02 July 2007 11:55 Go to previous messageGo to next message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Do you think posting lines of 500 characters is readable?

Regards
Michel
Re: ORA-12514 When Setting up a Servive Name using Net Configuration Assistant [message #248976 is a reply to message #248863] Tue, 03 July 2007 00:31 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

1. your B server Database Version ? is 10g or 9i
2. you should restart your listener services on Server A and try to connect.


Regards
Taj


Re: ORA-12514 When Setting up a Servive Name using Net Configuration Assistant [message #249038 is a reply to message #248863] Tue, 03 July 2007 02:26 Go to previous message
t.summerfield
Messages: 39
Registered: March 2007
Location: UK
Member
Thankyou for the replies.

I have now fixed the problem. It seems that whoever installed Oracle 10g on the server whilst I was away did not completely remove the 9i install (only used the UI & did not remove registry entries etc) and this was causing a conflict in the listener (aswell as confusion for me!).

All is working fine now.

Regards
Toby
Previous Topic: How to add a new partition to an existing partition
Next Topic: Flashback SCN
Goto Forum:
  


Current Time: Sat Dec 10 16:21:29 CST 2016

Total time taken to generate the page: 0.05855 seconds