Home » Developer & Programmer » Reports & Discoverer » From Form, passing NULL parameters to Report
From Form, passing NULL parameters to Report [message #247914] Wed, 27 June 2007 09:03 Go to next message
dude4084
Messages: 221
Registered: March 2005
Location: Mux
Senior Member
Dear All

My objective is to pass parameter from form to report.
My Problem is that i can not pass NULL value to the report as it is giving me Error Rep-0788.


The report stand alone works perfectly.
The form works perfectly for all values except "All Departments".
Here are attached files


Please help me to find the solution of the problem as i have tried many combinations but failed.
I am using Oracle 8i anf Forms 6.

(Note: though, in report, if i uncheck "restrict list to predetirmined values" then the things are working perfectly but i dont want this as this will create problems when the report will be run as stand alone)
  • Attachment: rep1.RDF
    (Size: 56.00KB, Downloaded 224 times)
Re: From Form, passing NULL parameters to Report [message #247916 is a reply to message #247914] Wed, 27 June 2007 09:05 Go to previous messageGo to next message
dude4084
Messages: 221
Registered: March 2005
Location: Mux
Senior Member
Here is the form file
  • Attachment: MODULE1.fmb
    (Size: 40.00KB, Downloaded 196 times)
Re: From Form, passing NULL parameters to Report [message #247920 is a reply to message #247914] Wed, 27 June 2007 09:13 Go to previous messageGo to next message
dude4084
Messages: 221
Registered: March 2005
Location: Mux
Senior Member
--Sorry--

[Updated on: Wed, 27 June 2007 09:14]

Report message to a moderator

Re: From Form, passing NULL parameters to Report [message #249308 is a reply to message #247914] Wed, 04 July 2007 01:10 Go to previous messageGo to next message
dude4084
Messages: 221
Registered: March 2005
Location: Mux
Senior Member
I have solved the problem.


As i have specified in my post that: "if i uncheck "restrict list to predetirmined values" then the things are working perfectly but i dont want this as this will create problems when the report will be run as stand alone"


But it is not creating problems.

I thought that it will not validate user input when we will run report but it is.

Thanks for your time on my post!
Re: From Form, passing NULL parameters to Report [message #249309 is a reply to message #249308] Wed, 04 July 2007 01:15 Go to previous message
ab_trivedi
Messages: 460
Registered: August 2006
Location: Pune, India
Senior Member
GOOD KEEP IT UP
Previous Topic: Report pages not displaying properly in the desired sequence
Next Topic: Discoverer 10g
Goto Forum:
  


Current Time: Sat Dec 10 14:32:37 CST 2016

Total time taken to generate the page: 0.10133 seconds