Home » Developer & Programmer » Reports & Discoverer » Problem While Printing Report
Problem While Printing Report [message #247734] Wed, 27 June 2007 01:33 Go to next message
ramisetti1
Messages: 30
Registered: January 2007
Member
Hi Friends

I am facing the problem while printing the Report
It is printing without page break.
There is no break between pages.
how to solve this
could u help me ?

Thanks in advance
Re: Problem While Printing Report [message #248023 is a reply to message #247734] Wed, 27 June 2007 15:55 Go to previous messageGo to next message
Littlefoot
Messages: 20900
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
What kind of a report is it? Which tool did you use to create it? What is the break condition? Did you check the "Page Break Before / After" properties?
Re: Problem While Printing Report [message #248115 is a reply to message #247734] Thu, 28 June 2007 02:01 Go to previous messageGo to next message
ramisetti1
Messages: 30
Registered: January 2007
Member
Thankyou for your response
It is a TDS report made by rdf (report6i) only
in oracle apps-SRS window-View output we are getting the page break symbol i.e small box
but while printing through DOT MATRIX PRINTER (OCA) printer
it showing same box in output ,there is no page break.

It is printing the output continously without pagebreaks
Re: Problem While Printing Report [message #248157 is a reply to message #248115] Thu, 28 June 2007 03:26 Go to previous messageGo to next message
Littlefoot
Messages: 20900
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
It seems that printer doesn't "understand" the page break escape code.

Do you, perhaps, print it as a bitmap? Try to switch to character mode (if on MS Windows, see if you can clear something like "Bypass Windows print driver" check box).

Also, you might check whether you have installed the newest driver for your printer.
Re: Problem While Printing Report [message #248170 is a reply to message #247734] Thu, 28 June 2007 03:59 Go to previous messageGo to next message
ramisetti1
Messages: 30
Registered: January 2007
Member
The problem with this report only
other reports are printing perfectly
wt might be?
between pages it showing symbol like
no page break
Re: Problem While Printing Report [message #248455 is a reply to message #247734] Fri, 29 June 2007 02:07 Go to previous messageGo to next message
fastfreeeasy
Messages: 25
Registered: June 2007
Junior Member
Check .PRT file template that resides in \reports\printer\*.PRT and is being used for the report. Check if the line exists in the file AFTER PAGE Ctrl+L
Re: Problem While Printing Report [message #248481 is a reply to message #248455] Fri, 29 June 2007 02:58 Go to previous messageGo to next message
ramisetti1
Messages: 30
Registered: January 2007
Member
thank you for your reply
u told to check the line *.prt file
which line ?
if not exit wt we have to do
what for AFTER PAGE Ctrl+L ?
tell me details
Re: Problem While Printing Report [message #248503 is a reply to message #248481] Fri, 29 June 2007 04:29 Go to previous messageGo to next message
fastfreeeasy
Messages: 25
Registered: June 2007
Junior Member
I think you got the .prt file. One more thing is that please check DESFORMAT system parameter of the report. You will see the default value dflt. Basically this "dflt" is the name of the printer file (dflt.prt). The content of the file will be like the following content

printer "compress"

height 66
width 80

after page control(L)

return ""
linefeed control(J)

Note: AFTER PAGE CONTROL(L), if it is not there in the file then put this line. Save the .prt file then run the report and print. Sorry, for the mistake previously I mentioned it like Ctrl+L
Re: Problem While Printing Report [message #248515 is a reply to message #247734] Fri, 29 June 2007 05:20 Go to previous message
ramisetti1
Messages: 30
Registered: January 2007
Member
thank you very much
i will try it and get you back
Previous Topic: Regarding layout adjustment in report output
Next Topic: decode a numeric value to string in report
Goto Forum:
  


Current Time: Wed Dec 07 14:59:12 CST 2016

Total time taken to generate the page: 0.26416 seconds