Home » SQL & PL/SQL » Client Tools » Japanese characters while taking report from TOAD
Japanese characters while taking report from TOAD [message #247518] Tue, 26 June 2007 03:41 Go to next message
himang
Messages: 282
Registered: March 2005
Location: Bangalore
Senior Member

Hi,
We store Japanese characters in our database. When I do a select I can't see these characters in TOAD. They gets converted to "真真真真真". Anyway of displaying these properly in TOAD and getting spooled in EXCEL.

Regards
Himanshu
Re: Japanese characters while taking report from TOAD [message #247670 is a reply to message #247518] Tue, 26 June 2007 13:45 Go to previous messageGo to next message
andrew again
Messages: 2577
Registered: March 2000
Senior Member
Your Japanese characters may only exist in your database characterset (lets say that's UTF8). Windows needs to be able to display these characters for you to be able to see them before TOAD has a hope of doing so.

Assuming your data isn't in a Nchar data type, try:
1.) select * from v$nls_parameters where parameter in ('NLS_LANGUAGE', 'NLS_TERRITORY', 'NLS_CHARACTERSET');

NLS_LANGUAGE AMERICAN
NLS_TERRITORY AMERICA
NLS_CHARACTERSET AL32UTF8

Corresponding NLS_LANG is determined as follows:
NLS_LANG=<NLS_LANGUAGE>_<NLS_TERRITORY>.<NLS_CHARACTERSET>
i.e.
NLS_LANG=AMERICAN_AMERICA.AL32UTF8

Find NLS_LANG in your registry for the Oracle home used by TOAD and set to to match/be-compatible-with your database characterset. Restart TOAD.

2.) try selecting the data from isqlplus or Oracle XE browser. Browsers have much better characterset support than Windows apps. When you have the data in the browser, check the codepage (in IE: View > Encoding)
Re: Japanese characters while taking report from TOAD [message #247797 is a reply to message #247518] Wed, 27 June 2007 04:42 Go to previous messageGo to next message
himang
Messages: 282
Registered: March 2005
Location: Bangalore
Senior Member

Hi Andrew,
Thanks for your reply. I checked the database setting and it was

PARAMETER VALUE
NLS_LANGUAGE AMERICAN
NLS_TERRITORY AMERICA
NLS_CHARACTERSET AL32UTF8

In the registry also I modified the key NLS_LANG to AMERICAN_AMERICA.AL32UTF8 which was earlier as AMERICAN_AMERICA.WE8MSWIN1252 but still the same problem... though the characters have changed now Smile

its coming now as ƒƒƒƒˆƒƒ&frac14;‚‚潟ƒ潟ƒˆƒƒ&frac14;ƒ&frac14;ˆ‚ƒ潟ƒ純ƒ&frac14;ƒ‰&frac14;‰,

Am I doing something wrong?

Re: Japanese characters while taking report from TOAD [message #248025 is a reply to message #247797] Wed, 27 June 2007 16:34 Go to previous message
andrew again
Messages: 2577
Registered: March 2000
Senior Member
No - like I mentioned - most Windows apps (probably including TOAD) have even less characterset support than Windows. Check the help.

Check for the best font for seeing the characters you want Start > Programs > Accessories > Syatem tools > Character map. Select Caracter set=Unicode. Now try changing your TOAD font (for data grid or whatever) to that font.

A Browser is your best bet for seeing the characters - and even then - you need to select a font that supports the characters you are trying to view...
Previous Topic: editing sql commands
Next Topic: Master Detail Reporting
Goto Forum:
  


Current Time: Mon Dec 05 09:11:14 CST 2016

Total time taken to generate the page: 0.09021 seconds