Home » Infrastructure » Linux » Help installing Oracle 10g Release 2 (10.2) for Linux x86-64
Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #247302] Mon, 25 June 2007 08:09 Go to next message
bbmonster
Messages: 47
Registered: June 2007
Location: UB
Member

Dear all,

I am new to the oracle administration. I set all configurations, and installed prerequisite packages. It seems ok. When I running the installation I always get this error.

Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be redhat-3, redhat-4 or SuSE-9
Passed


All installer requirements met.

Preparing to launch Oracle Universal Installer from /tmp/OraInstall2007-06-30_03-21-41PM. Please wait ...[oracle@uccs install]$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /tmp/OraInstall2007-06-30_03-21-41PM/jre/1.4.2/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at sun.security.action.LoadLibraryAction.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.awt.NativeLibLoader.loadLibraries(Unknown Source)
at sun.awt.DebugHelper.<clinit>(Unknown Source)
at java.awt.Component.<clinit>(Unknown Source)
at oracle.sysman.emgc.oneclick.OneClickWizard.getGuiDefaults(OneClickWizard.java:239)
at oracle.sysman.emgc.oneclick.OneClickWizard.<init>(OneClickWizard.java:205)
at oracle.sysman.emgc.oneclick.OneClick.<init>(OneClick.java:230)
at oracle.sysman.emgc.oneclick.OneClickInstaller.<init>(OneClickInstaller.java:116)
at oracle.sysman.emgc.oneclick.OneClickInstaller.process(OneClickInstaller.java:268)
at oracle.sysman.emgc.oneclick.OneStartup.startup(OneStartup.java:359)
at oracle.sysman.emgc.oneclick.OneArgs.main(OneArgs.java:650)
at oracle.sysman.emgc.oneclick.OneStartup.main(OneStartup.java:367)




Could you tell me what was the wrong? What should I do to fix this error?

Thank you very much
Re: Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #247305 is a reply to message #247302] Mon, 25 June 2007 08:18 Go to previous messageGo to next message
Frank Naude
Messages: 4502
Registered: April 1998
Senior Member
Some required packages are not installed.

What distro & version are you using?
Re: Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #247427 is a reply to message #247302] Mon, 25 June 2007 20:27 Go to previous messageGo to next message
bbmonster
Messages: 47
Registered: June 2007
Location: UB
Member

Here's list of packages I've installed.

binutils-2.15.92.0.2-13.0.0.0.2
compat-db-4.1.25-9
control-center-2.8.0-12
gcc-3.4.3-9.EL4
gcc-c++-3.4.3-9.EL4
glibc-2.3.4-2
glibc-common-2.3.4-2
gnome-libs-1.4.1.2.90-44.1
libstdc++-3.4.3-9.EL4
libstdc++-devel-3.4.3-9.EL4
make-3.80-5
pdksh-5.2.14-30
sysstat-5.0.5-1
xscreensaver-4.18-5.rhel4.2

ldd /tmp/OraInstall2007-07-01_03-58-26AM/jre/1.4.2/lib/i386/libawt.so
linux-gate.so.1 => (0xffffe000)
libmlib_image.so => not found
libjvm.so => not found
libXp.so.6 => not found
libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0xf7c89000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0xf7c7b000)
libXtst.so.6 => /usr/X11R6/lib/libXtst.so.6 (0xf7c75000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xf7bae000)
libm.so.6 => /lib/tls/libm.so.6 (0xf7b8b000)
libdl.so.2 => /lib/libdl.so.2 (0xf7b87000)
libjava.so => not found
libc.so.6 => /lib/tls/libc.so.6 (0xf7a5e000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0xf7a55000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0xf7a3d000)
/lib/ld-linux.so.2 (0x56555000)

Re: Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #247435 is a reply to message #247302] Mon, 25 June 2007 21:25 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
Needless to say you need to fix the following:
libmlib_image.so => not found
libjvm.so => not found
libXp.so.6 => not found
libjava.so => not found
icon5.gif  Re: Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #247752 is a reply to message #247302] Wed, 27 June 2007 02:12 Go to previous messageGo to next message
bbmonster
Messages: 47
Registered: June 2007
Location: UB
Member

Sorry, How can I fix these files?
Re: Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #248060 is a reply to message #247302] Wed, 27 June 2007 23:06 Go to previous messageGo to next message
bbmonster
Messages: 47
Registered: June 2007
Location: UB
Member

Hi all,
I managed to install the oracle 10g. The error's main reason is my RedHat is 64bit system, but oracle installation requires only 32 bit executables. During the installation I ignored all the warnings.

when I executing $ORACLE_HOME/lib/relink all
the following errors throws:

/usr/bin/ld: cannot find -lgcc_s_32
collect2: ld returned 1 exit status
genclntsh: Failed to link libclntsh.so.10.1
/usr/bin/ld: cannot find -lgcc_s_32
collect2: ld returned 1 exit status
/home/oracle/product/10.2.0/lib//libcore10.a(slftmp.o)(.text+0x10): In function `SlfTmpnam':
: warning: the use of `tmpnam_r' is dangerous, better use `mkstemp'
/usr/bin/find: /home/oracle/product/10.2.0/lib32/libagtsh.so: No such file or directory
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib/snmccolm.o' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib/libnmccol.a(nmccole.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib/libnmcbuf.a(nmcbuft.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib/libnmcbuf.a(nmcbufw.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib/libnmcbuf.a(nmcbufu.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib/libnmcbuf.a(snmcbufm.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib/libnmcbuf.a(nmcbuff.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib//libnmadbg.a(nmadbg.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: i386 architecture of input file `/home/oracle/product/10.2.0/sysman/lib//libnmadbg.a(snmadbg.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: cannot find -lgcc_s_32
collect2: ld returned 1 exit status
make[1]: *** [/home/oracle/product/10.2.0/sysman/lib/libnmemso.so] Error 1
make: *** [libnmemso] Error 2
/usr/bin/ld: cannot find -lgcc_s_32
collect2: ld returned 1 exit status
make: *** [ctxhx] Error 1
gcc: unrecognized option `-h'
gcc: unrecognized option `-h'
gcc: unrecognized option `-h'
/usr/bin/ld: skipping incompatible /home/oracle/product/10.2.0/lib/libagtsh.so when searching for -lagtsh
/usr/bin/ld: cannot find -lagtsh
collect2: ld returned 1 exit status
make[1]: *** [/home/oracle/product/10.2.0/rdbms/lib/extproc32] Error 1
make: *** [extproc32] Error 2

Then I tried to fix by following command.

[root@uccs ~]# rpm -Uvh compat-libstdc++-296-2.96-132.7.2.i386.rpm
error: Failed dependencies:
libgcc_s.so.1 is needed by compat-libstdc++-296-2.96-132.7.2.i386
libgcc_s.so.1(GLIBC_2.0) is needed by compat-libstdc++-296-2.96-132.7.2.i386

[root@uccs ~]# rpm -Uvh compat-libstdc++-33-3.2.3-47.3.i386.rpm
error: Failed dependencies:
libgcc_s.so.1 is needed by compat-libstdc++-33-3.2.3-47.3.i386
libgcc_s.so.1(GCC_3.0) is needed by compat-libstdc++-33-3.2.3-47.3.i386
libgcc_s.so.1(GCC_3.3) is needed by compat-libstdc++-33-3.2.3-47.3.i386
libgcc_s.so.1(GLIBC_2.0) is needed by compat-libstdc++-33-3.2.3-47.3.i386

[root@uccs ~]# rpm -Uvh libgcc-3.4.3-9.EL4.i386.rpm
Preparing... ########################################### [100%]
package libgcc-3.4.6-8 (which is newer than libgcc-3.4.3-9.EL4) is already installed

[root@uccs ~]# rpm -e libgcc-3.4.6-8
error: Failed dependencies:
libgcc is needed by (installed) glibc-2.3.4-2.36.x86_64
libgcc is needed by (installed) glibc-2.3.4-2.36.i686
libgcc >= 3.4.6-8 is needed by (installed) gcc-3.4.6-8.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) db4-4.2.52-7.1.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) gmp-4.1.4-3.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) lftp-3.0.6-3.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) libwvstreams-3.75.0-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) iptstate-1.3-4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) wvdial-1.54.0-3.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) Omni-0.9.1-7.1.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) hpijs-1.6-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) libmusicbrainz-2.0.2-11.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) flac-1.1.0-7.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) pwlib-1.6.5-11.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) openjade-1.3.2-14.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) openh323-1.13.4-7.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) arts-1.3.1-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) gstreamer-plugins-0.8.5-1.EL.0.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdemultimedia-3.3.1-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) doxygen-1.3.9.1-1.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) swig-1.3.21-6.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) autorun-3.14-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdeartwork-3.3.1-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdeaddons-3.3.1-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdeutils-3.3.1-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) arts-devel-1.3.1-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) sip-4.1-1.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) PyQt-3.13-1.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdbg-1.2.9-6.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdesdk-3.3.1-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdevelop-3.1.1-2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) nmap-3.70-1.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) libstdc++-3.4.6-8.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) aspell-0.50.5-4.EL4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) pilot-link-0.11.8-9.RHEL4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) groff-1.18.1.1-3.EL4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) boost-1.32.0-6.rhel4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) htdig-3.2.0b6-3.40.2.rhel4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) ttmkfdir-3.0.9-20.el4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) qt-3.3.3-10.RHEL4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) libgcj-3.4.6-8.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) xorg-x11-Mesa-libGLU-6.8.2-1.EL.18.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdelibs-3.3.1-6.RHEL4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) qt-devel-3.3.3-10.RHEL4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdelibs-devel-3.3.1-6.RHEL4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) seamonkey-1.0.9-2.el4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) tetex-2.0.2-22.EL4.7.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) cups-1.1.22-0.rc1.9.20.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) redhat-lsb-3.0-8.EL.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) devhelp-0.10-0.8.el4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) qt-designer-3.3.3-10.RHEL4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) oprofile-0.8.1-26.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) vnc-4.0-11.el4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) firefox-1.5.0.12-0.1.el4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) gnomemeeting-1.0.2-9.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) gpdf-2.8.2-7.4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) vnc-server-4.0-11.el4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdebase-3.3.1-5.19.rhel4.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdepim-3.3.1-2.2.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdegraphics-3.3.1-3.9.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdenetwork-3.3.1-2.3.x86_64
libgcc_s.so.1()(64bit) is needed by (installed) kdepim-devel-3.3.1-2.2.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) db4-4.2.52-7.1.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) gmp-4.1.4-3.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) lftp-3.0.6-3.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) iptstate-1.3-4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) wvdial-1.54.0-3.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) Omni-0.9.1-7.1.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) hpijs-1.6-2.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) libmusicbrainz-2.0.2-11.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) flac-1.1.0-7.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) pwlib-1.6.5-11.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) openjade-1.3.2-14.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) openh323-1.13.4-7.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) gstreamer-plugins-0.8.5-1.EL.0.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) swig-1.3.21-6.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) autorun-3.14-2.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) kdeaddons-3.3.1-2.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) PyQt-3.13-1.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) kdesdk-3.3.1-2.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) kdevelop-3.1.1-2.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) nmap-3.70-1.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) libstdc++-3.4.6-8.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) aspell-0.50.5-4.EL4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) pilot-link-0.11.8-9.RHEL4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) groff-1.18.1.1-3.EL4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) boost-1.32.0-6.rhel4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) ttmkfdir-3.0.9-20.el4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) libgcj-3.4.6-8.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) xorg-x11-Mesa-libGLU-6.8.2-1.EL.18.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) kdelibs-3.3.1-6.RHEL4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) qt-devel-3.3.3-10.RHEL4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) tetex-2.0.2-22.EL4.7.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) cups-1.1.22-0.rc1.9.20.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) devhelp-0.10-0.8.el4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) oprofile-0.8.1-26.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) vnc-4.0-11.el4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) gnomemeeting-1.0.2-9.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) gpdf-2.8.2-7.4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) vnc-server-4.0-11.el4.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) kdegraphics-3.3.1-3.9.x86_64
libgcc_s.so.1(GCC_3.0)(64bit) is needed by (installed) kdenetwork-3.3.1-2.3.x86_64
libgcc_s.so.1(GCC_3.3)(64bit) is needed by (installed) lftp-3.0.6-3.x86_64
libgcc_s.so.1(GCC_3.3)(64bit) is needed by (installed) wvdial-1.54.0-3.x86_64
libgcc_s.so.1(GCC_3.3)(64bit) is needed by (installed) Omni-0.9.1-7.1.x86_64
libgcc_s.so.1(GCC_3.3)(64bit) is needed by (installed) libstdc++-3.4.6-8.x86_64
libgcc_s.so.1(GCC_3.3)(64bit) is needed by (installed) libgcj-3.4.6-8.x86_64
libgcc_s.so.1(GCC_3.4)(64bit) is needed by (installed) firefox-1.5.0.12-0.1.el4.x86_64
libgcc_s.so.1(GCC_4.2.0)(64bit) is needed by (installed) libstdc++-3.4.6-8.x86_64


What should I do? Is it not possible to install Oracle R2 to RedHat AS-4?
Re: Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #248276 is a reply to message #248060] Thu, 28 June 2007 09:22 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Quote:
Is it not possible to install Oracle R2 to RedHat AS-4?


Yess

Installation guides

http://www.oracle-base.com/articles/10g/Articles10g.php#DB10gRelease2Installations
Re: Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #252531 is a reply to message #247302] Thu, 19 July 2007 02:11 Go to previous messageGo to next message
tanmoy7
Messages: 20
Registered: February 2007
Location: Dhaka, Bangladesh
Junior Member

you can try with the following commands, it may be work

$./runInstaller -ignoreSysPreRequisite
Re: Help installing Oracle 10g Release 2 (10.2) for Linux x86-64 [message #510400 is a reply to message #252531] Sat, 04 June 2011 18:12 Go to previous message
jackomito
Messages: 1
Registered: June 2011
Junior Member
with this link your issue will be fixed

ln -s /usr/X11R6/lib/libXp.so.6 /usr/lib/libXp.so.6
Previous Topic: Forms 11 installation problem on Ubuntu Linux
Next Topic: 11gR2 create database dbca post tasks?
Goto Forum:
  


Current Time: Thu Dec 08 04:09:22 CST 2016

Total time taken to generate the page: 0.20998 seconds