Home » Server Options » Replication » Replication
icon9.gif  Replication [message #247055] Sat, 23 June 2007 04:58 Go to next message
logina
Messages: 11
Registered: June 2007
Location: hyd
Junior Member

hi all,
I am using oracle 10g. i am trying to do MATERIALIZED VIEW replication.
for that i got 3 commands procedure:
i had 2 databases like 1.source (otest), 2.dest (otest1)

On the destination system


CREATE DATABASE LINK to_source_system
CONNECT TO username_on_source_system
IDENTIFIED BY password_on_source_system
USING 'tns_name_for_source_system_on_dest_system';



On the source system


CREATE MATERIALIZED VIEW LOG
ON table_to_replicate
WITH PRIMARY KEY
INCLUDING NEW VALUES;



On the destination system



CREATE MATERIALIZED VIEW table_to_replicate
REFRESH FAST
START WITH sysdate + 5/(24*60)
NEXT sysdate + 5/(24*60)
AS
SELECT * FROM table_to_replicate@to_source_system.

but the 3rd command not working.It is giving error as ORA-12154: TNS:could not resolve the connect identifier specified
. Any help please.
Re: Replication [message #247061 is a reply to message #247055] Sat, 23 June 2007 06:50 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Can you connect TO the source database with SQL*Plus FROM the destination database using the 'tns_name_for_source_system_on_dest_system' you specified in the database link?
Re: Replication [message #247109 is a reply to message #247061] Sun, 24 June 2007 02:47 Go to previous message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
CHECK your service .
Check your listener.
CHECK the ports for listeneing and in service names.
Previous Topic: Simple MV not being used.
Next Topic: Materialized view complete refresh
Goto Forum:
  


Current Time: Tue Sep 30 01:20:10 CDT 2014

Total time taken to generate the page: 0.12181 seconds