Home » SQL & PL/SQL » Client Tools » Error while starting SQLPLUS!!!!!!
Error while starting SQLPLUS!!!!!! [message #246936] Fri, 22 June 2007 09:50 Go to next message
SenthilGugan
Messages: 9
Registered: June 2007
Junior Member
Hi all,
I am very new to the Oracle and SQL. Now I have some problem in starting SQLPlus.
I have successfully installed the Oracle 10g Express edition in my Lniux10.2 suse OS after that I have set the ORACLE_HOME and the PATH environment variables as follows.
exportPATH=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin
export ORACLE_HOME=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server.

Now I was not able to start the SQLPlus from the command editor.
When I login to Oracle, it gives me,

oracle@manickam:/root> sqlplus

SQL*Plus: Release 10.2.0.1.0 - Production on Fri Jun 22 20:13:09 2007

Copyright (c) 1982, 2005, Oracle. All rights reserved.

Enter user-name: system
Enter password:
ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
Linux Error: 2: No such file or directory

Looking forward to your suggestions.
Thanks in advance,
Senthil.
Re: Error while starting SQLPLUS!!!!!! [message #246938 is a reply to message #246936] Fri, 22 June 2007 09:52 Go to previous messageGo to next message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
To what is ORACLE_SID set?
Is the database up & running?

Re: Error while starting SQLPLUS!!!!!! [message #246939 is a reply to message #246938] Fri, 22 June 2007 09:59 Go to previous messageGo to next message
SenthilGugan
Messages: 9
Registered: June 2007
Junior Member
Thanks,
Ya Oracle database is working good.
on ORACLE_SID set: I have no idea on this, but I have set it as, ORACLE_SID=[orcl] ? orcl

Senthil.
Re: Error while starting SQLPLUS!!!!!! [message #246941 is a reply to message #246936] Fri, 22 June 2007 10:10 Go to previous messageGo to next message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
use CUT & PASTE to show results from following command:

ps -ef | grep pmon

Re: Error while starting SQLPLUS!!!!!! [message #246943 is a reply to message #246941] Fri, 22 June 2007 10:17 Go to previous messageGo to next message
SenthilGugan
Messages: 9
Registered: June 2007
Junior Member
manickam:~ # ps -ef | grep pmon
oracle 3252 1 0 15:41 ? 00:00:00 xe_pmon_XE
root 19429 19379 0 20:42 pts/1 00:00:00 grep pmon

as Oracle user:
oracle@manickam:/root> ps -ef | grep pmon
oracle 3252 1 0 15:41 ? 00:00:00 xe_pmon_XE
oracle 19442 19435 0 20:44 pts/1 00:00:00 grep pmon
Re: Error while starting SQLPLUS!!!!!! [message #246945 is a reply to message #246936] Fri, 22 June 2007 10:20 Go to previous messageGo to next message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
Doing the following might get you going running/logged in as user oracle

ORACLE_SID=XE
export ORACLE_SID
sqlplus
/ as sysdba

If not, CUT & PASTE whole session including ALL Oracle responses back here.

[Updated on: Fri, 22 June 2007 10:21] by Moderator

Report message to a moderator

Re: Error while starting SQLPLUS!!!!!! [message #246948 is a reply to message #246945] Fri, 22 June 2007 10:32 Go to previous message
SenthilGugan
Messages: 9
Registered: June 2007
Junior Member
Hi its great.
It is working, now I am able to connect the the database.

Thanks a lot,
Senthil.
Previous Topic: some useful tip about sequences
Next Topic: Matrix out put
Goto Forum:
  


Current Time: Sun Dec 04 23:02:09 CST 2016

Total time taken to generate the page: 0.13840 seconds