Home » RDBMS Server » Server Administration » ASM Disk in Ignored state
ASM Disk in Ignored state [message #246283] Wed, 20 June 2007 08:42 Go to next message
citrowske
Messages: 8
Registered: March 2007
Location: STL
Junior Member
I'll try to make this brief.
Current environment: 2-node RAC on Standard editon, Red Hat 64 version 4.0
Set up new ASM disk groups with Normal Redundancy. One diskgroup had 4 luns from SAN A. The other disk group was made up of 4 LUNS from SAN B.
Got these up and running, no problem. Then we did a test -- we took one SAN and removed the permissions for the SAN from the OS -- the test worked --- the box kept running.
However, after we restored the permissions, each disk in the diskgroup were in a HUNG state.I attempted to remove one of the bad disks "PRIVOL04". It just became a state of "force" in EM. I let it go for about 20 minutes, and then decided to use svrctl to stop all the instances and restart ASM. I did so. Then I issued the following command:
ALTER DISKGROUP DATA ADD FAILGROUP FLGRP1 (the old failgroup name) disk 'ORCL:PRIVOL02' name PRIMVOL02 (note-> different name of disk). It worked. So I did the same for 'ORCL:PRIVOLE03' AND 'ORCL:PRIVOL04'. But when I got to 'PRIVOL01' -- it don't work. Here is the following command and error received:
ALTER DISKGROUP DATA ADD FAILGROUP FLGRP1 DISK 'ORCL:PRIVOL01' NAME PRIMVOL01 SIZE 136403 M FORCE REBALANCE POWER 11
*
ERROR at line 1:
ORA-15032: not all alterations performed
ORA-15020: discovered duplicate ASM disk "PRIVOL01"

I'm stuck. I got the other 3 disks in the primary diskgroup working just fine. But this one won't cooperate. This is the following output of the V$asm_disk:


MOUNT_S ++ MODE_ST ++ STATE ++ NAME---- ++ LABEL--- ++ FAILGROUP ++ PATH
----------------------------------------------------------------------------
IGNORED ++ ONLINE---- ++ NORMAL++ -blank-- ++ PRIVOL01 ++ ----blank---- ++ ORCL:PRIVOL01


I've got a tar open with Oracle, but have been very displeased with the lack of progress. (It's been open since Friday).

I did find the following article, but didn't actually do it yet.
http://www.raleighdba.com/index.asp?ci=9&s=category
It's a gutsy thing to do, and I didn't want to mess up it more than I already have. I was hoping that Oracle support would guide me to the solution, but thus far they haven't done squat.

Any ideas or suggestions would be welcome.
Re: ASM Disk in Ignored state [message #246907 is a reply to message #246283] Fri, 22 June 2007 07:43 Go to previous message
citrowske
Messages: 8
Registered: March 2007
Location: STL
Junior Member
I thought I would follow up with the solution. Oracle support was worthless (available for another topic), so I finally just did the common sense thing and removed the disk using the ./etc/init.d/oracleasm command.

Then I had to log in as root and add the disk back. Then i went to node #2 and logged in as root and used the oracleasm scandisk command. The disk no longer showed up in a state of "ignored" -- it was "normal". So I was able to issue my add my disk back into the disk group without any problems.
Previous Topic: Granting Privileges........
Next Topic: Error while creating spfile from pfile on standby
Goto Forum:
  


Current Time: Thu Dec 08 02:15:41 CST 2016

Total time taken to generate the page: 0.07364 seconds