Home » Developer & Programmer » Forms » Call Report from Forms - sometimes process "hang up"
Call Report from Forms - sometimes process "hang up" [message #245712] Mon, 18 June 2007 10:48 Go to next message
Zenith
Messages: 10
Registered: June 2007
Junior Member
Hello! Sorry for my poor english. I work with Forms4.5 and Reports 2.5
running on WinXp Profess. I call report from forms (destype preview ).
Report works fine, but sometimes when report closes (through button Close or menu[x]) the Reports Server hang up (process in task manager has status "not response") Accordingly Forms hang up too and application dosn't work. Help me please

There is a source code:
List_Param := Create_Parameter_List('params');
Add_Parameter(List_Param,'DESTYPE',TEXT_PARAMETER,'Preview');
Add_Parameter(List_Param,'MODE',TEXT_PARAMETER,'BITMAP');
Add_Parameter(List_Param,'PRINTJOB',TEXT_PARAMETER,'NO');
Add_Parameter(List_Param,'PARAMFORM',TEXT_PARAMETER,'No');

....
/*my parameters here*/
Run_Product(REPORTS, 'rep_name', SYNCHRONOUS, RUNTIME,FILESYSTEM, List_Param);

Thank you for help
Re: Call Report from Forms - sometimes process "hang up" [message #247176 is a reply to message #245712] Mon, 25 June 2007 00:10 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
You need to make sure that the parameter list does not exist befor eyou create it.

Please search this forum or the documentation for 'destroy_paramter_list' and 'run_product'. There are plenty of examples.

David
Re: Call Report from Forms - sometimes process "hang up" [message #247333 is a reply to message #247176] Mon, 25 June 2007 10:44 Go to previous messageGo to next message
Zenith
Messages: 10
Registered: June 2007
Junior Member
Thank you , David.
But i use Destroy_Parameter_List after Run_Product. Sorry, I not wrote this line in my code example .
Re: Call Report from Forms - sometimes process "hang up" [message #252503 is a reply to message #247333] Thu, 19 July 2007 01:04 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

David
Re: Call Report from Forms - sometimes process "hang up" [message #255373 is a reply to message #245712] Tue, 31 July 2007 10:32 Go to previous messageGo to next message
Zenith
Messages: 10
Registered: June 2007
Junior Member
Sorry David.
I not solve this problem, because project suspended ....
Re: Call Report from Forms - sometimes process "hang up" [message #256052 is a reply to message #255373] Thu, 02 August 2007 20:34 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Get back to us if you need any help in the future.

David
Previous Topic: frm - 40202
Next Topic: HOW TO SAVE DATA GENERATED SO I CAN KEEP RE-USING THE SAME DATA TO BE ABLE TO SAVE IT TO FILE
Goto Forum:
  


Current Time: Tue Dec 06 08:09:37 CST 2016

Total time taken to generate the page: 0.17525 seconds