Home » Developer & Programmer » Forms » form is not running from a particular maachine
form is not running from a particular maachine [message #244266] Tue, 12 June 2007 03:41 Go to next message
indrani31
Messages: 7
Registered: May 2007
Location: www
Junior Member

I am not able to call a procedure from 'When new form Instance Trigger' from my machine. while the form is running fine from other machines.can u people please help me
Re: form is not running from a particular maachine [message #244311 is a reply to message #244266] Tue, 12 June 2007 05:31 Go to previous messageGo to next message
Maaher
Messages: 7062
Registered: December 2001
Senior Member
indrani31 wrote on Tue, 12 June 2007 10:41
I am not able to call a procedure from 'When new form Instance Trigger' from my machine. while the form is running fine from other machines.can u people please help me

Version?
Web?
Client/Server?

"not able to call a procedure" --> database stored procedure? A Forms Library?

MHE
Re: form is not running from a particular maachine [message #244559 is a reply to message #244311] Wed, 13 June 2007 06:20 Go to previous messageGo to next message
indrani31
Messages: 7
Registered: May 2007
Location: www
Junior Member

version is oracle9i....9i AS.......and procedure is database stored procedure
Re: form is not running from a particular maachine [message #245032 is a reply to message #244559] Fri, 15 June 2007 00:59 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
How many copies of the database are you using? Ar eyou using the same userid from both PCs?

David
Re: form is not running from a particular maachine [message #245525 is a reply to message #245032] Mon, 18 June 2007 00:40 Go to previous messageGo to next message
indrani31
Messages: 7
Registered: May 2007
Location: www
Junior Member

ya.....we are using same user id from both the machine......then can u please tell me what is the problem.............I need a solution as early as possible.....can u people please help me?
Re: form is not running from a particular maachine [message #245576 is a reply to message #245525] Mon, 18 June 2007 03:01 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please answer the question:
How many copies of the database are you using?

We can only help you if you help us by answering EVERY question we ask.

Do you have the forms executables on the PC or on a network drive?

Davie
Re: form is not running from a particular maachine [message #245623 is a reply to message #245576] Mon, 18 June 2007 04:19 Go to previous messageGo to next message
indrani31
Messages: 7
Registered: May 2007
Location: www
Junior Member

we are using almost 10 copies of the database....and we have forms executable on a network drive...the network is provided by our clients
Re: form is not running from a particular maachine [message #245636 is a reply to message #244266] Mon, 18 June 2007 04:43 Go to previous messageGo to next message
Flyhard
Messages: 21
Registered: April 2007
Location: Germany
Junior Member
Have you double checked, if you are using the same TNSNAMES.ora and SQLNET.ora as the other machines - and the same ConnectString?

Is the FormsServer the same Version on all Machines?

Re: form is not running from a particular maachine [message #245653 is a reply to message #245636] Mon, 18 June 2007 05:38 Go to previous messageGo to next message
indrani31
Messages: 7
Registered: May 2007
Location: www
Junior Member

Ya Flyhard,
I have double checked that I am using the same TNSNAMES.ora and SQLNET.ora as the other machines - and the same ConnectString. And the form server is same version on all the machines.

I can run some forms from my machine and not able to run forms from my machine...The particular types of forms that are not running are the forms which are calling some procedure in the form itself...and the procedure is database procedure....this form is running well from other machines..please help
Re: form is not running from a particular maachine [message #245663 is a reply to message #245653] Mon, 18 June 2007 06:10 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
What happens if you recompile the form on your computer (using <Ctrl + Shift + K> - compile all) and run the form again?
Re: form is not running from a particular maachine [message #245665 is a reply to message #245663] Mon, 18 June 2007 06:19 Go to previous messageGo to next message
indrani31
Messages: 7
Registered: May 2007
Location: www
Junior Member

If I recompile then form is compiled and after that when I run the form the Form server is started...and the form is appeared but the procedures called in that are not started.....I have 10 procedures called from my forms....and starting of each procedure can be viewed from my forms....But this is not working here
Re: form is not running from a particular maachine [message #247174 is a reply to message #245665] Mon, 25 June 2007 00:04 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
In these 10 databases, do they all have all of the procedures? Are these procedures 'valid' in all of the databases? Are the procedures owned by the same 'user' in each of the databases? Are there any specific 'grants' that have to be assigned to the user in each database? If so, has this been done?

Can you use a tool like TOAD to access two instances at the same time and do a database compare to check for differences? If yes, then do a compare and see if there are any differences.

David
Re: form is not running from a particular maachine [message #247902 is a reply to message #244266] Wed, 27 June 2007 08:15 Go to previous message
spider99
Messages: 9
Registered: May 2007
Junior Member
Is the error machine a different operating system to the one where your forms were compiled? For example, if you compiled on XP, you may find that your application does not run on NT. However, if you compile on NT, it should work on NT and XP.

[Updated on: Wed, 27 June 2007 08:17]

Report message to a moderator

Previous Topic: plugins for running oracle forms on solaris
Next Topic: Forms 4,5 - problem with message displaying
Goto Forum:
  


Current Time: Fri Dec 09 11:33:47 CST 2016

Total time taken to generate the page: 0.12287 seconds