Home » Server Options » Data Guard » Automatic database startup issues after SWITCHOVER!
Automatic database startup issues after SWITCHOVER! [message #244137] Mon, 11 June 2007 12:50 Go to next message
ramineniv
Messages: 1
Registered: June 2007
Location: Washington, DC
Junior Member
All,

We are in the process of testing DG SWITCHOVER functionality in our environment. We are using DG CLI (DGMGRL) to perform the switchover. The switchover works fine, except the primary and the physical standby instances doesn't get restarted automatically.

Configuration:- Oracle 10g Release 2
- Solaris 10
- MaxAvailability mode
- Physical Standby setup
- File structures are identical

Do you have any suggestions? Any help is appreciated.

Per 'Data Guard Broker' documentation and recommendation, we have tried using a new service with the following specific names and registered statically with the local listener of each instance:

infovista1_DGMRL.xyz.com
infovista2_DGMRL.xyz.com


Output
Following is the output from DGMGRL:

DGMGRL> show configuration

Configuration
Name: ivdg
Enabled: YES
Protection Mode: MaxAvailability
Fast-Start Failover: DISABLED
Databases:
infovista1 - Physical standby database
infovista2 - Primary database

Current status for "ivdg":
SUCCESS

DGMGRL> switchover to infovista1
Performing switchover NOW, please wait...
Operation requires shutdown of instance "infovista2" on database "infovista2"
Shutting down instance "infovista2"...
ORA-01109: database not open

Database dismounted.
ORACLE instance shut down.
Operation requires shutdown of instance "infovista1" on database "infovista1"
Shutting down instance "infovista1"...
ORA-01109: database not open

Database dismounted.
ORACLE instance shut down.
Operation requires startup of instance "infovista2" on database "infovista2"
Starting instance "infovista2"...
Unable to connect to database
ORA-12514: TNS:listener does not currently know of service requested in connect descriptor

Failed.
You are no longer connected to ORACLE
Please connect again.
Unable to start instance "infovista2"
You must start instance "infovista2" manually
Operation requires startup of instance "infovista1" on database "infovista1"
You must start instance "infovista1" manually
Switchover succeeded, new primary is "infovista1"
Re: Automatic database startup issues after SWITCHOVER! [message #244143 is a reply to message #244137] Mon, 11 June 2007 13:34 Go to previous messageGo to next message
jsingh
Messages: 36
Registered: June 2007
Location: ny
Member
I am sorry i could not help with your process.
But i know you can definitely help me out.
Actually i'm also going to check failover and swithover.
Right know i'm in need of documentation for failover and switchover.
I would really appreciate for your help

Thanks

Jsingh
jagmohan81@gmail.com
Re: Automatic database startup issues after SWITCHOVER! [message #244145 is a reply to message #244143] Mon, 11 June 2007 13:35 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
read this document.
Re: Automatic database startup issues after SWITCHOVER! [message #261474 is a reply to message #244145] Wed, 22 August 2007 13:16 Go to previous messageGo to next message
mlgoins
Messages: 116
Registered: March 2007
Location: Denver, CO
Senior Member

That document sure gets some mileage Cool

I used Data Broker to do a switchover and got the same results (no automatic restart). My "guess" would be that you have to use the Observer (described in the document) in order to have the databases restarted automatically, OR perhaps it's always a manual restart. Either way, the switchover works.

Mike
Re: Automatic database startup issues after SWITCHOVER! [message #261488 is a reply to message #261474] Wed, 22 August 2007 15:14 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Aww Thanks MIke sending comments after 2months Wink

Data Observer automatically bring the machine up.

DGMGRL> show configuration;

Configuration
	Name: broker1
	Enabled: YES
	Protection Mode: MaxAvailability
	Fast-Start Failover: Enabled
	Databases:
		standby - Primary database
		primary - Physical standby database
-	Fast – Start Failover target

Fast-Start Failover 
	Threshold: 30 seconds>>>>>>>>>>>>>>>>>>>>>maximum time after that observer do a switch automatically.
	Observer:  orat
Re: Automatic database startup issues after SWITCHOVER! [message #282797 is a reply to message #244137] Fri, 23 November 2007 08:22 Go to previous messageGo to next message
M.Shakeel Azeem
Messages: 226
Registered: September 2006
Senior Member
Dear DreamzZ

By using ur provided document i m trying to configure dataguard broker
C:\>dgmgrl
DGMGRL for 32-bit Windows: Version 9.2.0.1.0 - Production.

(c) Copyright 2002 Oracle Corporation. All rights reserved.

Welcome to DGMGRL, type "help" for information.
DGMGRL>connect sys/oracle@abc

DGMGRL> create configuration 'broker1' as
> primary database is 'ABC'
> connect identifier is ABC
> ;
Syntax error before or at "database"
DGMGRL>

'ABC' is the service_name in tnsnames at both standby and primary DB and listener is also listening for this

Please suggest!
Re: Automatic database startup issues after SWITCHOVER! [message #283276 is a reply to message #282797] Mon, 26 November 2007 10:22 Go to previous message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Run this command on your Broker server to identify the problem.

DGMGRL>show database 'DB_NAME' statusreport;
Previous Topic: Dataguard automatic failover question
Next Topic: help implementation ORACLE DATA GUARD 10G
Goto Forum:
  


Current Time: Sat Dec 10 09:25:07 CST 2016

Total time taken to generate the page: 0.10151 seconds