Home » Developer & Programmer » JDeveloper, Java & XML » Help with XML output 10g- Closing issue
Help with XML output 10g- Closing issue [message #244105] Mon, 11 June 2007 10:49
marks20101
Messages: 74
Registered: May 2005
Member
CLOSING THIS ISSUE FOR NOW, I HAVE RESOLVED IT.
I’m pulling two columns from the db to populate the Name and InputSource elements.
For simplicity I’m using values from the emp table instead of real data.
The following is the results that are needed;

<SourceGroup Name="TURNER" RolloverType="-1" RolloverSourceGroup="WMENC_SOURCEGROUP_AUTOROLLOVER_TO_NEXT">
<Source Type="WMENC_AUDIO" Scheme="file" InputSource="CLERK"/>
<Source Type="WMENC_SCRIPT" Scheme="userscript"/>
<EncoderProfile id="Multiple bit rates audio (CBR) / Script High"/>
</SourceGroup>

Query I strated with,
set long 132000
SELECT XMLElement("SourceGroup", XMLAttributes(ename AS Name, '-1' as RolloverType, 'WMENC_SOURCEGROUP_AUTOROLLOVER_TO_NEXT' as RolloverSourceGroup),
XMLForest(Job AS "COOL"))
FROM emp;

I can't seem to nest another XMLElement and then another XMLAttribute?

I don’t need the XML forest. As you can see the XML just consist of elements and attributes. But it seems that I can't leave the XMLForest out. How can I achieve the desired XML output?



Thanks,
Mark

[Updated on: Mon, 11 June 2007 12:47]

Report message to a moderator

Previous Topic: JDBC and query as command-line argument
Next Topic: Querying XML
Goto Forum:
  


Current Time: Fri Dec 02 12:41:18 CST 2016

Total time taken to generate the page: 0.22733 seconds