Home » Infrastructure » Unix » error when executing a shell script(which contains oracle express commands) present on remote server
error when executing a shell script(which contains oracle express commands) present on remote server [message #243135] Wed, 06 June 2007 03:59 Go to next message
ssunda6
Messages: 28
Registered: June 2007
Junior Member
Hi All,

My requirement is to execute a shell script present on remote server(say "B") from local unix server("A").

I have to run scripts from Unix server "A". As server "A" does not have Oracle Express s/w installed in it, I am using ssh to login remotely to server 'B' and then executing a shell script which has oracle express commands.

While doing so, I am getting the following error:

Cannot load access provider DLL libsnlr.sl
Can't find access provider DLL


Any inputs on why we are getting this error , will be very helpful.

Regards,
ssunda




Re: error when executing a shell script(which contains oracle express commands) present on remote se [message #243262 is a reply to message #243135] Wed, 06 June 2007 11:23 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Post your script.
Re: error when executing a shell script(which contains oracle express commands) present on remote se [message #243269 is a reply to message #243262] Wed, 06 June 2007 12:07 Go to previous messageGo to next message
andrew again
Messages: 2577
Registered: March 2000
Senior Member
It sounds like a simple environment issue. Add a line similar to ENV|sort > t.txt in to top of the remote script. Compare the output captured when run directly and via ssh. Your environment setup shouldn't rely on your interactive shell environment (say your .profile for KSH) - it should be explicitly set by the script.
Re: error when executing a shell script(which contains oracle express commands) present on remote se [message #243909 is a reply to message #243269] Mon, 11 June 2007 00:04 Go to previous message
ssunda6
Messages: 28
Registered: June 2007
Junior Member

Hi Andrew,

Ya, it is environment issue as you mentioned. I explicitly called the .profile in my remote script and now it is running fine.

Thank you very much,

Regards,
ssunda.
Previous Topic: Shell Script Directory Listing
Next Topic: cut a variable
Goto Forum:
  


Current Time: Tue Dec 06 10:10:02 CST 2016

Total time taken to generate the page: 0.16798 seconds