Home » RDBMS Server » Server Utilities » Import skips table
Import skips table [message #242049] Thu, 31 May 2007 08:50 Go to next message
Messages: 259
Registered: January 2006
Senior Member

I've taken export of one table from schema USER1,using the following parameters,


I'm trying to import the table into another schema USER2 with the following import


But it's not importing table,but it creates index file which is containing DDL for,

1. USER_FAX table
2. Index
3. Enabling constraints

Please see below the import log file,

Export file created by EXPORT:V09.02.00 via conventional path

Warning: the objects were exported by USER1, not by you

import done in US7ASCII character set and AL16UTF16 NCHAR character set
. . skipping table "USER_FAX"

Import terminated successfully without warnings.

My questions are,

1. Why it's skipping table,what i've to do to import this table into USER2 schema?
2. In indexfile created, i don't need DDL statement for Table & remove REM word attached
to each line.What i've to do to achieve this?

Re: Import skips table [message #242121 is a reply to message #242049] Thu, 31 May 2007 13:21 Go to previous messageGo to next message
Messages: 4623
Registered: February 2005
Location: East Coast USA
Senior Member
Because the table already exists, as the default is INGORE=N on imports.
Or you already have an object by the same name.
Re: Import skips table [message #242404 is a reply to message #242049] Fri, 01 June 2007 16:27 Go to previous message
Messages: 9
Registered: April 2007
Junior Member
Hi ganjini,

The problem in your parameters is the parameter indexfile, which instructs the import utility to just write all the information about the to-be-imported table and its indexes to the filename given. This is usually just used to get the create statements (mostly of objects which fail to create), not the indexes or tables themself.
Even if the table already exists in the user2 schema your indexfile-file should have contained the create statement of the table too. Are you sure that your export is okay?

If so, drop the indexfile parameter ... and may be add ignore=y instead to be on the sure side ... and try again.

Good luck

PS: Just for fun, why are your using such an enormous buffer without feedback?
Previous Topic: export error
Next Topic: exporting procedure-in user mode
Goto Forum:

Current Time: Thu Oct 27 04:34:49 CDT 2016

Total time taken to generate the page: 0.10108 seconds