Home » RDBMS Server » Backup & Recovery » RMAN catalog upgrade
RMAN catalog upgrade [message #241647] Wed, 30 May 2007 05:08 Go to next message
LaFilipina
Messages: 46
Registered: May 2007
Location: spain
Member
Hi All,

I have just upgraded our 10.2.0.2 databases to 10.2.0.3. I also perfoemed an RMAN catalog upgrade and I got this message after issuing the upgrade catalog command:

RMAN> upgrade catalog

recovery catalog upgraded to version 10.02.00.03
DBMS_RCVMAN package upgraded to version 10.02.00.02
DBMS_RCVCAT package upgraded to version 10.02.00.02

I am just wondering if this is ok or this result is expected. I am not very familiar with RMAN but since the DBMS_RCVMAN and DBMS_RCVCAT is reported to have a version of 10.02.00.02, different from the recover catalog, I am kind of worried if I am on the right the track.

I hope someone could respond to my question.

Thanks in Advance!
Re: RMAN catalog upgrade [message #241743 is a reply to message #241647] Wed, 30 May 2007 09:30 Go to previous messageGo to next message
Frank Naude
Messages: 4502
Registered: April 1998
Senior Member
Have you started RMAN from the 10.2.0.2 or the 10.2.0.3 binaries? Check if you still have references to your 10.2.0.2 home.
Re: RMAN catalog upgrade [message #241792 is a reply to message #241743] Wed, 30 May 2007 11:29 Go to previous messageGo to next message
LaFilipina
Messages: 46
Registered: May 2007
Location: spain
Member
Thanks for the quick response, Frank Naude,

I started rman from 10.2.0.3 binaries. I checked all my environment variables and all of them are pointing to my 10.2.0.3 binaries and SID if that's what you meant.
Re: RMAN catalog upgrade [message #241795 is a reply to message #241792] Wed, 30 May 2007 11:34 Go to previous messageGo to next message
Frank Naude
Messages: 4502
Registered: April 1998
Senior Member
In that case you should be OK.
Re: RMAN catalog upgrade [message #241818 is a reply to message #241795] Wed, 30 May 2007 12:04 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
Just re run these two packages again.
Re: RMAN catalog upgrade [message #241948 is a reply to message #241795] Thu, 31 May 2007 02:57 Go to previous messageGo to next message
LaFilipina
Messages: 46
Registered: May 2007
Location: spain
Member
Frank Naude wrote on Wed, 30 May 2007 11:34
In that case you should be OK.


Thanks, Frank Naude.

By the way... right before I did the upgrade catalog, I got this messaage the moment I logged in to rman:

connected to recovery catalog database
PL/SQL package RCAT_DEV.DBMS_RCVCAT version 10.02.00.02 in RCVCAT database is not current
PL/SQL package RCAT_DEV.DBMS_RCVMAN version 10.02.00.02 in RCVCAT database is not current

And then I ran the upgrade catalog, exited rman, logged back in again and though the packages mentioned before was reported to have the same version upgraded, I didn't get the same messaage anymore. So perhaps you are right, Frank.

Thanks again Smile
Re: RMAN catalog upgrade [message #241950 is a reply to message #241818] Thu, 31 May 2007 02:58 Go to previous messageGo to next message
LaFilipina
Messages: 46
Registered: May 2007
Location: spain
Member
DreamzZ wrote on Wed, 30 May 2007 12:04
Just re run these two packages again.



Hi Dreamz,

I am not sure what you mean by re-running those packages. I am not even familiar with what those packages are for and when are they being used. How and why would I re-run those packages?
Re: RMAN catalog upgrade [message #242945 is a reply to message #241950] Tue, 05 June 2007 10:17 Go to previous message
LaFilipina
Messages: 46
Registered: May 2007
Location: spain
Member
Hi All,

just an FYI, I ended up creating an SR ticket for this and found out that the upgrade procedure done in rman catalog was not successfull. I was asked to run the script below:

SQL> select comp_name,status,version from dba_registry;

I got this result:

COMP_NAME
--------------------------------------------------------------------------------
STATUS VERSION
----------- ------------------------------
Oracle Database Catalog Views
VALID 10.2.0.3.0

Oracle Database Packages and Types
UPGRADED 10.2.0.3.0

The UPGRADED status is not good.. the correct status after the upgrade should be VALID.. so I was asked to run utlrp.sql again against the database.. after this, the result of the same query above is already a VALID status for both COMP_NAME.

Just thought of posting this as the query above can be helpful to validate the upgrade done on a catalog database.

I hope this can help others.
Previous Topic: database oracle 8.0.5
Next Topic: RMAN-10035 while doing database duplicate
Goto Forum:
  


Current Time: Tue Dec 06 08:53:48 CST 2016

Total time taken to generate the page: 0.09850 seconds