Home » SQL & PL/SQL » SQL & PL/SQL » granting system privs to a role then user but nothing shows up
granting system privs to a role then user but nothing shows up [message #240299] Thu, 24 May 2007 10:14 Go to next message
shaseeb
Messages: 113
Registered: April 2007
Location: Madison, WI
Senior Member
Hi,

I am having a problem. I am granting sys privs to a role, then I grant the role to a user (and all of this succeeds) but when I query the user_sys_privs view for that user nothing shows up. Why could this be?


CTMS@FPRCDEV> connect / as sysdba
Connected.
SYS@FPRCDEV> GRANT CREATE JOB TO CTMSRL01;
GRANT CREATE TYPE TO CTMSRL01;
GRANT CREATE VIEW TO CTMSRL01;
GRANT CREATE TABLE TO CTMSRL01;
GRANT CREATE CLUSTER TO CTMSRL01;
GRANT CREATE LIBRARY TO CTMSRL01;
GRANT CREATE SYNONYM TO CTMSRL01;
GRANT CREATE TRIGGER TO CTMSRL01;
GRANT CREATE OPERATOR TO CTMSRL01;
GRANT CREATE SEQUENCE TO CTMSRL01;
GRANT CREATE DIMENSION TO CTMSRL01;
GRANT CREATE INDEXTYPE TO CTMSRL01;
GRANT CREATE PROCEDURE TO CTMSRL01;
GRANT DROP ANY CONTEXT TO CTMSRL01;
GRANT CREATE ANY CONTEXT TO CTMSRL01;
GRANT CREATE MATERIALIZED VIEW TO CTMSRL01;
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>
Grant succeeded.

SYS@FPRCDEV>

Grant succeeded.

SYS@FPRCDEV>
SYS@FPRCDEV>
SYS@FPRCDEV>
SYS@FPRCDEV>
SYS@FPRCDEV> GRANT ctmsrl01 TO ctms;

Grant succeeded.

SYS@FPRCDEV> connect ctms/ctms
Connected.
CTMS@FPRCDEV> select * from user_sys_privs;

no rows selected
Re: granting system privs to a role then user but nothing shows up [message #240308 is a reply to message #240299] Thu, 24 May 2007 10:28 Go to previous messageGo to next message
DreamzZ
Messages: 1666
Registered: May 2007
Location: Dreamzland
Senior Member
select * from role_sys_privs;
Re: granting system privs to a role then user but nothing shows up [message #240345 is a reply to message #240308] Thu, 24 May 2007 11:49 Go to previous message
shaseeb
Messages: 113
Registered: April 2007
Location: Madison, WI
Senior Member
Thank you.
Previous Topic: Using CONVERT US7ASCII to drop accents
Next Topic: CONNECTIN TO ACUCOBOL VIA ODBC
Goto Forum:
  


Current Time: Fri Dec 09 13:26:53 CST 2016

Total time taken to generate the page: 0.26265 seconds