Home » RDBMS Server » Networking and Gateways » HTTP Server issue
HTTP Server issue [message #239141] Mon, 21 May 2007 09:56 Go to next message
shaseeb
Messages: 113
Registered: April 2007
Location: Madison, WI
Senior Member
Hi all,

I am trying to connect to APEX but I get the cannot find page error. So I did the following:

[oracle@rh-staging network]$ /opt/app/oracle/product/10.2.0/http_1/opmn/bin/opmnctl status
Unable to connect to opmn.
Opmn may not be up.
[oracle@rh-staging network]$ /opt/app/oracle/product/10.2.0/http_1/opmn/bin/opmnctl stopall
opmnctl: opmn is not running
[oracle@rh-staging network]$ /opt/app/oracle/product/10.2.0/http_1/opmn/bin/opmnctl start
opmnctl: opmn started
[oracle@rh-staging network]$ /opt/app/oracle/product/10.2.0/http_1/opmn/bin/opmnctl status

Processes in Instance: standalone
-------------------+--------------------+---------+---------
ias-component | process-type | pid | status 
-------------------+--------------------+---------+---------
HTTP_Server | HTTP_Server | 10576 | Init 
LogLoader | logloaderd | N/A | Down 
dcm-daemon | dcm-daemon | N/A | Down 

[oracle@rh-staging network]$ /opt/app/oracle/product/10.2.0/http_1/opmn/bin/opmnctl startproc ias-component=HTTP_Server
opmnctl: opmn is not running
[oracle@rh-staging network]$ /opt/app/oracle/product/10.2.0/http_1/opmn/bin/opmnctl start
opmnctl: opmn is already running
[oracle@rh-staging network]$ /opt/app/oracle/product/10.2.0/http_1/opmn/bin/opmnctl startproc ias-component=HTTP_Server
opmnctl: starting opmn managed processes...
================================================================================
opmn id=rh-staging.fprc.ophth.wisc.edu:6201
no processes matched this request


What does this error mean? And why is it in the init status?

THanks
Re: HTTP Server issue [message #239327 is a reply to message #239141] Tue, 22 May 2007 01:04 Go to previous messageGo to next message
Frank Naude
Messages: 4502
Registered: April 1998
Senior Member
Inspect the OPMN ad HTTP Server (Apache) logs for possible errors.
Re: HTTP Server issue [message #239603 is a reply to message #239327] Tue, 22 May 2007 13:46 Go to previous messageGo to next message
shaseeb
Messages: 113
Registered: April 2007
Location: Madison, WI
Senior Member
Ok, I have got the HTTP Server up, but I still cannot connect to APEX.

[oracle@rh-staging init.d]$ /opt/app/oracle/product/10.2.0/http_1/opmn/bin/opmnctl status

Processes in Instance: standalone
-------------------+--------------------+---------+---------
ias-component | process-type | pid | status
-------------------+--------------------+---------+---------
HTTP_Server | HTTP_Server | 5045 | Alive
LogLoader | logloaderd | N/A | Down
dcm-daemon | dcm-daemon | N/A | Down


I am trying to examine the logs. Here they are:

[oracle@rh-staging logs]$ more error_log.1179748800
[Mon May 21 08:13:35 2007] [notice] FastCGI: process manager initialized (pid 16904)
[Mon May 21 08:13:36 2007] [notice] Oracle-Application-Server-10g/10.1.2.0.0 Oracle-HTTP-Server configured -- resuming normal operations
[Mon May 21 08:13:36 2007] [notice] Accept mutex: fcntl (Default: sysvsem)
[Mon May 21 08:26:32 2007] [error] [client 172.16.1.25] [ecid: 1179753992:172.16.0.68:19746:0:18,0] File does not exist: /opt/app/oracle/p
roduct/10.2.0/http_1/Apache/Apache/htdocs/pls/htmldb
[Mon May 21 08:26:38 2007] [error] [client 172.16.1.25] [ecid: 1179753998:172.16.0.68:19713:0:10,0] File does not exist: /opt/app/oracle/p
roduct/10.2.0/http_1/Apache/Apache/htdocs/pls/htmldb
[Mon May 21 08:30:24 2007] [error] [client 172.16.1.25] [ecid: 1179754224:172.16.0.68:5941:0:1,0] File does not exist: /opt/app/oracle/pro
duct/10.2.0/http_1/Apache/Apache/htdocs/favicon.ico
[Mon May 21 08:47:18 2007] [error] [client 172.16.1.25] [ecid: 1179755238:172.16.0.68:19688:0:27,0] File does not exist: /opt/app/oracle/p
roduct/10.2.0/http_1/Apache/Apache/htdocs/pls/htmldb/apex
[Mon May 21 14:56:31 2007] [warn] pid file /opt/app/oracle/product/10.2.0/http_1/Apache/Apache/logs/httpd.pid overwritten -- Unclean shutd
own of previous Apache run?
[Mon May 21 14:56:31 2007] [notice] FastCGI: process manager initialized (pid 3721)
[Mon May 21 14:56:32 2007] [notice] Oracle-Application-Server-10g/10.1.2.0.0 Oracle-HTTP-Server configured -- resuming normal operations
[Mon May 21 14:56:32 2007] [notice] Accept mutex: fcntl (Default: sysvsem)
[Mon May 21 14:59:17 2007] [notice] FastCGI: process manager initialized (pid 5049)
[Mon May 21 14:59:18 2007] [notice] Oracle-Application-Server-10g/10.1.2.0.0 Oracle-HTTP-Server configured -- resuming normal operations
[Mon May 21 14:59:18 2007] [notice] Accept mutex: fcntl (Default: sysvsem)
[Mon May 21 14:59:44 2007] [error] [client 172.16.1.25] [ecid: 1179777584:172.16.0.68:5058:0:1,0] File does not exist: /opt/app/oracle/pro
duct/10.2.0/http_1/Apache/Apache/htdocs/pls/htmldb



Re: HTTP Server issue [message #239607 is a reply to message #239141] Tue, 22 May 2007 13:52 Go to previous messageGo to next message
BlackSwan
Messages: 25039
Registered: January 2009
Location: SoCal
Senior Member
> File does not exist: /opt/app/oracle/product/10.2.0/http_1/Apache/Apache/htdocs/pls/htmldb
What happened to this file?

[Updated on: Tue, 22 May 2007 13:52] by Moderator

Report message to a moderator

Re: HTTP Server issue [message #239615 is a reply to message #239607] Tue, 22 May 2007 14:32 Go to previous messageGo to next message
shaseeb
Messages: 113
Registered: April 2007
Location: Madison, WI
Senior Member
I don't know what happenned to the file. It doesn't exist in our dev environment but that is still working
Re: HTTP Server issue [message #239627 is a reply to message #239615] Tue, 22 May 2007 16:33 Go to previous message
shaseeb
Messages: 113
Registered: April 2007
Location: Madison, WI
Senior Member
I got it. I was missing the images folder Mad Once I copied that over everything was fine.

Thanks
Previous Topic: DB Link issue with different versions of Oracle
Next Topic: ORA-01034: ORACLE not available
Goto Forum:
  


Current Time: Tue Dec 06 04:40:58 CST 2016

Total time taken to generate the page: 0.10456 seconds