Home » SQL & PL/SQL » SQL & PL/SQL » client_info is not working (merged)
client_info is not working (merged) [message #238674] Fri, 18 May 2007 23:39 Go to next message
srinivasocp
Messages: 91
Registered: December 2005
Location: INDIA
Member
Hi guys,

select userenv('client_info') from dual;

is not working .It is giving a null value.
But the below statement is working.
select userenv('LANGUAGE') from dual;

Quote:
output:
AMERICAN_AMERICA.WE8ISO8859P1.


Regards
Srini...
Re: CLeint_info is not working. [message #238681 is a reply to message #238674] Sat, 19 May 2007 00:25 Go to previous messageGo to next message
Michel Cadot
Messages: 64121
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
It is perfectly working.
There is nothing in "client_info" if *you*, the client, does not put info in it.
SQL> select userenv('client_info') from dual;
USERENV('CLIENT_INFO')
----------------------------------------------------------


1 row selected.

SQL> exec dbms_application_info.set_client_info('My info')

PL/SQL procedure successfully completed.

SQL> select userenv('client_info') from dual;
USERENV('CLIENT_INFO')
----------------------------------------------------------
My info

1 row selected.

Btw, don't use USERENV, use SYS_CONTEXT.

Regards
Michel
Re: CLeint_info is not working. [message #238685 is a reply to message #238681] Sat, 19 May 2007 00:38 Go to previous message
srinivasocp
Messages: 91
Registered: December 2005
Location: INDIA
Member
Hi Michel,

Thanks a lot for your timely response.

Regards
Srini....
Previous Topic: Month and day that an employee got hired
Next Topic: Can this be achieved without using EXISTS
Goto Forum:
  


Current Time: Wed Dec 07 02:58:55 CST 2016

Total time taken to generate the page: 0.08552 seconds