Home » SQL & PL/SQL » SQL & PL/SQL » ERROR: ORA-01017
ERROR: ORA-01017 [message #236652] Thu, 10 May 2007 09:11 Go to next message
proddy
Messages: 13
Registered: May 2007
Junior Member
I have just installed Oracle Database 10g Enterprise Edition and I have opened up Oracle SQL Plus but when I logon with my username and password it says invalid details. Which login details should be used? It is when I open up Oracle SQL *Plus. A dialogue box appears asking for my User Name:, Password:, and Host String:.

The error is:

ERROR:
ORA-01017: invalid username/password; login denied

Please help a newbie with problems. Thanks in advance.

Proddy
Re: ERROR: ORA-01017 [message #236653 is a reply to message #236652] Thu, 10 May 2007 09:13 Go to previous messageGo to next message
Michel Cadot
Messages: 64101
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Try username SYSTEM and password MANAGER.
Then create your own user.

Regards
Michel
Re: ERROR: ORA-01017 [message #236654 is a reply to message #236653] Thu, 10 May 2007 09:15 Go to previous messageGo to next message
proddy
Messages: 13
Registered: May 2007
Junior Member
Michel Cadot wrote on Thu, 10 May 2007 09:13
Try username SYSTEM and password MANAGER.
Then create your own user.

Regards
Michel



Thanks for the prompt reply. I tried that but still it won't login with the same error being displayed.

It is SQL*Plus: Release 10.2.0.1.0 if that helps anyone.
Re: ERROR: ORA-01017 [message #236657 is a reply to message #236653] Thu, 10 May 2007 10:11 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Try username SYSTEM and password MANAGER.
In 10g. default password "manager" is not supported and also scott default password is tiger but scott account is lock/expire. so whenever you unlock scott username you have to reset scott password.


Whenever we install 10g XP or 10 EE during installation time we have to give password.
given password will be use for "SYS,SYSTEM,SYSMAN" or we can set separate password for above three user.

anyway if you forget your password then connect with sys user like "sql> conn / as sysdba" and reset system or create new user.

Regards
Taj
Re: ERROR: ORA-01017 [message #236680 is a reply to message #236657] Thu, 10 May 2007 11:06 Go to previous messageGo to next message
proddy
Messages: 13
Registered: May 2007
Junior Member
Mohammad Taj wrote on Thu, 10 May 2007 10:11
Try username SYSTEM and password MANAGER.
In 10g. default password "manager" is not supported and also scott default password is tiger but scott account is lock/expire. so whenever you unlock scott username you have to reset scott password.


Whenever we install 10g XP or 10 EE during installation time we have to give password.
given password will be use for "SYS,SYSTEM,SYSMAN" or we can set separate password for above three user.

anyway if you forget your password then connect with sys user like "sql> conn / as sysdba" and reset system or create new user.

Regards
Taj


Ok thanks, managed to create a new user but now having problems with Tomcat config. I want to do XSQL and I've changed the XSQLConfig.xml to my connections but still the local host is not working. Any ideas?
Re: ERROR: ORA-01017 [message #236685 is a reply to message #236657] Thu, 10 May 2007 11:13 Go to previous messageGo to next message
saibal
Messages: 111
Registered: March 2007
Location: India
Senior Member
Absolutely correct. another way would be to log in as SYS if you are logged in as an administrator from the o/s. You can fool SQL*Plus into accepting just about any password.

SQL*Plus: Release 10.1.0.2.0 - Production on Thu May 10 21:39:05 2007

Copyright (c) 1982, 2004, Oracle.  All rights reserved.


Connected to:
Oracle Database 10g Enterprise Edition Release 10.1.0.2.0 - Production
With the Partitioning, OLAP and Data Mining options

system@ORCL-SQL>>conn sys/saibal@orcl as sysdba
Connected.
sys@ORCL-SQL>>conn sys/taj@orcl as sysdba
Connected.
sys@ORCL-SQL>>conn sys/cadot@orcl as sysdba
Connected.
sys@ORCL-SQL>>












Re: ERROR: ORA-01017 [message #236688 is a reply to message #236685] Thu, 10 May 2007 11:16 Go to previous messageGo to next message
Mohammad Taj
Messages: 2412
Registered: September 2006
Location: Dubai, UAE
Senior Member

Hi,
if you are logged in as an administrator from the o/s.

Correct, plus "sqlnet.authentication_services=(NTS)"

Regards
Taj
Re: ERROR: ORA-01017 [message #236690 is a reply to message #236680] Thu, 10 May 2007 11:18 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
proddy wrote on Thu, 10 May 2007 18:06

Ok thanks, managed to create a new user but now having problems with Tomcat config. I want to do XSQL and I've changed the XSQLConfig.xml to my connections but still the local host is not working. Any ideas?

Be more precise. What did you do? Define 'is not working'. What does your configuration look like?
Remember, because you have been working with your problem for a while, you might forget that we don't know what you have been doing, or what you want to achieve.
Re: ERROR: ORA-01017 [message #236692 is a reply to message #236690] Thu, 10 May 2007 11:31 Go to previous messageGo to next message
proddy
Messages: 13
Registered: May 2007
Junior Member
Frank wrote on Thu, 10 May 2007 11:18
proddy wrote on Thu, 10 May 2007 18:06

Ok thanks, managed to create a new user but now having problems with Tomcat config. I want to do XSQL and I've changed the XSQLConfig.xml to my connections but still the local host is not working. Any ideas?

Be more precise. What did you do? Define 'is not working'. What does your configuration look like?
Remember, because you have been working with your problem for a while, you might forget that we don't know what you have been doing, or what you want to achieve.



Ok, I'll try my best to explain as much as I can. I want to be able to view files so I assume I need to create a local host using Tomcat. In the webapps folder I have created my own directory but when I put the URL in Explorer, it don't work.
Re: ERROR: ORA-01017 [message #236695 is a reply to message #236652] Thu, 10 May 2007 11:36 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
>Ok, I'll try my best to explain as much as I can. I want to be able to view files so I assume I need to create a local host using Tomcat. In the webapps folder
>I have created my own directory but when I put the URL in Explorer, it don't work.
Thanks for this explanation, but what does any of what you explained have to do with Oracle?
Re: ERROR: ORA-01017 [message #236699 is a reply to message #236695] Thu, 10 May 2007 11:47 Go to previous messageGo to next message
proddy
Messages: 13
Registered: May 2007
Junior Member
anacedent wrote on Thu, 10 May 2007 11:36
>Ok, I'll try my best to explain as much as I can. I want to be able to view files so I assume I need to create a local host using Tomcat. In the webapps folder
>I have created my own directory but when I put the URL in Explorer, it don't work.
Thanks for this explanation, but what does any of what you explained have to do with Oracle?


I am trying to do XSQL with Oracle and Tomcat.
Re: ERROR: ORA-01017 [message #236701 is a reply to message #236652] Thu, 10 May 2007 11:48 Go to previous messageGo to next message
proddy
Messages: 13
Registered: May 2007
Junior Member
I am a newbie, no need to be too hard on me?
Re: ERROR: ORA-01017 [message #236702 is a reply to message #236695] Thu, 10 May 2007 11:57 Go to previous messageGo to next message
proddy
Messages: 13
Registered: May 2007
Junior Member
anacedent wrote on Thu, 10 May 2007 11:36
>Ok, I'll try my best to explain as much as I can. I want to be able to view files so I assume I need to create a local host using Tomcat. In the webapps folder
>I have created my own directory but when I put the URL in Explorer, it don't work.
Thanks for this explanation, but what does any of what you explained have to do with Oracle?


The error was caused by Oracle but now it is sorted. Now I am configuring something else. Sorry, I should have explained better.

[Updated on: Thu, 10 May 2007 12:12]

Report message to a moderator

Re: ERROR: ORA-01017 [message #236725 is a reply to message #236652] Thu, 10 May 2007 13:13 Go to previous messageGo to next message
proddy
Messages: 13
Registered: May 2007
Junior Member
So is anyone able to assist me in configuring Tomcat with Oracle?
Re: ERROR: ORA-01017 [message #236816 is a reply to message #236725] Fri, 11 May 2007 01:30 Go to previous message
Frank
Messages: 7880
Registered: March 2000
Senior Member
If you configured Tomcat (you still didn't tell what you did, no config file, no explanation of "it don't work"), but you cannot get a webpage, this is no longer Oracle related.
You will probably have more luck in a Tomcat forum.
Previous Topic: Need help on ALL/DBA_DEPENDENCIES
Next Topic: Data stored in DB is not in the same order as they were inserted
Goto Forum:
  


Current Time: Fri Dec 02 13:52:20 CST 2016

Total time taken to generate the page: 0.08575 seconds