Home » Developer & Programmer » Forms » Forms Version
Forms Version [message #236649] Thu, 10 May 2007 08:52 Go to next message
khel51
Messages: 3
Registered: May 2007
Location: Birmingham_England
Junior Member
Hi

How do I find out the Version of Oracle Forms that a particular Form was originally written in. If I go to 'Help' -> 'About Form Builder', this will tell me the Version Of Oracle Forms that I am using and NOT the version that the Form was written in.

Thanks.

Jim.

Re: Forms Version [message #236818 is a reply to message #236649] Fri, 11 May 2007 01:37 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
You could try opening it with Forms Builder and see what message it displays.

David
Re: Forms Version [message #236868 is a reply to message #236818] Fri, 11 May 2007 03:21 Go to previous messageGo to next message
khel51
Messages: 3
Registered: May 2007
Location: Birmingham_England
Junior Member
Hi David

Thanks for your reply.
The Form appears to load in Forms Builder (9i and 10g) without any errors or messages, but when I try and run it, I get problems.

If I load and run it in Oracle 9i, I get the error
FRM-92160 - WEB Client Version Too Old.

I looked this up on the Internet. Unfortunately I didn't really understand it. It was asking to check the set up and jar files, ORACLE_HOME/bin, CODEBASE entries etc. I tried a few things but it didn't work, the DBA said that the PC needs rebuilding!

If I load and run it in Oracle 10g, it just crashes and takes me completely out of Oracle Forms, (It shuts down the Form).

I am now waiting for the DBA to rebuild the PC with 9i.

I do have the executables on a server and they run okay.
Is there any way of knowing which version of Forms an executable was complied from instead?

I love supporting systems with NO documentation!

Thanks for your help

Jim.
Re: Forms Version [message #237267 is a reply to message #236868] Mon, 14 May 2007 00:43 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Ah yes, the joy of no documentation.

I had a look at a few 'fmx' files from different versions and I couldn't see any 'marker'. I think there is a marker.

I did a search and found this obvious text.
Quote:
"FRM-99999: WEB Client Version too old."
Description The version of the Client is older than the version of the Server.

Sounds like you are trying to run 6i code against a 9i Application Server.

Did you recompile and regenerate your form before trying to run it? I suggest bringing a copy of all the forms into your 9i Forms directory, compiling the libraries and menues, then the forms, and then trying to run the system. Do likewise for 10g but obviously into the 10g development library.

Tell us how you get on with your problem.

David
Re: Forms Version [message #237460 is a reply to message #237267] Mon, 14 May 2007 10:07 Go to previous message
khel51
Messages: 3
Registered: May 2007
Location: Birmingham_England
Junior Member
Thanks for that

I tried to open some ‘.fmt’ files and some refer to F50 (Forms 5) and some refer to FRM45_OBJECT (Forms 4.5) I suspect !!

I had tried what you suggested previous but it didn’t work. I think that the main problem is that there are two different version of Oracle on my PC and this is causing confusion.

At present the DBA is rebuilding a PC with JUST Forms 9i. I have forwarded your email to him and I working with him to see if we can resolve the problem.

I will keep you informed.

Thanks for all your help.

Jim.
Previous Topic: Using Webutil to export data to Excel
Next Topic: Inconsistent datatype
Goto Forum:
  


Current Time: Sat Dec 10 03:33:36 CST 2016

Total time taken to generate the page: 0.08600 seconds